Switching between tab groups takes up to half a minute the first time

RESOLVED WONTFIX

Status

Firefox Graveyard
Panorama
RESOLVED WONTFIX
5 years ago
a year ago

People

(Reporter: aleth, Unassigned)

Tracking

16 Branch
x86
Linux

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:16.0) Gecko/20120815 Firefox/16.0
Build ID: 20120815042007

Steps to reproduce:

~80 tabs open in 4 tab groups.
One group active on startup.



Actual results:

Switching between tabs within the same tab group via Panorama is reasonably fast, though not snappy (the zoom animation is not smooth and the switch is not immediate).

But when switching to a tab in a different tab group, the zoom-in animation actually freezes half-way for many seconds (up to half a minute at times). 

Once the new tab group has been switched to at least once, there is no difference between switching tabs within these groups and between them.
(Reporter)

Updated

5 years ago
Component: Untriaged → Panorama
Panorama has been removed from Firefox 45, currently in Beta and scheduled for release on March 7th. As such, I'm closing all existing Panorama bugs.

If you are still using Panorama, you will see a deprecation message in Firefox 44, and when 45 is released your tab group data will be migrated to bookmarks, with a folder for each group. There are also a few addons offering similar functionality.

See https://support.mozilla.org/en-US/kb/tab-groups-removal for more info.

We're removing Panorama because it has extremely low usage (about 0.01% of users), and has a large number of bugs and usability issues. The cost of fixing all those issues is far too high to justify, and so we'll instead be focusing our time and energy on improving other parts of Firefox.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

a year ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.