Last Comment Bug 783373 - Change mobile-specific Google search URL to standard Google search URL
: Change mobile-specific Google search URL to standard Google search URL
Status: VERIFIED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: -- normal (vote)
: Firefox 17
Assigned To: Brian Nicholson (:bnicholson)
:
: Sebastian Kaspari (:sebastian)
Mentors:
: 776007 (view as bug list)
Depends on:
Blocks: 776007
  Show dependency treegraph
 
Reported: 2012-08-16 14:02 PDT by Brian Nicholson (:bnicholson)
Modified: 2016-07-29 14:29 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
verified
verified
verified
verified


Attachments
Use standard Google search URL (3.74 KB, patch)
2012-08-16 14:02 PDT, Brian Nicholson (:bnicholson)
mark.finkle: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
lukasblakk+bugs: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description Brian Nicholson (:bnicholson) 2012-08-16 14:02:14 PDT
Created attachment 652558 [details] [diff] [review]
Use standard Google search URL

Google's recent UA changes have made forcing the mobile-specific search unnecessary. We should be able to use the standard query URL.
Comment 1 Mark Finkle (:mfinkle) (use needinfo?) 2012-08-16 19:52:22 PDT
Comment on attachment 652558 [details] [diff] [review]
Use standard Google search URL

UX might want this uplifted as far as reasonable
Comment 2 Brian Nicholson (:bnicholson) 2012-08-17 08:06:39 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/83f6e76262be
Comment 3 Brian Nicholson (:bnicholson) 2012-08-17 08:09:40 PDT
Comment on attachment 652558 [details] [diff] [review]
Use standard Google search URL

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: Google mobile search is forced, meaning Request Desktop site option won't be honored for searches
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): medium-low risk - everything should be fine on our end, but there's always a chance Google could change something to break it again
String or UUID changes made by this patch: none
Comment 4 Lukas Blakk [:lsblakk] use ?needinfo 2012-08-17 10:25:37 PDT
Comment on attachment 652558 [details] [diff] [review]
Use standard Google search URL

Approving, if there are changes on google's end we'll have to do outreach but changing our code here makes sense for uplift.
Comment 5 Ryan VanderMeulen [:RyanVM] 2012-08-17 19:23:22 PDT
https://hg.mozilla.org/mozilla-central/rev/83f6e76262be
Comment 6 Brian Nicholson (:bnicholson) 2012-08-20 10:33:16 PDT
http://hg.mozilla.org/releases/mozilla-beta/rev/1b1c3270c679
Comment 7 Brian Nicholson (:bnicholson) 2012-08-20 10:34:51 PDT
http://hg.mozilla.org/releases/mozilla-aurora/rev/bbdbc7a0c457
Comment 8 Axel Hecht [:Pike] 2012-08-22 03:06:30 PDT
What testing did this change get outside the US? There's at least bug 757979 that deals with the difference in experience in Japan for the previous iteration.
Comment 9 Brian Nicholson (:bnicholson) 2012-08-22 09:12:23 PDT
(In reply to Axel Hecht [:Pike] from comment #8)
> What testing did this change get outside the US? There's at least bug 757979
> that deals with the difference in experience in Japan for the previous
> iteration.

The search engine XML files are localization-dependent; this patch is only for /mobile/locales/en-US/searchplugins/google.xml.
Comment 10 Brian Nicholson (:bnicholson) 2012-08-22 09:20:47 PDT
(In reply to Brian Nicholson (:bnicholson) from comment #9)
> The search engine XML files are localization-dependent; this patch is only
> for /mobile/locales/en-US/searchplugins/google.xml.

After reading bug 757979, it looks like Japan (and other locales) were just using the English google.xml. https://bugzilla.mozilla.org/show_bug.cgi?id=757979#c25 sounds like the current implementation will be changed to use a single XML for all localizations, but that doesn't appear to be implemented yet.

I assumed different locales would just have their own XML files, meaning this change wouldn't affect them, but that doesn't appear to be the case. AFAIK, there wasn't any testing done for other languages for this patch.
Comment 11 Mark Finkle (:mfinkle) (use needinfo?) 2012-09-05 13:40:37 PDT
*** Bug 776007 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.