The default bug view has changed. See this FAQ.

Image discarding not always working correctly on OSX and Linux

RESOLVED FIXED in mozilla17

Status

()

Core
ImageLib
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: mccr8, Assigned: khuey)

Tracking

({regression})

unspecified
mozilla17
regression
Points:
---

Firefox Tracking Flags

(firefox17-)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
I've only noticed this recently, in the last few days.  It maybe due to bug 683290.

When you have Zimbra in a background tab for a while, then switch back, many of the images don't show up.  The regular folder icon on the left side shows up, but the icons for "sent" "drafts" "junk", and the various icons on the main toolbar across the middle (new, get mail, delete, etc.) don't show up. Interacting with the page a little brings it back to some extent.
(Reporter)

Comment 1

5 years ago
Okay, it does show the icon for "sent", "new" and "translate".
(Reporter)

Comment 2

5 years ago
Similar problem on Pandora. There's a cloud image in the background that isn't displayed if you flip to another tab for a while, then switch back.
Summary: Zimbra doesn't show icons when it sits in a background tab for a while → Zimbra and Pandora don't show images when they sit in a background tab for a while
(Reporter)

Comment 3

5 years ago
On Pandora, image is reshown when you scroll up and down.
Blocks: 683290
(Reporter)

Updated

5 years ago
Keywords: regression
(Reporter)

Comment 4

5 years ago
When I load dslreports.com, the images for the main toolbar (home, reviews, tools, forums, etc.) are not immediately displayed.  Switching to another tab and back does show them, as does reloading.  Doing a hard reload (command-shift-R on OSX) and they disappear again until I switch to another tab.

Also, I tried an 8/14 nightly at Kyle's request, and it did not show the symptoms in Comment 0-2.
OS: All → Mac OS X
(Reporter)

Comment 5

5 years ago
https://odesk.com/ doesn't show the background image (a bunch of people) on initial load.

Comment 6

5 years ago
I and brson are seeing this on Linux as well. Started over the last few days.
OS: Mac OS X → All
(Reporter)

Comment 7

5 years ago
odesk.com is working for me now, so maybe it was just site slowness.
Duplicate of this bug: 784068
(Reporter)

Comment 9

5 years ago
Alice's regression range in bug 784068 points at khuey's patch.
Summary: Zimbra and Pandora don't show images when they sit in a background tab for a while → Image discarding not always working correctly on OSX and Linux

Updated

5 years ago
tracking-firefox17: --- → ?
(In reply to Andrew McCreight [:mccr8] from comment #7)
> odesk.com is working for me now, so maybe it was just site slowness.

Still present for me in zimbra.
Bisecting the range from dupe bug 784068 comment 5, the first bad revision is

102329:5c730c1f2274

changeset:   102329:5c730c1f2274
user:        Kyle Huey <khuey@kylehuey.com>
date:        Mon Aug 13 15:04:19 2012 -0700
summary:     Bug 697230: Part 1 - Centralize style image observers. r=bz

(Same as causes the permaorange in bug 651866.)

Bisecting methodology: Open zimbra, browse to another tab, wait 1.5 minutes, go back. In the bad case most of the images vanished and only reappear on clicking on the page.
Created attachment 653585 [details] [diff] [review]
Patch

There is an optimization to avoid invalidating frames before the first paint (since there is no existing data that is now invalid).  The way we listen for paints is flawed, and sometimes we don't realize that a paint has occurred and fail to invalidate when we should.  roc thinks this optimization is probably unnecessary, since invalidating these frames should be cheap.  This patch removes that optimization.
Assignee: nobody → khuey
Status: NEW → ASSIGNED
Attachment #653585 - Flags: review?(roc)
Attachment #653585 - Flags: review?(roc) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/657b3f3a616b
Duplicate of this bug: 783355
tracking-firefox17: ? → -
https://hg.mozilla.org/mozilla-central/rev/657b3f3a616b
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla17

Updated

5 years ago
Duplicate of this bug: 784068
Duplicate of this bug: 783126
You need to log in before you can comment on or make changes to this bug.