Launching a web application on Nightly shows a window with no title and white content

VERIFIED FIXED in Firefox 17

Status

Firefox Graveyard
Web Apps
VERIFIED FIXED
5 years ago
2 years ago

People

(Reporter: jsmith, Assigned: myk)

Tracking

({regression})

17 Branch
Firefox 17
regression

Details

(Whiteboard: [qa!])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Steps:

1. Go to apps.mozillalabs.com/appdir
2. Install a web application
2. Launch the web application

Expected:

The application should launch with no errors.

Actual:

The application window launches, but the title does not appear. A whitebox is seen in the window instead.
(Reporter)

Updated

5 years ago
Summary: Cannot launch a web application on FF Nightly → Launching a web application on Nightly shows a window with no title and white content
(Reporter)

Updated

5 years ago
Keywords: regression
(Reporter)

Updated

5 years ago
status-firefox16: --- → unaffected
status-firefox17: --- → affected
(Reporter)

Comment 1

5 years ago
Also reproduce on Ubuntu 12, so this likely OS independent. Getting a regression range now.
OS: Windows 7 → All
Hardware: x86_64 → All
(Reporter)

Comment 2

5 years ago
Firefox Web Apps Regression Range

- 8/1/2012 Windows 7 - Working
- 8/10/2012 Windows 7 - Working
- 8/15/2012 Windows 7 - Working
- 8/16/2012 Windows 7 - Busted
- 8/17/2012 Windows 7 - Busted
- 8/17/2012 Ubuntu 12 - Busted

Getting a changelog shortly.
(Reporter)

Comment 3

5 years ago
http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2012-08-15&enddate=2012-08-16
(Reporter)

Comment 4

5 years ago
Broken changeset: http://hg.mozilla.org/mozilla-central/rev/07b53bdc212a

Bug likely to cause this - bug 770770.
(Reporter)

Updated

5 years ago
Blocks: 770770
(Assignee)

Updated

5 years ago
Assignee: nobody → myk
Status: NEW → ASSIGNED
Target Milestone: --- → Firefox 17
(Assignee)

Comment 5

5 years ago
Created attachment 653086 [details] [diff] [review]
patch v1: obvious, trivial fix

Apps still work on my debug build, which explains why I didn't see the problem while testing the fix for bug 770770.

This is a packaging bug: bug 770770 added a module but neglected to add it to the installer manifest, so it doesn't get packaged and isn't found when imported by webapp.js during startup.

Here's the obvious, trivial, one-line fix.

Requesting review from either Drew or Felipe, on the off-chance one of them is watching his bugmail this weekend, so we can land this sooner than later.
Attachment #653086 - Flags: review?(felipc)
Attachment #653086 - Flags: review?(adw)
Attachment #653086 - Flags: review?(felipc)
Attachment #653086 - Flags: review?(adw)
Attachment #653086 - Flags: review+
(Reporter)

Updated

5 years ago
Keywords: checkin-needed
(Assignee)

Comment 6

5 years ago
Comment on attachment 653086 [details] [diff] [review]
patch v1: obvious, trivial fix

https://hg.mozilla.org/integration/mozilla-inbound/rev/9fd67bb245e3
Attachment #653086 - Flags: checkin+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
Shouldn't we package webapprt/modules/*, like we do for modules/*? would avoid this problem in the future...
https://hg.mozilla.org/mozilla-central/rev/9fd67bb245e3
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Updated

5 years ago
Whiteboard: [qa+]
(Assignee)

Comment 9

5 years ago
(In reply to :Gavin Sharp (use gavin@gavinsharp.com for email) from comment #7)
> Shouldn't we package webapprt/modules/*, like we do for modules/*? would
> avoid this problem in the future...

One version of the patch in bug 725408 used a webapprt/* wildcard to package all files in that directory, but in bug 725408, comment 53, bsmedberg expressed a preference for listing each file.

And doing so turned out to be useful for this patch, which builds mochitest.xul and mochitest.js (for use during testing) but does not package them.

Nevertheless, perhaps the considerations are different for a module-specific wildcard (webapprt/modules/*).  cc:ing bsmedberg for his thoughts.
Note that we already package dist/bin/modules/* that way:
http://mxr.mozilla.org/mozilla-central/source/browser/installer/package-manifest.in#494

Updated

5 years ago
status-firefox17: affected → fixed
Yeah, dist/bin/webapprt/* is different than dist/bin/webapprt/modules/*. With the latter, it's less likely that you'll accidentally package an unwanted file.
I filed bug 784209 for that.
(Reporter)

Updated

5 years ago
Status: RESOLVED → VERIFIED
status-firefox17: fixed → verified
(Reporter)

Updated

5 years ago
Whiteboard: [qa+] → [qa!]
(Reporter)

Updated

5 years ago
Duplicate of this bug: 783911
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.