Closed Bug 783845 Opened 8 years ago Closed 7 years ago

detached khmer vowels fail to render properly on firefox android (missing the dotted oval shape)

Categories

(Firefox for Android :: General, defect)

17 Branch
All
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
firefox17 --- affected

People

(Reporter: nirvn.asia, Unassigned)

References

Details

Attachments

(3 files)

Thanks to the splendid of Behdad, harfbuzz now supports Khmer, and so does the latest Firefox Android Nightlies.

I did spot a pretty serious issue with the Khmer rendering support though. That is, "detached" khmer vowels (i.e. a vowel that is not preceded by a consonant) fails to render properly. It's missing a dotted oval shape that is drawn as a replacement to the absent consonant.

It's a pretty big issue as wrongly entered text (such as consonant + zero-width space + vowel) will look like it's rendered properly but will no be under all the existent khmer script unicode renderers (including firefox on all platforms other than Android). This problem is example #1 in the test case [url: http://licadho-cambodia.org/play/harfbuzz.html].

This issue also messes up rendering of detached vowels with glyphs placements defined both before and after the consonant. This problem is example #2 and #3 in the test case [url: http://licadho-cambodia.org/play/harfbuzz.html].

This bug filing also includes screenshot of firefox android vs android stock browser rendering of the attached test case, as well as a real-life application (khmer keyboard).
Note: the problem was confirmed as still being present after the latest harfbuzz merge which occured earlier today (bug 782908).

I've added Behdad to the CC list, hope it was ok to do so :)
Just realized the absence of the dotted oval (substituting the missing consonant) is also causing khmer "legs" to not render at all. The additional screenshot captures this issue in example #4.
Mathieu, thanks for the detailed bug report. The screenshots are a big help.

blassey, who would be an appropriate dev assignee for HarfBuzz rendering/layout bugs?
Version: Trunk → Firefox 17
Chris, no problem, hope this can help.

FYI, I've also filed this bug in freedesktop's bugzilla database: https://bugs.freedesktop.org/show_bug.cgi?id=53693
(In reply to Chris Peterson (:cpeterson) from comment #6)
Jonathan Kew. He is CC'ed on the bug and is good about responding to bug comments.
We'll add dotted-circle support to HarfBuzz soon (next few weeks).
Chris, could you change the status to confirmed?

FYI, harfbuzz 0.9.4 was finalized two days ago, which fixes the missing dotted-circle feature for indic scripts, such as Khmer. Would be nice for firefox to synch its harfbuzz library to this latest version.
Is there a bug for updating harfbuzz?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Depends on: 789687
Filed bug 789687 on taking a fresh harfbuzz update. (I filed it as a separate bug because it's a general update, not just a Khmer-focused fix.) When we do that, it should "magically" resolve this issue, I believe.
Jonathan, you can mark this bug as RESOLVED > FIXED (I would but can't). Confirmed that dotted-circles are showing on Firefox Android using latest thinderbox build. Cheers.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → INVALID
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Marking FIXED, as a result of bug 789687.
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.