Render standalone images against a black background instead of dark gray to lower browser power consumption

VERIFIED WONTFIX

Status

()

Core
Layout
--
enhancement
VERIFIED WONTFIX
6 years ago
6 months ago

People

(Reporter: Virtual, Unassigned)

Tracking

({feature, nightly-community})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Bug #754133 (Set background of standalone images (the image itself, not the whole page) to white) and Bug #756419 (White standalone image background flashes into view when switching tabs) landed,
so there aren't any more obstacles to render standalone images against a black background, instead of dark gray background [ Bug #376997 (Render standalone images against a dark gray background)].

With this change we will win more in browser power consumption image tests.
>With this change we will win more in browser power consumption image tests.

Is there any actual measurement backing that up? As far as I know normal LCD's use more power to display a black screen instead of a white one, unless they're advanced LED displays with local dimming capability.

Then there's a point that viewing a standalone image isn't a typical use-case. I'd even say it's a very uncommon one.

For me this is WONTFIX or even INVALID unless there's data supporting your claim.
Here's one test:
http://techlogg.com/2010/05/black-vs-white-screen-power-consumption-24-more-monitors-tested/17

and I've seen other backing that up (that black draws MORE power on most
monitors today (backlit LCD)).  (note also that the test measures the
black/white difference, the dark-grey/black difference would be smaller)

I agree with gcp - it's a very rare use case so even on monitors that
does use less power for black it'll be insignificant overall.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
If we're talking only about TN LCD technology you're partially correct, because LCDs can't show true black, so pixels always 'working'.

But in not true when we look on outdated CRT [still used in about 25-10% PC looking on Steam hardware survey and iSuppli data] and new LED [OLED & AMOLED] and Plasma and LED-backlit LCD or even LCDs based on MVA, IPS, AFFS and PLS (not sure only about ASV and PVA).
Newer types of LCD include a dynamic dimming capability that changes the strength of the backlight based on the image being displayed. Also many of the new monitor technologies such as LCDs backlit with light-emitting diodes, plasma screens and organic LED screens do not have a constant backlight.


Test on mobiles:
http://blog.stevemould.com/phone-battery-save-black-wallpaper/

Apple stated that PowerBooks in 'black mode' use less energy than in 'white mode':
http://support.apple.com/kb/TA47608

Other 'new' test showing black use less energy than white in Blaclke vs Google and full screen black vs full screen white:
http://www.pcstats.com/articleview.cfm?articleid=2649

IPS LCD use less energy in black than in white compared to TN LCD
http://techlogg.com/2010/05/black-vs-white-screen-power-consumption-24-more-monitors-tested/17

Comparison of LCD, edge lit LED and LED:
http://i.imgur.com/hOIyx.jpg

Average power consumption LCD vs LED
http://i302.photobucket.com/albums/nn108/bemymonkey/power.png

Some nice discussion about it:
http://tech.slashdot.org/story/12/04/19/2026252/power-saving-web-pages-real-or-myth


Next pros can be also reducing eye strain and fatigue.
http://www.ncbi.nlm.nih.gov/pubmed/2793458
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
I don't think anyone is arguing that there aren't cases where a monitor will use less power in black than in white (local dimming LED was already specifically pointed out as one). The problem is that for this to make any sense at all:

1) Firefox would have to know the exact monitor it's running on, not even just the type or display class(!), and have a database that tells it the correct behavior on those monitor models.
2) There must be a substantial amount of time where you're in the situation of looking at a standalone image *where the background is covering most of the visible screen*. (It's questionable this is true on desktop, and it's even worse on phones due to smaller resolutions which makes images fill the screen)
3) The difference between dark grey and black multiplied by (2) actually makes a difference in the end.

As I said, unless you can provide data that "we will win more in browser power consumption image tests", this bug makes no sense and sounds like a waste of resources that would be better spent elsewhere. Your links fall far short of achieving that, because of the above, and well, some of them don't even really support the base claim:

>Apple stated that PowerBooks in 'black mode' use less energy than in 'white 
>mode': http://support.apple.com/kb/TA47608

Note it's a difference of 0.8% for an entire white vs an entire black screen. Just to give some idea of magnitude!

>IPS LCD use less energy in black than in white compared to TN LCD

LG, which is the biggest manufacturer of IPS panels, claims an advantage of IPS is that you can watch normal webpages without the increased power that (AM)OLED has on white pages, and that IPS usage is essentially constant. (Your link about OLED claims the same)
http://mobileraptor.blogspot.be/2012/04/ips-versus-oled-power-consumption-and.html

>Next pros can be also reducing eye strain and fatigue.

The study isn't even related to the topic.

A realistic version of this is perhaps "use a darker default theme in Firefox for Android on AM(OLED) based phones", combined with setting the the black version of Google there that *might* just cause enough savings to actually make a difference in real use, though it sounds like the kind of thing that should be in an add-on.

But just blindly setting it from grey to black everywhere? No reason to believe that's going to do any good.
I don't think switching from dark-grey to black for standalone image
backgrounds would make much difference overall, even on panels where
it use less power. (and it can probably be done as a theme or add-on)

For "use a darker default theme in Firefox for Android on AM(OLED)
based phones" - if you think it's worth pursuing this, I suggest
discussing it in mozilla.dev.platforms.mobile first, and file a new
bug when there is consensus.  Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → WONTFIX
Status: RESOLVED → VERIFIED
Has Regression Range: --- → irrelevant
Has STR: --- → irrelevant
Keywords: feature
You need to log in before you can comment on or make changes to this bug.