Last Comment Bug 783912 - [ARMv6] Use more conservative GC settings for ARMv6
: [ARMv6] Use more conservative GC settings for ARMv6
Status: RESOLVED FIXED
[ARMv6]
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: 16 Branch
: x86_64 Linux
: -- normal (vote)
: Firefox 17
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 995165
Blocks: 256meg
  Show dependency treegraph
 
Reported: 2012-08-19 14:02 PDT by Mark Finkle (:mfinkle) (use needinfo?)
Modified: 2014-04-11 08:55 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
patch (1.55 KB, patch)
2012-08-19 14:02 PDT, Mark Finkle (:mfinkle) (use needinfo?)
blassey.bugs: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
Details | Diff | Review

Description Mark Finkle (:mfinkle) (use needinfo?) 2012-08-19 14:02:55 PDT
Created attachment 653203 [details] [diff] [review]
patch

Since ARNv6 devices are likely to have less available memory, we should use more conservative GC settings. Bug 782694 provides settings used by b2g for 128MB devices. Fennec on ARMv6 is looking to support devices with as little as 256MB RAM.

Gregor: Should we tweak the values for higher memory devices too? Most "high-end" Android devices are still in the 512MB-1GB RAM range.
Comment 1 Brad Lassey [:blassey] (use needinfo?) 2012-08-19 20:45:15 PDT
Comment on attachment 653203 [details] [diff] [review]
patch

Review of attachment 653203 [details] [diff] [review]:
-----------------------------------------------------------------

It would be better if we could tune these dynamically at runtime. Can you file a bug for that as a follow up?
Comment 2 Mark Finkle (:mfinkle) (use needinfo?) 2012-08-19 21:21:52 PDT
> It would be better if we could tune these dynamically at runtime. Can you
> file a bug for that as a follow up?

Filed bug 783943

http://hg.mozilla.org/integration/mozilla-inbound/rev/a2535133b802
Comment 3 Ed Morley [:emorley] 2012-08-20 08:54:45 PDT
https://hg.mozilla.org/mozilla-central/rev/a2535133b802
Comment 4 Mark Finkle (:mfinkle) (use needinfo?) 2012-08-21 22:15:26 PDT
Comment on attachment 653203 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: more OOM on armv6 builds
Testing completed (on m-c, etc.): a few nights
Risk to taking this patch (and alternatives if risky): low, we are only lowering armv6 settings
String or UUID changes made by this patch: none

I did not request beta approval since we are only targeting higher end armv6 phones for Fx15
Comment 5 Mark Finkle (:mfinkle) (use needinfo?) 2012-08-22 23:16:15 PDT
http://hg.mozilla.org/releases/mozilla-aurora/rev/433dd8914307

Note You need to log in before you can comment on or make changes to this bug.