Bug 792131 (256meg)

[ARMv6] [meta] Make Fennec work well on 256-meg devices

RESOLVED WONTFIX

Status

()

Firefox for Android
General
RESOLVED WONTFIX
5 years ago
a year ago

People

(Reporter: kats, Assigned: kats)

Tracking

(Depends on: 4 bugs, {meta})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ARMv6])

This is a metabug to track all of the different bugs that reduce memory usage for Fennec. Ideally we want to get it down to running on 256-meg devices without impacting user experience.

I'll start by filing separate bugs for the brainstorming items at https://wiki.mozilla.org/Mobile/BostonBrainstorm/ARMv6
Alias: 256meg
Depends on: 783912
Depends on: 783943
Depends on: 792134
Depends on: 792136
Depends on: 792138
Depends on: 791263
Depends on: 792139
Depends on: 792143
Depends on: 792144
Depends on: 792147
Depends on: 792148
Depends on: 792151
Depends on: 792154
Depends on: 792155
Depends on: 784040
Depends on: 789923
See Also: → bug 744515
Depends on: 792165
Depends on: 713032
Depends on: 760653
Whiteboard: [MemShrink]
Depends on: 748598
Depends on: 739245
Depends on: 792603
Depends on: 783560
Depends on: 776588
Depends on: 797015
Whiteboard: [MemShrink]

Updated

5 years ago
Depends on: 795432

Updated

5 years ago
Whiteboard: [ARMv6]
Depends on: 803575
Depends on: 796117
Depends on: 798491
Depends on: 807104
Depends on: 807110
Depends on: 807998
No longer depends on: 798491
Depends on: 748488
Status update: yesterday I tried running a nightly on a Motorola Milestone which is a 256-meg ARMv7 device. (/proc/meminfo actually reported memory less than 256 meg; the first device I have phyiscally seen to do so). I was able to load CNN after starting fennec. The whole time /proc/meminfo was reporting MemFree on the order of 3-4 MiB so the system is still pretty strapped for memory but it does get the job done.

We should probably focus on reducing startup memory usage a bit more to alleviate the memory pressure and also profile Fennec startup on that device to see if there's any other things we can do to improve the startup experience which is slower than I would like.
Depends on: 812957
Depends on: 769099
Duplicate of this bug: 807189
Depends on: 818169
Depends on: 818546
Depends on: 817134
Depends on: 825483
Depends on: 764220
Depends on: 619558, 759585
No longer depends on: 764220
Depends on: 843999
Depends on: 844669
I'm going to close out this bug since we no longer plan on supporting 256-meg devices. 384 megs is the minimum we plan on supporting, and is supported in FF20 and up. We can still work on some of the dependent bugs to further reduce our memory usage, which will help performance on the 384-meg devices, but this meta-bug is no longer needed.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.