Last Comment Bug 784004 - Don't include Layers.h everywhere Part 3
: Don't include Layers.h everywhere Part 3
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: General (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla17
Assigned To: David Zbarsky (:dzbarsky)
:
Mentors:
Depends on: 784452 784536
Blocks: includehell
  Show dependency treegraph
 
Reported: 2012-08-20 06:27 PDT by David Zbarsky (:dzbarsky)
Modified: 2012-08-23 09:02 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (39.68 KB, patch)
2012-08-20 06:27 PDT, David Zbarsky (:dzbarsky)
no flags Details | Diff | Review
Build fix for Linux and B2G (20.33 KB, patch)
2012-08-20 11:45 PDT, Nicolas Silva [:nical]
dzbarsky: review+
Details | Diff | Review
Patch (54.51 KB, patch)
2012-08-20 20:13 PDT, David Zbarsky (:dzbarsky)
nical.bugzilla: review+
Details | Diff | Review

Description David Zbarsky (:dzbarsky) 2012-08-20 06:27:21 PDT
Created attachment 653347 [details] [diff] [review]
Patch

Nical, you get to review this since your patch did parts of what I was doing and rotted me ;)
Comment 1 Nicolas Silva [:nical] 2012-08-20 11:45:47 PDT
Created attachment 653458 [details] [diff] [review]
Build fix for Linux and B2G

Your patch breaks the build on some platforms, This patch fixes Linux and B2G, I let you check the rest. Fold this one into your first patch.
Comment 2 David Zbarsky (:dzbarsky) 2012-08-20 11:59:57 PDT
Comment on attachment 653458 [details] [diff] [review]
Build fix for Linux and B2G

Review of attachment 653458 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Comment 3 David Zbarsky (:dzbarsky) 2012-08-20 20:13:22 PDT
Created attachment 653638 [details] [diff] [review]
Patch
Comment 4 David Zbarsky (:dzbarsky) 2012-08-20 21:07:21 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/3000e30d082c
Comment 5 Ed Morley [:emorley] 2012-08-21 06:27:46 PDT
https://hg.mozilla.org/mozilla-central/rev/3000e30d082c

Note You need to log in before you can comment on or make changes to this bug.