Closed Bug 784185 Opened 7 years ago Closed 7 years ago

Empty embed tags should not display plugin errors

Categories

(Core :: Plug-ins, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
mozilla17
Tracking Status
firefox16 --- unaffected
firefox17 --- verified
firefox18 --- verified
firefox-esr10 --- unaffected

People

(Reporter: johns, Assigned: johns)

References

Details

Attachments

(2 files, 1 obsolete file)

Empty <embed> tags, after bug 745030, will default to being a "A plugin is needed to display this content" square. However, if they have no src or type, they should just always display alternate content (which is nothingness, in the case of a completely empty tag)

Once bug 548133 lands, <object> tags will have this problem too. (currently the odd pluginurl logic prevents it)
This more closely mimics our old behavior as well as other UAs
Attachment #653556 - Flags: review?(joshmoz)
Of course, adding that check inside a if (tag == object) block isn't going work...
Attachment #653556 - Attachment is obsolete: true
Attachment #653556 - Flags: review?(joshmoz)
Attachment #653579 - Flags: review?(joshmoz)
Attachment #653579 - Flags: review?(joshmoz) → review+
If you're looking for a (badly programmed) test case, please have a look at 
http://edu-net.net/media/paris/

John Schoenick was kind enough to open this bug after spotting the error in my lousy code. 

By the way, the problem is still there as of Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120823030518 CSet: 5650196a8c7d
https://hg.mozilla.org/mozilla-central/rev/e25785cfd8ad
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla18
Comment on attachment 653579 [details] [diff] [review]
object/embed tags without a type shouldn't display plugin error frames

Nominating this for m-a, it's a fairly minor issue, but as-is 17 would change the behavior only to have it revert in 18.

[Approval Request Comment]
Bug caused by (feature/regressing bug #):
Bug 745030

User impact if declined:
Some pages that have empty <object> or <embed> tags without a type or URI will display needless "You need a plugin to display this content" frames where they did not previously

Testing completed (on m-c, etc.): on m-c

Risk to taking this patch (and alternatives if risky):
Low, only changes behavior of when these frames are triggered

String or UUID changes made by this patch: None
Attachment #653579 - Flags: approval-mozilla-aurora?
Attached file Simple test case
Flags: in-testsuite?
I apologize for the prolix.

In regard to the discussion about the apparently now-fixed Bug 781394, I guess I not only added my comment twice; I actually added it to the wrong bug - I should have added it to this one. Sorry. 

John: Even though I saw your note that the fix for Bug 784185 has not been "backported to 17", just to keep the record straight, I'm repeating here the comment I made in regard to the other (the wrong) bug.

This was the essence of my comment: 
-> I checked this bug on http://edu-net.net/media/talkin2me/ using today's Aurora (30Aug12) zip version. 

I checked it with both an absolutely clean profile without extensions and with my "normal" profile, which includes FlashBlock and over thirty other extensions. 

In both cases it requested a plugin. However, there was not, as in the past, a message bar that could be clicked to look (in vain) for the missing plugin. (This behavior, however, may in fact have been related to Bug 781394.)

In closing, is there a proposed date when the fix for Bug 784185 will be "backported" to 17?

Thanks.
Addendum: The testing alluded to in comment 8 was done on a 32-bit XP machine.
Comment on attachment 653579 [details] [diff] [review]
object/embed tags without a type shouldn't display plugin error frames

approving, let's keep consistent behaviour.
Attachment #653579 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Depends on: 798623
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 beta 4
Build ID: 20121031065642

After running the "simple test plan" from comment 0, in the first square, "A plugin is needed to display this content" appears for the missing plug-in warning, and an empty box for the "no missing plugin warning".
Also verified for Mac OS X 10.7.5 and Ubuntu 12.04.

Could previously reproduce the issue.
Verified fixed on FF 18b1 on Win 7, Ubuntu 12.04 and Mac OS X 10.6
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.