Last Comment Bug 781394 - Firefox displays "Install Missing Plugins" popup for nytimes.com home page
: Firefox displays "Install Missing Plugins" popup for nytimes.com home page
Status: VERIFIED FIXED
: regression
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: 17 Branch
: All All
-- normal with 2 votes (vote)
: mozilla17
Assigned To: John Schoenick [:johns]
:
: Benjamin Smedberg [:bsmedberg]
Mentors:
http://www.nytimes.com/
: 781681 782140 (view as bug list)
Depends on:
Blocks: 767631 745030 784185
  Show dependency treegraph
 
Reported: 2012-08-08 17:32 PDT by Chris Peterson [:cpeterson]
Modified: 2012-12-14 11:40 PST (History)
21 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
unaffected
+
verified


Attachments
another reduced test case (609 bytes, text/html)
2012-08-14 11:34 PDT, David Keeler [:keeler] (use needinfo?)
no flags Details
Don't fire plugin errors for plugins that never got to a determined type (1.37 KB, patch)
2012-08-14 11:49 PDT, John Schoenick [:johns]
no flags Details | Diff | Splinter Review
Don't fire plugin errors for plugins that never got to a determined type (1.37 KB, patch)
2012-08-14 11:55 PDT, John Schoenick [:johns]
jaas: review+
john: checkin+
Details | Diff | Splinter Review

Description User image Chris Peterson [:cpeterson] 2012-08-08 17:32:56 PDT
Firefox displays the "Install Missing Plugins" popup for some (but not all) nytimes.com pages. I have Flash 11.3, Silverlight, QuickTime, and Java plugins installed and enabled.

I bisected older Nightly 17 builds and I believe the regression point is today's build 8-08. Here is the pushlog of changes between build 8-07 and 8-08:

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=1bbc0b65dffb&tochange=e55638d4037a


I have seen this problem on the following pages:

http://www.nytimes.com/

http://fivethirtyeight.blogs.nytimes.com/2012/08/08/how-romneys-pick-of-a-running-mate-could-sway-the-outcome/
Comment 1 User image John Schoenick [:johns] 2012-08-08 17:48:21 PDT
It looks like we're firing a plugin load error when we did not previously possibly due to something the site's js is doing - investigating
Comment 2 User image Alice0775 White 2012-08-08 17:59:54 PDT
Confirmed.
http://www.yahoo.co.jp/ when loads ad.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120808030529
Comment 3 User image Chris Peterson [:cpeterson] 2012-08-08 18:22:26 PDT
jschoenick, bisecting mozilla-inbound's archived tinderbox builds, I have narrowed the regression range to your nsObjectLoadingContent changes:

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=b4a63a0b90c2&tochange=f3bd764deb31
Comment 4 User image alex_mayorga 2012-08-09 07:27:18 PDT
Is this the same bug that prompts to install missing plugins on Amazon's product pages[1]?

1| http://www.amazon.com/gp/product/B005HH0N3U/
Comment 5 User image Rob Madden 2012-08-09 11:03:06 PDT
The bug is on all platforms not just Mac OS X. I am using firefox 64bit with windows 8 and get the plugin is missing also on windows 7 too.
Comment 6 User image Benjamin Smedberg [:bsmedberg] 2012-08-09 15:53:23 PDT
*** Bug 781681 has been marked as a duplicate of this bug. ***
Comment 7 User image Benjamin Smedberg [:bsmedberg] 2012-08-09 15:53:49 PDT
Bug 781681 has a reduced testcase.
Comment 8 User image (mostly gone) XtC4UaLL [:xtc4uall] 2012-08-09 16:05:57 PDT
(In reply to alex_mayorga from comment #4)
Per
    // pre-fetching css and js assets based on different browser types
    ...
    else if (isFireFox) {
      for (var i=0; i<jsCssAssets.length; i++) {
        var o =  document.createElement("object");
        o.data = jsCssAssets[i];
        o.width = o.height = 0;
        document.body.appendChild(o);
      }
I'd would think so, no?
Comment 9 User image JoeG 2012-08-11 04:16:07 PDT
If it's of any interest, the problem also occurs on my little website.
e.g. http://edu-net.net/media/talkin2me/
Comment 10 User image JoeG 2012-08-11 04:27:28 PDT
Complement to my comment.
-> http://forums.mozillazine.org/viewtopic.php?f=23&t=2513405
Comment 11 User image ex.astris 2012-08-12 12:35:35 PDT
*** Bug 782140 has been marked as a duplicate of this bug. ***
Comment 12 User image ex.astris 2012-08-12 12:36:27 PDT
Also affecting most articles on news.bbc.co.uk
Comment 13 User image Paul [pwd] 2012-08-13 04:23:59 PDT
I'm seeing it on most sites with embedded flash videos.
Comment 14 User image David Keeler [:keeler] (use needinfo?) 2012-08-14 11:34:01 PDT
Created attachment 651838 [details]
another reduced test case

Looks like if a data attribute isn't specified (until it gets added later with javascript), we'll fire the missing plugin event (and then load the plugin later anyway).
Comment 15 User image John Schoenick [:johns] 2012-08-14 11:49:49 PDT
Created attachment 651842 [details] [diff] [review]
Don't fire plugin errors for plugins that never got to a determined type
Comment 16 User image John Schoenick [:johns] 2012-08-14 11:52:36 PDT
(In reply to David Keeler from comment #14)
> Created attachment 651838 [details]
> another reduced test case
> 
> Looks like if a data attribute isn't specified (until it gets added later
> with javascript), we'll fire the missing plugin event (and then load the
> plugin later anyway).

Previously we wont only fire the plugin error if we loaded a channel and still had no type, but wouldn't for e.g.
> <object type="application/x-derp">
>   <param name="foo" value="bar">
> </object>

745030 made this logic saner, and all objects with an ultimately unknown type will trigger an error. This patch will fix us firing errors for objects with no type, but I'm not sure if we want to completely revert to our old broken behavior.
Comment 17 User image John Schoenick [:johns] 2012-08-14 11:55:14 PDT
Created attachment 651843 [details] [diff] [review]
Don't fire plugin errors for plugins that never got to a determined type

nit, use IsEmpty() instead of checking Length()
Comment 18 User image John Schoenick [:johns] 2012-08-15 11:31:23 PDT
Comment on attachment 651843 [details] [diff] [review]
Don't fire plugin errors for plugins that never got to a determined type

https://hg.mozilla.org/integration/mozilla-inbound/rev/8973d9714190

try run:
https://tbpl.mozilla.org/?tree=Try&rev=1e72e421e6b8
Comment 19 User image John Schoenick [:johns] 2012-08-15 11:32:30 PDT
Leaving open as it's not clear this will solve all the problems
Comment 20 User image Ryan VanderMeulen [:RyanVM] 2012-08-15 18:44:47 PDT
https://hg.mozilla.org/mozilla-central/rev/8973d9714190
Comment 21 User image John Schoenick [:johns] 2012-08-20 13:07:48 PDT
I believe this is fixed now, looking at this further it seems that Bug 767631 prevents us from triggering this in other cases that websites might not expect, as we only really trigger loads on BindToTree and SetAttr(data)
Comment 22 User image John Schoenick [:johns] 2012-08-20 13:13:03 PDT
QA - We should be on the lookout for sites displaying this popup in FF17 that did not previously (though many of these cases may be evangelism issues, as our old behavior was not very correct)
Comment 23 User image JoeG 2012-08-20 15:04:47 PDT
Sorry for the "amateurish" post.

1. In the last few days the little "robot" figure in the error message disappeared.
Please see -> http://edu-net.net/images/plugin-error.jpg

2. I assume the fix will be in tomorrow's build because I've just (midnight, Berlin time) updated to Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120820030522 CSet: c676b554c7bb
and the bug is still present. 

3. I have a very simple, primitively coded personal site that I use for my English classes at the Technical University here in Berlin, Germany. For some reason, it, too, throws up the "plugin needed" error. Please see the page I mentioned above in comment 10.
e.g. http://edu-net.net/media/talkin2me/

Thanks.
Comment 24 User image John Schoenick [:johns] 2012-08-20 15:21:14 PDT
(In reply to Joe Greenman from comment #23)
> Sorry for the "amateurish" post.
> 
> 1. In the last few days the little "robot" figure in the error message
> disappeared.
> Please see -> http://edu-net.net/images/plugin-error.jpg

Does this happen with addons disabled? (Help -> restart with addons disabled)
If so, please file a new bug for this

> 2. I assume the fix will be in tomorrow's build because I've just (midnight,
> Berlin time) updated to Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:17.0)
> Gecko/17.0 Firefox/17.0 ID:20120820030522 CSet: c676b554c7bb
> and the bug is still present. 

This build should have the fix - what sites are you still seeing this error on?

> 3. I have a very simple, primitively coded personal site that I use for my
> English classes at the Technical University here in Berlin, Germany. For
> some reason, it, too, throws up the "plugin needed" error. Please see the
> page I mentioned above in comment 10.
> e.g. http://edu-net.net/media/talkin2me/
> 
> Thanks.

I think this is because you have an extra <embed> tag on this page that is causing the error, before the object tag:

> <embed> <!-- ~ Delete this -->
> <object ...>
>   <param name='movie' value='http://edu-net.net/media/talkin2me/player.swf'>
>   ...
>   <embed
>      type='application/x-shockwave-flash'
>      ...
>      />
> </object>
Comment 25 User image JoeG 2012-08-20 15:45:27 PDT
(In reply to John Schoenick [:johns] from comment #24)
>...
> > 1. In the last few days the little "robot" figure in the error message
> > disappeared.
> > Please see -> http://edu-net.net/images/plugin-error.jpg
> 
> Does this happen with addons disabled? (Help -> restart with addons disabled)
> If so, please file a new bug for this
I tried it. There's an image, but it looks like a "lego" block rather than the little robot. I suppose the robot had something to do with my setup. 
 
> > 2. I assume the fix will be in tomorrow's build because I've just (midnight,
> > Berlin time) updated to Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:17.0)
> > Gecko/17.0 Firefox/17.0 ID:20120820030522 CSet: c676b554c7bb
> > and the bug is still present. 
> 
> This build should have the fix - what sites are you still seeing this error
> on?

I had only checked on my own site, and with the fix for my lousy coding that you kindly provided, it's now fixed. Thank you very much.  

> 
> I think this is because you have an extra <embed> tag on this page that is
> causing the error, before the object tag:

Yes, that was the problem. Again, thanks very much. 

I've fixed some of the pages and hope to get through the rest of them tomorrow.

My most since thanks.
Comment 26 User image JoeG 2012-08-20 15:46:17 PDT
I meant "sincere" thanks.
Comment 27 User image John Schoenick [:johns] 2012-08-20 15:51:58 PDT
(In reply to Joe Greenman from comment #25)
> > I think this is because you have an extra <embed> tag on this page that is
> > causing the error, before the object tag:
> 
> Yes, that was the problem. Again, thanks very much. 

Thinking about this more, I think it is a bug that <embed> tags without any type or URI trigger an error frame - I opened bug 784185 for that
Comment 28 User image Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-08-30 10:22:29 PDT
Replacing QAWANTED with VERIFYME. To whomever tests this, please confirm the URLs in this bug don't trigger this bug anymore. However, also keep an eye out for other websites which may potentially trigger this bug. We'll want to be as broad in our testing as possible to try to tickle some edge-cases.
Comment 29 User image alex_mayorga 2012-08-30 11:37:14 PDT
I can confirm that the "Install Missing Plugins" popup no longer appears on Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120830030531 for the following pages:

http://www.nytimes.com/
http://fivethirtyeight.blogs.nytimes.com/2012/08/08/how-romneys-pick-of-a-running-mate-could-sway-the-outcome/
http://www.yahoo.co.jp/
http://edu-net.net/media/talkin2me/
http://www.amazon.com/gp/product/B005HH0N3U/
Comment 30 User image Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-08-30 11:40:06 PDT
Thanks Alex. Can you please also confirm with the latest Firefox 17.0a2 Aurora build?
Comment 31 User image JoeG 2012-08-30 12:16:49 PDT
It's not fixed on http://edu-net.net/media/talkin2me/ in 17.02a
Comment 32 User image Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-08-30 12:33:02 PDT
(In reply to Joe Greenman from comment #31)
> It's not fixed on http://edu-net.net/media/talkin2me/ in 17.02a

Thanks Joe. I can confirm that Firefox 18.0a1 Nightly 2012-08-30 does not reproduce but Firefox 17.0a2 Aurora 2012-08-30 does. Reopening this as it seems to not be a complete fix. Feel free to close and request a new dependency bug.
Comment 33 User image JoeG 2012-08-30 12:42:18 PDT
Sorry, I meant 17.0a2. I also apologize for not being more specific. 

To elucidate, I checked it on today's Aurora (30Aug12) zip version. I checked it both with an absolutely clean profile with no extensions and with my normal profile, that includes FlashBlock. 

In both cases it requested a plugin. 

However, there was not, as in the past, a message bar that could be clicked to look (in vain) for the missing plugin.
Comment 34 User image JoeG 2012-08-30 12:45:32 PDT
Sorry, I meant 17.0a2. I also apologize for not being more specific. 

To elucidate, I checked it on today's Aurora (30Aug12) zip version. I checked it both with an absolutely clean profile with no extensions and with my normal profile, that includes FlashBlock. 

In both cases it requested a plugin. 

However, there was not, as in the past, a message bar that could be clicked to look (in vain) for the missing plugin.
Comment 35 User image John Schoenick [:johns] 2012-08-30 12:51:46 PDT
The issue with the extra embed frame on that page is bug 784185, which is separate from this bug. That bug was not yet backported to 17, hence the continuing issue there.

This bug is for the message-bar popup for empty plugin tags, which does appear to be fixed in 17 and 18 as you note
Comment 36 User image Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-08-30 12:55:17 PDT
Thanks for the clarification John. Remarking this verified though we'll keep an eye out for issues like this through the QA cycle for Firefox 17.
Comment 37 User image Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-08-30 12:56:09 PDT
Note that I've added the verifyme keyword to bug 784185 to make sure we test that as well.

Note You need to log in before you can comment on or make changes to this bug.