Last Comment Bug 784255 - [b2g-bluetooth] devicefound event does not come up correctly
: [b2g-bluetooth] devicefound event does not come up correctly
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Device Interfaces (show other bugs)
: unspecified
: ARM Gonk (Firefox OS)
: -- normal (vote)
: mozilla17
Assigned To: Eric Chou [:ericchou] [:echou]
:
Mentors:
Depends on:
Blocks: b2g-bluetooth 743933
  Show dependency treegraph
 
Reported: 2012-08-20 21:22 PDT by Eric Chou [:ericchou] [:echou]
Modified: 2012-08-21 10:07 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1: Add property 'Type' to device and adapter property name list (1.25 KB, patch)
2012-08-20 21:38 PDT, Eric Chou [:ericchou] [:echou]
kyle: review+
Details | Diff | Review

Description Eric Chou [:ericchou] [:echou] 2012-08-20 21:22:16 PDT
I tried to use latest code base to discovery devices nearby but failed. It's because GetProperty() in ParseProperties() returned false, so that aValue = props would not be executed and aValue would have no value. The root cause is there was a 'Type' property in devicefound event, but we were unable to recognize it because it didn't exist in sDeviceProperties. We have to update sDeviceProperties & sAdapterProperties to the same value as in Android ICS[1].

[1] See android_bluetooth_common.cpp for more information.
Comment 1 Eric Chou [:ericchou] [:echou] 2012-08-20 21:24:06 PDT
Forgot to mention, the issue happened on otoro.
Comment 2 Eric Chou [:ericchou] [:echou] 2012-08-20 21:38:55 PDT
Created attachment 653649 [details] [diff] [review]
v1: Add property 'Type' to device and adapter property name list

Type is a newly added property of BlueZ (in ICS). Old version BlueZ won't be affected because we didn't delete or modify any existing properties.
Comment 3 Kyle Machulis [:kmachulis] [:qdot] 2012-08-20 22:25:31 PDT
Comment on attachment 653649 [details] [diff] [review]
v1: Add property 'Type' to device and adapter property name list

Review of attachment 653649 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good. Linked to bug 743933, which is other ICS dbus/bluez changes. I can't even start on that until the arm7 gb try target is gone though, so mainly just putting this here to note.
Comment 4 Eric Chou [:ericchou] [:echou] 2012-08-20 23:25:40 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/f9a8fdb08193
Comment 5 Ed Morley [:emorley] 2012-08-21 06:27:04 PDT
https://hg.mozilla.org/mozilla-central/rev/f9a8fdb08193

Note You need to log in before you can comment on or make changes to this bug.