Recent Apps list only shows one Webapp

VERIFIED FIXED in Firefox 16

Status

()

defect
VERIFIED FIXED
7 years ago
3 years ago

People

(Reporter: wesj, Unassigned)

Tracking

unspecified
Firefox 17
Points:
---

Firefox Tracking Flags

(firefox16 verified)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Reporter

Description

7 years ago
ibarlow noticed that only one app ever shows in his recent apps list. Is this fallout from changing them to all be named "App"? It would be nice if you could have more than one in there.
Reporter

Comment 1

7 years ago
Posted patch Patch (obsolete) — Splinter Review
Had to dig into the android source, but it turns out that ActivityManagerService uses affinity to determine if two tasks are "unique". We could set it to "" and just always use a unique task (I think, the word task here is confusing...).

This also works and namespaces them a bit, which feels good.
Attachment #654401 - Flags: review?(mark.finkle)
Reporter

Comment 2

7 years ago
Posted patch PatchSplinter Review
Now with code.
Attachment #654401 - Attachment is obsolete: true
Attachment #654401 - Flags: review?(mark.finkle)
Attachment #654402 - Flags: review?(mark.finkle)
Comment on attachment 654402 [details] [diff] [review]
Patch

Seems reasonable based on the docs I have seen, We could also try using the same string we use for process as the taskAffinity too, but I'm not sure it's any better of a choice.
Attachment #654402 - Flags: review?(mark.finkle) → review+
Reporter

Comment 5

7 years ago
Comment on attachment 654402 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): New apps stuff
User impact if declined: Only one app (including Fennec) ever appears in the Recent apps screen
Testing completed (on m-c, etc.): landed today
Risk to taking this patch (and alternatives if risky):  Very low risk. Only affects mobile webapps. Just changed their "task" which should have no affect on anything but this
String or UUID changes made by this patch: None.
Attachment #654402 - Flags: approval-mozilla-aurora?
Attachment #654402 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/d720637283eb
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 17
Component: General → Web Apps
Duplicate of this bug: 766815
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.