Last Comment Bug 784410 - Scrolling by the turn of the mouse wheel stops working on certain element
: Scrolling by the turn of the mouse wheel stops working on certain element
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Layout (show other bugs)
: 15 Branch
: x86 All
: -- normal (vote)
: mozilla18
Assigned To: Robert O'Callahan (:roc) (Exited; email my personal email if necessary)
:
Mentors:
Depends on:
Blocks: 681192 785460
  Show dependency treegraph
 
Reported: 2012-08-21 10:38 PDT by Alice0775 White
Modified: 2012-09-18 20:02 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-
+
fixed
+
fixed


Attachments
reduced html (2.17 KB, text/html)
2012-08-21 11:13 PDT, Alice0775 White
no flags Details
reduced html (979 bytes, text/html)
2012-08-21 11:32 PDT, Alice0775 White
no flags Details
fix (4.08 KB, patch)
2012-08-22 23:27 PDT, Robert O'Callahan (:roc) (Exited; email my personal email if necessary)
mats: review+
akeybl: approval‑mozilla‑aurora+
akeybl: approval‑mozilla‑beta+
Details | Diff | Review
mousewheel fix (3.27 KB, patch)
2012-09-12 21:13 PDT, Robert O'Callahan (:roc) (Exited; email my personal email if necessary)
mats: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
lukasblakk+bugs: approval‑mozilla‑beta+
Details | Diff | Review

Description Alice0775 White 2012-08-21 10:38:30 PDT
http://hg.mozilla.org/mozilla-central/rev/360ab7771e27
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120821030519

Scrolling by the turn of the mouse wheel does not work sometimes.
This happens regardless of HWA.

This happens Firefox14, 15Beta, Aurora16.0a2 and Nightly17.0a1.
And this makes me annoy.

Steps To Reproduce:
1. Start Firefox with clean profile(no add-ons and no plug-ins)
2. Open https://developer.mozilla.org/en-US/docs/Storage
3. Find "nsresult rv = mDBConn->CreateStatement"
4. left Click on the paragraph(Code Syntax highlighter?)
5. Try to scroll with mouse wheel carefully(one tick)
6. Repeat step 4 and 5

Actual Results:
 Scrolling by the turn of the mouse wheel does not work sometimes.
 And fonts in the element moves up/down 1 pixel.

Expected Results:
 Scroll the page
Comment 1 Alice0775 White 2012-08-21 10:44:30 PDT
Screen capture:
http://youtu.be/kHnN3JjBYrI
Comment 2 Alice0775 White 2012-08-21 11:13:24 PDT
Created attachment 653852 [details]
reduced html
Comment 3 Alice0775 White 2012-08-21 11:32:25 PDT
Created attachment 653866 [details]
reduced html
Comment 4 Alice0775 White 2012-08-21 11:36:51 PDT
Err
This does not happen in Firefox14.
Comment 5 Alice0775 White 2012-08-21 11:50:45 PDT
Regression window(m-i)
Good:
http://hg.mozilla.org/mozilla-central/rev/6fe7dd2f8f57
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120510021321
Bad:
http://hg.mozilla.org/mozilla-central/rev/b7b6565d12a0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120510050721
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=6fe7dd2f8f57&tochange=b7b6565d12a0


Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/b5304fd23df9
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120509222721
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/67091352b7d2
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120509223521
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=b5304fd23df9&tochange=67091352b7d2

Last good: c3d3bfb3b68d
First bad: 9d9a3edaa0b9

Triggered by
9d9a3edaa0b9	Robert O'Callahan — Bug 681192. Part 11: Don't snap scrollrange endpoints to device pixels anymore. r=matspal
Comment 6 Alice0775 White 2012-08-21 12:07:23 PDT
And
In Caret Browsing Mode,  this problem can see easily

Steps To Reproduce:
1. Start Firefox with clean profile(no add-ons and no plug-ins)
2. Open https://developer.mozilla.org/en-US/docs/Storage
3. Turn on  "Caret Browsing Mode" (F7)
4. Find "nsresult rv = mDBConn->CreateStatement"
5. left Click on the paragraph
6. Press "Page UP" key

Actual Results:
  the element moves up 1 pixel.

Expected Results:
  Scrolls the document up one screenful.
Comment 7 Lukas Blakk [:lsblakk] use ?needinfo 2012-08-22 11:17:54 PDT
At this stage in FF15 release, we're too late to track this and it's not a chemspill-worthy issue but we'll track for 16/17.
Comment 8 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2012-08-22 22:32:53 PDT
This is tricky. The text on each line of the code samples actually overflows the line a little bit, I think because the line-height is 1.1em but the font ascenders and descenders stick out of the line a little. So we think the code sample overflows its overflow:auto container a little bit (less than a pixel in this case). If you zoom in a lot, you can see vertical scrollbars on the examples. This content should be using overflow-x:auto overflow-y:hidden, really, or changing its line-height.

Having said that, nsHTMLScrollFrame::TryLayout refuses to show the vertical scrollbar in the unzoomed case unless we can scroll by at least one device pixel, and in this case we can't. The code in nsLayoutUtils::GetNearestScrollableFrameForDirection and nsLayoutUtils::GetNearestScrollableFrame should do the same.
Comment 9 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2012-08-22 23:27:55 PDT
Created attachment 654523 [details] [diff] [review]
fix
Comment 10 Mats Palmgren (:mats) 2012-08-23 07:10:47 PDT
Did you forget to include nsLayoutUtils::GetNearestScrollableFrameForDirection
in the patch? (comment 8 mentioned it should have the same change)

If so, perhaps we should share this code, in say
bool nsIScrollableFrame::CanScrollInDirection(Direction aDirection)
Comment 11 Mats Palmgren (:mats) 2012-08-23 07:20:27 PDT
Nevermind, I see that this is GetNearestScrollableFrameForDirection actually
although the diff says otherwise, and GetNearestScrollableFrame
doesn't have this check...
Comment 12 Mats Palmgren (:mats) 2012-08-23 07:21:22 PDT
Comment on attachment 654523 [details] [diff] [review]
fix

Looks fine, r=mats
Comment 13 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2012-08-29 04:25:05 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/17b1db7b293f
Comment 14 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2012-08-29 04:26:02 PDT
Comment on attachment 654523 [details] [diff] [review]
fix

Review of attachment 654523 [details] [diff] [review]:
-----------------------------------------------------------------

Annoying user-facing regression. Needs to be fixed ASAP.
Comment 15 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2012-08-29 04:26:26 PDT
(Low risk too)
Comment 16 Ryan VanderMeulen [:RyanVM] 2012-08-29 17:21:21 PDT
https://hg.mozilla.org/mozilla-central/rev/17b1db7b293f
Comment 17 Alex Keybl [:akeybl] 2012-08-31 16:09:17 PDT
Comment on attachment 654523 [details] [diff] [review]
fix

[Triage Comment]
Low risk fix for a recent Firefox regression that may cause user pain. Approving for branches.
Comment 18 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2012-09-05 04:15:28 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/c896d87bbe70
https://hg.mozilla.org/releases/mozilla-beta/rev/8082d8212064
Comment 19 Alice0775 White 2012-09-05 04:30:50 PDT
I tested with STR in comment#0 and  attachment 653866 [details] as well,
I can still reproduce.
It seems nothing changed.

http://hg.mozilla.org/mozilla-central/rev/a86b00fa6bc6
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120904030512
Comment 20 Alice0775 White 2012-09-05 07:29:40 PDT
And I can reproduce the problem in Aurora17.a2 and Beta16. It seems nothing changed.

http://hg.mozilla.org/releases/mozilla-aurora/rev/c896d87bbe70
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120905040812

http://hg.mozilla.org/releases/mozilla-beta/rev/8082d8212064
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20120904 Firefox/16.0 ID:20120905041410
Comment 21 Alice0775 White 2012-09-08 01:07:49 PDT
I can also reproduce in the following page.
http://www.natural-science.or.jp/article/20120220155529.php#h2_1
"サンプル1:tutorial1.html(視点と光源の設定、立方体の描画)"
Comment 22 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2012-09-12 20:40:16 PDT
I fixed scrolling with the keyboard, but not with the mousewheel, which of course is what Alice originally filed this about.
Comment 23 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2012-09-12 21:13:36 PDT
Created attachment 660701 [details] [diff] [review]
mousewheel fix
Comment 24 Mats Palmgren (:mats) 2012-09-13 08:57:07 PDT
Comment on attachment 660701 [details] [diff] [review]
mousewheel fix

r=mats
Comment 25 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2012-09-16 22:46:46 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/3ee856aa68d2
Comment 26 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2012-09-16 22:47:12 PDT
Comment on attachment 660701 [details] [diff] [review]
mousewheel fix

Review of attachment 660701 [details] [diff] [review]:
-----------------------------------------------------------------

Another simple fix for this user-annoying bug.
Comment 27 Ed Morley [:emorley] 2012-09-17 12:25:58 PDT
https://hg.mozilla.org/mozilla-central/rev/3ee856aa68d2
Comment 28 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2012-09-18 20:02:43 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/a728bf11ff1d

https://hg.mozilla.org/releases/mozilla-beta/rev/5460444bc681

Note You need to log in before you can comment on or make changes to this bug.