Empty address bar isn't always focused after startup

RESOLVED FIXED in Firefox 17

Status

()

Firefox
General
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Octoploid, Assigned: dao)

Tracking

({regression})

17 Branch
Firefox 17
x86_64
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.83 KB, patch
Neil Deakin (mostly unavailable until September)
: review+
Details | Diff | Splinter Review
(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20120822094317

Steps to reproduce:

Start Firefox


Actual results:

Address bas is not selected (no cursor).
Happens with about:blank and about:newtab.


Expected results:

The address bar should be selected by default.
(Reporter)

Comment 1

5 years ago
Started with:

commit 5f387a38960ae207462848cf0f2bbf20775abfa5
Author: Dão Gottwald <dao@mozilla.com>
Date:   Tue Aug 21 15:53:39 2012 +0200

    Bug 783103 - Avoid layout flush from isElementVisible when attempting to focus the URL bar or search bar. r=enn
(Assignee)

Updated

5 years ago
Blocks: 783103
Component: Untriaged → General
Keywords: regression
(Assignee)

Comment 2

5 years ago
Created attachment 654180 [details] [diff] [review]
patch

I couldn't reproduce this bug with my default profiles on Windows and Linux, but I can reproduce it with a new profile on Linux. delayedStartup appears to be racing with the initial window being focused, and gURLBar.focused will only be true once the window is focused.
Assignee: nobody → dao
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #654180 - Flags: review?(enndeakin)
(Assignee)

Updated

5 years ago
Summary: Address bar not selected after startup → Empty address bar isn't always focused after startup
Comment on attachment 654180 [details] [diff] [review]
patch

Seems ok, as long as the extra call to mouseoverToggle and select() is acceptable.
Attachment #654180 - Flags: review?(enndeakin) → review+
(Assignee)

Comment 4

5 years ago
(In reply to Neil Deakin from comment #3)
> Comment on attachment 654180 [details] [diff] [review]
> patch
> 
> Seems ok, as long as the extra call to mouseoverToggle and select() is
> acceptable.

FullScreen.mouseoverToggle will only be called when starting up in fullscreen mode, and return early because the fullscreen UI isn't set up at that point. select() can be avoided if deemed worthwhile, see bug 783064 comment 1.
(Assignee)

Comment 5

5 years ago
http://hg.mozilla.org/integration/mozilla-inbound/rev/3ded80c6a2da

Comment 6

5 years ago
https://hg.mozilla.org/mozilla-central/rev/3ded80c6a2da
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 17
You need to log in before you can comment on or make changes to this bug.