Last Comment Bug 784676 - Moving from a menu item to another in new menu button causes menu to stay open
: Moving from a menu item to another in new menu button causes menu to stay open
Status: RESOLVED FIXED
: polish
Product: Thunderbird
Classification: Client Software
Component: Toolbars and Tabs (show other bugs)
: 17 Branch
: x86_64 All
: -- normal (vote)
: Thunderbird 18.0
Assigned To: Mike Conley (:mconley) - (needinfo me!)
:
Mentors:
Depends on:
Blocks: 789417 TB-AppMenu
  Show dependency treegraph
 
Reported: 2012-08-22 07:55 PDT by Paul [:dew]
Modified: 2012-10-04 23:43 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
+
fixed


Attachments
Both menus open at once. (19.68 KB, image/png)
2012-08-22 07:55 PDT, Paul [:dew]
no flags Details
Patch v1 (1.89 KB, patch)
2012-09-11 07:39 PDT, Mike Conley (:mconley) - (needinfo me!)
mkmelin+mozilla: review+
Details | Diff | Splinter Review
Patch v2 (r+'d by mkmelin) (2.13 KB, patch)
2012-09-11 13:19 PDT, Mike Conley (:mconley) - (needinfo me!)
mconley: review+
standard8: approval‑comm‑aurora+
Details | Diff | Splinter Review

Description Paul [:dew] 2012-08-22 07:55:57 PDT
Created attachment 654207 [details]
Both menus open at once.

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20120821092158

Steps to reproduce:

Hovered over the tools menu and moved cursor to the help menu.


Actual results:

Tools menu stayed open while help menu opened.


Expected results:

Tools menu should have disappeared.
Comment 1 Richard Marti (:Paenglab) 2012-08-22 09:50:40 PDT
The strange is, when you go from Tools menu directly to Help the Tools popup stays. When you go from Tools menu directly to the arrow on the right of the Help menu then the Tools popup closes normally.

mconley, could it be something in the new binding in mailWidget.xml line2690 ff. isn't correct?
Comment 2 Mike Conley (:mconley) - (needinfo me!) 2012-09-11 07:36:09 PDT
Finally figured out what was going on here - Firefox does a little hack that we missed in our port. Patch coming...
Comment 3 Mike Conley (:mconley) - (needinfo me!) 2012-09-11 07:39:47 PDT
Created attachment 660070 [details] [diff] [review]
Patch v1

Firefox's hack happens here:

http://mxr.mozilla.org/comm-central/source/mozilla/browser/base/content/browser-appmenu.inc#14

And it looks like the splitmenu binding appears to require this in order to make menu-closing work properly.

This patch allows us to emulate this.
Comment 4 Mike Conley (:mconley) - (needinfo me!) 2012-09-11 07:41:51 PDT
Comment on attachment 660070 [details] [diff] [review]
Patch v1

Magnus,

How does this look to you?

-Mike
Comment 5 Magnus Melin 2012-09-11 12:38:16 PDT
Comment on attachment 660070 [details] [diff] [review]
Patch v1

Review of attachment 660070 [details] [diff] [review]:
-----------------------------------------------------------------

Looks like the submenu problem is gone, but when moving the mouse between the menus Tools and Help are both highlighted simultaneously until the Help submenu opens. Feels like opening Help is "heavy". Maybe that's not related though...

r=mkmelin, but do add a comment about what it's doing
Comment 6 Mike Conley (:mconley) - (needinfo me!) 2012-09-11 13:01:17 PDT
(In reply to Magnus Melin from comment #5)
> Comment on attachment 660070 [details] [diff] [review]
> Patch v1
> 
> Review of attachment 660070 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Looks like the submenu problem is gone, but when moving the mouse between
> the menus Tools and Help are both highlighted simultaneously until the Help
> submenu opens. Feels like opening Help is "heavy". Maybe that's not related
> though...

Yeah, that heaviness is the 600ms delay, and is expected behaviour. Essentially, it gives / reveals the ability for the user to select that individual item ("Help") without exposing its submenu.

It's the same behaviour as Firefox, so I think we'll keep it. I'll add the comment as you requested.

Thanks for the review!

> 
> r=mkmelin, but do add a comment about what it's doing
Comment 7 Mike Conley (:mconley) - (needinfo me!) 2012-09-11 13:19:50 PDT
Created attachment 660205 [details] [diff] [review]
Patch v2 (r+'d by mkmelin)
Comment 8 Mike Conley (:mconley) - (needinfo me!) 2012-09-11 13:33:44 PDT
Comment on attachment 660205 [details] [diff] [review]
Patch v2 (r+'d by mkmelin)

Improves usability and general correctness of the appmenu.
Comment 9 Mike Conley (:mconley) - (needinfo me!) 2012-09-11 13:36:31 PDT
comm-central: https://hg.mozilla.org/comm-central/rev/6b93d9025dcb
Comment 10 Mike Conley (:mconley) - (needinfo me!) 2012-09-14 12:11:35 PDT
comm-aurora: https://hg.mozilla.org/releases/comm-aurora/rev/1d31223635ef

Note You need to log in before you can comment on or make changes to this bug.