Last Comment Bug 784797 - Excessive left margin in conversation pane
: Excessive left margin in conversation pane
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Instant Messaging (show other bugs)
: Trunk
: x86 Windows XP
: -- normal (vote)
: Thunderbird 18.0
Assigned To: Richard Marti (:Paenglab)
:
:
Mentors:
Depends on:
Blocks: 768919
  Show dependency treegraph
 
Reported: 2012-08-22 13:55 PDT by Joe Sabash [:JoeS1]
Modified: 2012-10-26 06:35 PDT (History)
7 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed
fixed


Attachments
screenshot (14.52 KB, image/gif)
2012-08-22 13:55 PDT, Joe Sabash [:JoeS1]
no flags Details
patch (987 bytes, patch)
2012-08-28 11:41 PDT, Richard Marti (:Paenglab)
bugs: feedback-
Details | Diff | Splinter Review
Patch v2 (2.24 KB, patch)
2012-09-08 08:58 PDT, Richard Marti (:Paenglab)
florian: review+
bugs: ui‑review+
standard8: approval‑comm‑aurora+
Details | Diff | Splinter Review
Patch for beta (2.25 KB, patch)
2012-09-13 09:08 PDT, Richard Marti (:Paenglab)
standard8: approval‑comm‑beta+
Details | Diff | Splinter Review

Description Joe Sabash [:JoeS1] 2012-08-22 13:55:12 PDT
Created attachment 654361 [details]
screenshot

Since 20120822 the conversation pane show an excessive left margin.
bug 768919 ?
It looks fine in win 7 on a wide reso monitor, but pretty ugly on my laptop and oldish winxp systems.
Comment 1 Richard Marti (:Paenglab) 2012-08-25 11:47:08 PDT
Andreas, what do you think about this Bug? 150px may be a little bit wide and gives a lot of white space. We could use 12ch instead of 150px. The advantage would be the width would be adapted depending the font size.
Comment 2 Florian Quèze [:florian] [:flo] 2012-08-25 14:12:34 PDT
Would a size in % work in this case?
Comment 3 Richard Marti (:Paenglab) 2012-08-25 14:27:56 PDT
Something like nick is 15% of chat width? Wouldn't this make the nick go in overflow earlier on narrow windows and then harder to recognize?
Comment 4 Florian Quèze [:florian] [:flo] 2012-08-25 14:32:25 PDT
What about a min-width and a max-width in px or ch, and a width in % ?
(mostly thinking out loud at this point; I'm not saying this is what we should do.)
Comment 5 Andreas Nilsson (:andreasn) 2012-08-26 12:17:45 PDT
(In reply to Richard Marti [:Paenglab] from comment #1)
> Andreas, what do you think about this Bug? 150px may be a little bit wide
> and gives a lot of white space. We could use 12ch instead of 150px. The
> advantage would be the width would be adapted depending the font size.

That sounds good to me.
Comment 6 Richard Marti (:Paenglab) 2012-08-28 11:41:09 PDT
Created attachment 656129 [details] [diff] [review]
patch

Patch only changing the width to 12ch. This saves on my system 40px. With this width the nick 'cricccoulson' is fully visible. With 10ch it is already shortend and has an ellipsis at the end.

If this patch is used on TB < 17 then calc() needs to be changed to -moz-calc()
Comment 7 Andreas Nilsson (:andreasn) 2012-09-07 06:21:51 PDT
Comment on attachment 656129 [details] [diff] [review]
patch

ch seems to give issues with bold text
Comment 8 Richard Marti (:Paenglab) 2012-09-08 08:50:55 PDT
*** Bug 789690 has been marked as a duplicate of this bug. ***
Comment 9 Richard Marti (:Paenglab) 2012-09-08 08:58:43 PDT
Created attachment 659491 [details] [diff] [review]
Patch v2

This patch is now using a width of 15% for the pseudo. To make a gap between pseudo and message I used calc(). For TBs <17 this would need -moz-calc(). To help to identify the pseudo when it's abbreviated, hovering it shows now a tooltip.
Comment 10 Andreas Nilsson (:andreasn) 2012-09-12 06:42:09 PDT
Comment on attachment 659491 [details] [diff] [review]
Patch v2

Looks good to me ui-wise and don't have the issue with boldtext that the previous patch had.
I'm also ok with the labels.
Comment 11 Florian Quèze [:florian] [:flo] 2012-09-13 05:40:52 PDT
Comment on attachment 659491 [details] [diff] [review]
Patch v2

Should we also take this for Thunderbird 16 and 17?
Comment 12 Richard Marti (:Paenglab) 2012-09-13 09:06:09 PDT
Comment on attachment 659491 [details] [diff] [review]
Patch v2

[Approval Request Comment]
This impoves the display on small screens
Comment 13 Richard Marti (:Paenglab) 2012-09-13 09:08:15 PDT
Created attachment 660862 [details] [diff] [review]
Patch for beta

[Approval Request Comment]
This improves the display on small screens.

The only change to the other patch is -moz-calc() instead of calc() which is supported beginning with Gecko 17.
Comment 14 Ryan VanderMeulen [:RyanVM] 2012-09-13 14:08:25 PDT
https://hg.mozilla.org/comm-central/rev/117fc5dee3ee

Note You need to log in before you can comment on or make changes to this bug.