Last Comment Bug 785186 - Use the context menu in the markup panel
: Use the context menu in the markup panel
Status: RESOLVED FIXED
[fixed-in-fx-team]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Inspector (show other bugs)
: 13 Branch
: x86 Mac OS X
: -- normal (vote)
: Firefox 17
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 785421 (view as bug list)
Depends on:
Blocks: 777085
  Show dependency treegraph
 
Reported: 2012-08-23 12:19 PDT by Dave Camp (:dcamp)
Modified: 2012-08-25 17:02 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (6.31 KB, patch)
2012-08-23 12:19 PDT, Dave Camp (:dcamp)
jwalker: review+
Details | Diff | Splinter Review

Description Dave Camp (:dcamp) 2012-08-23 12:19:30 PDT
Created attachment 654733 [details] [diff] [review]
v1

This re-enables the context menu in the new markup panel.

Things get a little tricky because the markup panel and inspector don't necessarily agree on the selection (See bug 785180).
Comment 1 Dave Camp (:dcamp) 2012-08-24 09:57:30 PDT
*** Bug 785421 has been marked as a duplicate of this bug. ***
Comment 2 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-08-24 11:22:21 PDT
Comment on attachment 654733 [details] [diff] [review]
v1

Review of attachment 654733 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/devtools/highlighter/inspector.jsm
@@ +1203,5 @@
>          break;
>      }
>    },
>  
> +  // Return the currently-selected node for the purposes of the

If we care about comment style, then we might /**...*/ this.
Comment 4 Dave Camp (:dcamp) 2012-08-25 17:02:39 PDT
https://hg.mozilla.org/mozilla-central/rev/9b58a0a085ee

Note You need to log in before you can comment on or make changes to this bug.