[devhub] Landing page for SDK section

RESOLVED WONTFIX

Status

Marketplace
Developer Pages
P1
normal
RESOLVED WONTFIX
6 years ago
6 years ago

People

(Reporter: wenzel, Assigned: wenzel)

Tracking

Points:
---

Details

(Whiteboard: [devhub-v1])

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
Please make a landing page for the SDK section that looks similar to the dev section landing page, but outlines our different tools.

Suggested, rough, wordage:

---
**Firefox Developer Tools**

Powerful Development tools for Apps development, built right into Mozilla Firefox.

---
** Open Web Apps Development Templates**

Templates and tools to get started with apps development quickly, featuring HTML5 Boilerplate, an Open Web App manifest, simple appcache generation and more.

---
**HTML5 UI Components**

"x-tags" are powerful, custom UI components to make apps development in HTML6 quicker and easier.
---
(Assignee)

Comment 1

6 years ago
(In reply to Fred Wenzel [:wenzel] from comment #0)
> HTML6

... which is so much better than HTML5!

(oops)
Everywhere we were using X-Tags, I'd like to go with "Custom Elements" and have "(via X-Tag)" next to it. This way we rep the tech itself first instead of the polymimic implementation ;)
(Assignee)

Comment 3

6 years ago
Okay how about:

---
**Firefox Developer Tools**

All the tools you need, built right into Firefox.

---
** Open Web Apps Development Templates**

Start developing Open Web Apps quickly with powerful app templates using tools like HTML5 Boilerplate, appcache and more.

---
**Web Components**

Save time with easy-to-use HTML5 web components like Tab Box, Slider, and Date/Time Picker.
---
(link the component names to their respective sections in the design guidelines?)
Web Components is actually a conglomeration of 4 specs: Custom Elements, Shadow DOM, Templates, and Decorators - X-Tag only backfills capabilities for Custom Elements, so I feel this copy would be best:

**Custom Elements**

The Mozilla UI SDK offers a full catalog of custom elements - such as Tabbox, Slidebox, and Actionbar, all developed using X-Tag - that enable you to create apps faster than ever before.
(Assignee)

Updated

6 years ago
Duplicate of this bug: 784105
(Assignee)

Comment 6

6 years ago
Actually, do we need a landing page here? The other sections don't have a separate landing page and instead jump straight into the first section: In this case, we'd land on the Firefox Devtools section.
Assignee: jfong → fwenzel
I agree, no landing page is needed, it should be a block of intro with links to the W3 standard, X-Tags.org, and the registry, followed by a list of all the tags with a single line description and an icon. Clicking on a tag item takes you to a demo of that tag.
Created attachment 655709 [details]
power icon for "Gettings Started"

power icon added for "Getting Started"
That last icon/comment was intended for this bug: https://bugzilla.mozilla.org/show_bug.cgi?id=784077
(Assignee)

Comment 10

6 years ago
okay wontfixing for now
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.