Closed Bug 785496 Opened 7 years ago Closed 7 years ago

Marketplace app installs 4 shortcuts on dekstop

Categories

(Firefox for Android :: Web Apps, defect, P1)

16 Branch
ARM
Android
defect

Tracking

()

VERIFIED FIXED
Firefox 18
Tracking Status
firefox17 --- verified
firefox18 --- verified

People

(Reporter: chelsea, Unassigned)

References

Details

(Whiteboard: [blocking-webrtandroid1+])

Attachments

(2 files)

Screencap attached: http://cl.ly/image/1Y0s1C371Z0N

Galaxy S2 running ICS

Please let me know if you need more details.
This is awesome. I can reproduce this on the Galaxy SII too.

STR:

i) With a new profile, launch Nightly
ii) Tap the Mozilla Market Promotion, or visit the Mozilla Marketplace link in about:apps
iii) Wait a couple seconds for the Mozilla Marketplace to load; and tap the opt-in 'Open' in the door-hanger

--
Nightly (08/24)
Samsung Galaxy SII (Android 4.0.4)
OS: Linux → Android
Hardware: x86_64 → ARM
Whiteboard: [blocking-webrtandroid1?]
Blocks: 741621
Priority: -- → P1
Whiteboard: [blocking-webrtandroid1?] → [blocking-webrtandroid1+]
Attached patch PatchSplinter Review
We're getting into a loop here while we install the webapp. We send a message from HelperApps to java to launch the Marketplace App, which sends a message to us to install the marketplace, which sends a message from HelperApps to launch the app, etc. Apparently it takes about 4 rounds on some devices before the app is installed and we bail out of the loop.

We already have code to launch the app once its installed. This disabled the HelperApps code for callers that pass in a callback.
Attachment #660968 - Flags: review?(mark.finkle)
Attachment #660968 - Flags: review?(mark.finkle) → review+
Comment on attachment 660968 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 741621
User impact if declined: Multiple icons
Testing completed (on m-c, etc.): Landed 9/13
Risk to taking this patch (and alternatives if risky): Low risk. Mobile webapps only (for now since helper apps isn't used by anything else).
String or UUID changes made by this patch: None.
Attachment #660968 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/7102138abfb0
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 18
Attachment #660968 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified fixed on: 

Build: Firefox 18.0a1 (2012-09-17)
Device: Samsung Galaxy Nexus
OS: Android 4.1.1

Waiting to land on Aurora also.
Status: RESOLVED → VERIFIED
Verified fixed on: 

Build: Firefox 17.0a2 (2012-09-20)
Device: Samsung Galaxy Nexus
OS: Android 4.1.1
You need to log in before you can comment on or make changes to this bug.