Cannot delete bookmarks with Delete key on keyboard

VERIFIED FIXED in mozilla0.9.1

Status

SeaMonkey
Bookmarks & History
P1
normal
VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: Lynn Webb, Assigned: Fabian Guisset)

Tracking

Trunk
mozilla0.9.1
x86
All

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Steps to reproduce:

Under the Bookmarks menu, select Manage Bookmarks.
In the bookmarks manager, if I select a bookmark and click on the Delete key on 
the keyboard, the bookmark is not removed. I have to use another method to 
remove the bookmark.
(Reporter)

Updated

17 years ago
Keywords: rtm

Comment 1

17 years ago
Yes, the only way to delete a bookmark is to use context menu.


*** This bug has been marked as a duplicate of 76502 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

17 years ago
I am reopening this bug. The other bug refers to Mozilla freezing when a user 
tries to delete a bookmark. This is a separate issue.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 3

17 years ago
you headed me off at the pass, lynnw. ;-)
Yup.  Can't delete from the the edit menu or the delete button on the toolbar
menu.  Can only delete from the context menu.
Whiteboard: nsbeta1

Comment 5

17 years ago
Looks like a dup of bug 76964.
(Assignee)

Comment 6

17 years ago
Created attachment 33347 [details] [diff] [review]
Fix this bug. Minimal fix, doesn't include all the commands changes. Just make this work.
(Assignee)

Comment 7

17 years ago
Patch attached fixes this bug. Only this bug. In a next patch I will do the
right thing with all the "command" instead of "observes" etc, but in the
meantime, this will reenable the "del" key and the "Delete" button in the toolbar.
Please r=/sr=, thanks.
Reassing to myself.
Note: the previous patch doesn't fix the Edit menu wrt to deleting. Attaching a
new patch.
Assignee: ben → hidday
Status: REOPENED → NEW
OS: Windows NT → All
Priority: -- → P1
Target Milestone: --- → mozilla0.9.1
(Assignee)

Comment 8

17 years ago
Turns out enabling the delete menu item of the Edit menu is harder than I first
thought, it will be part of a larger patch that I will attach in a new bug.
The previous will enable the (most used) delete key and delete icon in the
toolbar. Please r=/sr= this patch, thanks.
Status: NEW → ASSIGNED

Comment 9

17 years ago
Code looks good, and I verified that it works. r=hwaara
Keywords: rtm

Comment 10

17 years ago
*** Bug 79102 has been marked as a duplicate of this bug. ***

Comment 11

17 years ago
sr=alecf

Comment 12

17 years ago
nav triage team:

Get this thing in. Marking nsbeta1+ because we think it's important.
Keywords: nsbeta1+
Whiteboard: nsbeta1
(Assignee)

Comment 13

17 years ago
Fixed. Marking as such.
Please note that the delete key and the delete button in the toolbar will work,
but not the menuitem in the edit menu. Like I said I have a patch for that in my
tree that I will be attaching in another bug, because it is a more general
problem. Thanks for the reviews.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED
(Assignee)

Comment 14

17 years ago
*** Bug 79226 has been marked as a duplicate of this bug. ***

Comment 15

17 years ago
the delete key works. VERIFIED Fixed with 20010511 builds
Status: RESOLVED → VERIFIED
(Assignee)

Comment 16

17 years ago
*** Bug 80645 has been marked as a duplicate of this bug. ***

Comment 17

17 years ago
*** Bug 80798 has been marked as a duplicate of this bug. ***

Comment 18

17 years ago
*** Bug 81891 has been marked as a duplicate of this bug. ***

Comment 19

17 years ago
*** Bug 82848 has been marked as a duplicate of this bug. ***

Comment 20

17 years ago
I think it should be reopened : With the left side bar , and with a right mouse
click, You can not delete any bookmark. You ere able to do that with the
bookmark tab.
Working with mozilla 2001053004
(Assignee)

Comment 21

17 years ago
Alberto, this bug does not cover the sidebar. This was only for the bookmarks
manager, and is indeed fixed. Please do not extend the scope of bugs. The bug
you are seeing is bug 82967 and will be fixed for 0.9.1.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.