Closed Bug 785921 Opened 10 years ago Closed 10 years ago

If related screenshots/videos are 404ing, don't show the screenshot block on Consumer pages

Categories

(Marketplace Graveyard :: Consumer Pages, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: krupa.mozbugs, Unassigned)

References

()

Details

(Whiteboard: [janus])

Attachments

(1 file, 1 obsolete file)

Attached image screenshot (obsolete) —
steps to reproduce:
1. Pick an app where the associated screenshot/video is 404'ing
- https://marketplace-dev.allizom.org/search/?q=packaged
- https://marketplace-dev.allizom.org/app/packaged-mozillaball-%E3%82%87-1/?src=
2. Notice the screenshot section

observed behavior:
If related screenshots/videos are 404ing, don't show the screenshot block on Consumer pages


See attached screenshot.
Wrong screenshot? And why are they 404'ing to begin with?
Blocks: 766199
No longer blocks: 756282
yeah, the problem here are that assets are 404ing.  Is this still a problem or has it been fixed along the way?
No longer blocks: 766199
Attached image screenshot
We need to compensate for the fact that sometimes uploaded images may get into a wonky state. Ideally, screenshots will never 404 but if they do, we should fail gracefully.
Attachment #655625 - Attachment is obsolete: true
(In reply to krupa raj 82[:krupa] from comment #3)
> Created attachment 659387 [details]
> screenshot
> 
> We need to compensate for the fact that sometimes uploaded images may get
> into a wonky state. Ideally, screenshots will never 404 but if they do, we
> should fail gracefully.

Letting something get in a wonky state is unacceptable.  If you have links or STR let's focus on that.  Having things not show up if they are a 404 is a nice idea until you're the developer uploading an image that is mysteriously not showing up.  If it's showing up as a big black blob or as a rainbow of pixels or whatever, that helps them and us know something is wrong.  Remember when people uploaded transparent PNGs and our converter turned the transparent parts black?  It was helpful to know that to track it down.

I'm wontfixing this - we should apply development time to fixing wonkiness, not patching around it.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.