Corrupt non-latin text into debugger

RESOLVED FIXED in Firefox 18

Status

()

Firefox
Developer Tools: Debugger
P2
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: ru-vadik, Assigned: past)

Tracking

15 Branch
Firefox 18
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed-in-fx-team])

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 655895 [details]
Screenshot

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0
Build ID: 20120824154833

Steps to reproduce:

1. Open http://javascript.ru/alert
2. Open debugger
3. Select alert file
4. Go to line 267 into degugger

Result - <td class="thead">Поиск по форуму</td>


Actual results:

Always.


Expected results:

<td class="thead">Поиск по форуму</td>
(Reporter)

Updated

5 years ago
Component: Untriaged → Developer Tools: Debugger
(Assignee)

Comment 1

5 years ago
We have the same issue as the Style Editor. Bug 747820 has code that looks like we could share.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

5 years ago
Duplicate of this bug: 786910

Updated

5 years ago
Summary: Corrupt Cyrilic text into debugger → Corrupt non-latin text into debugger
(Assignee)

Updated

5 years ago
Assignee: nobody → past
Status: NEW → ASSIGNED
Priority: -- → P2
(Assignee)

Comment 3

5 years ago
Created attachment 660005 [details] [diff] [review]
[in-fx-team] Patch v1

This fixes bug 789778 as well.
Attachment #660005 - Flags: review?(mihai.sucan)
(Assignee)

Updated

5 years ago
Duplicate of this bug: 789778
(Assignee)

Comment 5

5 years ago
Try: https://tbpl.mozilla.org/?tree=Try&rev=6903f23db920
Comment on attachment 660005 [details] [diff] [review]
[in-fx-team] Patch v1

Review of attachment 660005 [details] [diff] [review]:
-----------------------------------------------------------------

Patch looks good. All tests pass. Thanks!

One concern: you only use the channel.contentCharset to determine the correct encoding. Is this sufficient? In the case of CSS there's more code logic to determine the actual charset. This might be for some other day...
Attachment #660005 - Flags: review?(mihai.sucan) → review+
(Assignee)

Comment 7

5 years ago
(In reply to Mihai Sucan [:msucan] from comment #6)
> Patch looks good. All tests pass. Thanks!
> 
> One concern: you only use the channel.contentCharset to determine the
> correct encoding. Is this sufficient? In the case of CSS there's more code
> logic to determine the actual charset. This might be for some other day...

I'm not aware of any other ways (like @charset) to set the charset for scripts. We could file followups if anyone comes up with a problematic case.
(In reply to Panos Astithas [:past] from comment #7)
> (In reply to Mihai Sucan [:msucan] from comment #6)
> > Patch looks good. All tests pass. Thanks!
> > 
> > One concern: you only use the channel.contentCharset to determine the
> > correct encoding. Is this sufficient? In the case of CSS there's more code
> > logic to determine the actual charset. This might be for some other day...
> 
> I'm not aware of any other ways (like @charset) to set the charset for
> scripts. We could file followups if anyone comes up with a problematic case.

I'm not aware of such things either, but the page charset might be taken into consideration when the channel content charset is missing. Anyway, let's leave this as is - if someone finds more problematic cases a new bug shall be filed.
Comment on attachment 660005 [details] [diff] [review]
[in-fx-team] Patch v1

Landed:
https://hg.mozilla.org/integration/fx-team/rev/07175a2efd99
Attachment #660005 - Attachment description: Patch v1 → [in-fx-team] Patch v1

Updated

5 years ago
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/07175a2efd99
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 18
You need to log in before you can comment on or make changes to this bug.