first popup of flyout panel doesn't show arrow

RESOLVED FIXED in Firefox 17



6 years ago
4 years ago


(Reporter: mixedpuppy, Assigned: mixedpuppy)


Firefox 18
Mac OS X
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox17 verified)


(Whiteboard: [Fx17])


(1 attachment)



6 years ago
images showing this are in bug 785952, and per comment #7 we should set the side attribute to fix this.

Comment 1

6 years ago
Created attachment 656062 [details] [diff] [review]
arrow patch
Attachment #656062 - Flags: review?(
Why does this only affect the first popup?

Comment 3

6 years ago
Neil, (In reply to :Gavin Sharp (use for email) from comment #2)
> Why does this only affect the first popup?

TBH I'm not certain, but I think it has to do with setting up display prior to css being set during popupshowing.  I haven't traced everything through the boxobject class, there's a lot to digest.  Maybe Neil can give a more informed answer?

Comment 4

6 years ago
The side attribute can be computed dynamically based on where the panel is opened, the position of which can be specified differently for each call to openPopup. However, the computations only work when the horizontal or vertical arrangement is known beforehand (defaulting to vertical like the bookmarks panel). This issue can also occur if you open a popup to the side and then open it vertically. Since changing the orientation isn't a normal operation (indeed, we haven't seen usage of side arrow panels yet), the arrow panels don't currently handle it.
Attachment #656062 - Flags: review?( → review+

Comment 6

6 years ago
Comment on attachment 656062 [details] [diff] [review]
arrow patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: initial open of social side panel fails to show correctly
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): 
String or UUID changes made by this patch: none
Attachment #656062 - Flags: approval-mozilla-aurora?
Attachment #656062 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+


6 years ago
Keywords: checkin-needed
status-firefox17: --- → fixed
status-firefox18: --- → fixed
Flags: in-testsuite-
Keywords: checkin-needed
status-firefox18: fixed → ---
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 18
Keywords: verifyme
QA Contact:
This issue is fixed on Firefox 17 Release Candidate, User Agent:Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:17.0) Gecko/17.0 Firefox/17.0, Build ID: 20121116115405. (the arrow is visible)

Marking this as verified.
status-firefox17: fixed → verified
mass remove verifyme requests greater than 4 months old
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.