Closed Bug 786334 Opened 8 years ago Closed 6 years ago

Feature Request: Implement dynamic promo banner in about:home

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 905262

People

(Reporter: smott, Unassigned)

References

(Depends on 1 open bug)

Details

Attachments

(1 file)

Attached image Promo Slot
This is a feature request to make the Promo Banner on Firefox for Android dynamic and adjustable. 

Currently, on the start-up page for Firefox for Android, we have a promotional graphic that up-sells the sync feature (see attached). If we could change this featuring to enable back-end changes to the messaging and the icon, we would be able to leverage an in-app communication method. Some of the things we could do are:
   -Promote new features
   -Engage with our users (Surveys, feedback solicitation, etc...)
   -Cross promote desktop
   -Feature add-ons

To make this work, we would need a server side capability to change the:
   -Link
   -Copy
   -Graphic
   -Background

It would also be ideal if we could run multiple promotions at the same time. This would help with A/B testing, as well as other things.
Assignee: smott → nobody
Summary: Feature Request: Implement Dynamic Promo Banner for Firefox for Android → Feature Request: Implement dynamic promo banner in about:home
mfinkle is thinking about overlaps here with product announcements and campaign manager.
OS: Mac OS X → Android
Hardware: x86 → ARM
Depends on: 839129
mfinkle, is the use case described here covered by the snippet work happening for the new about:home? If so, can this bug be closed?
Flags: needinfo?(mark.finkle)
Yes, this was covered by bug 905262.

See this blog post for an example of how an add-on could use this banner API to dynamically pull content from a server:
http://blog.margaretleibovic.com/post/62378620575/home-page-snippets-for-firefox-for-android
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(mark.finkle)
Resolution: --- → DUPLICATE
Duplicate of bug: 905262
You need to log in before you can comment on or make changes to this bug.