The default bug view has changed. See this FAQ.

add way to pref off typed array move

RESOLVED FIXED in Firefox 16

Status

()

Core
JavaScript Engine
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: sfink, Assigned: sfink)

Tracking

unspecified
mozilla18
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox16+ fixed, firefox17+ fixed, firefox18+ fixed)

Details

(Whiteboard: [js:t][qa-])

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

5 years ago
Bug 730873 adds a move() operation to typed arrays. It may need to be preffed off (see bug 730873 comment 20 and following). We should add a way to do that easily, and for now we'll plan on turning it off before release.
(Assignee)

Updated

5 years ago
Blocks: 730873
Since this landed in the 16 cycle, it needs to be turned off before 16 ships, I believe.
tracking-firefox16: --- → ?
We'll track then to see that this is turned off, can someone be assigned to this and have a patch ready with approval nom?
tracking-firefox16: ? → +
(Assignee)

Updated

5 years ago
Assignee: general → sphink
Whiteboard: [js:t]
(Assignee)

Comment 3

5 years ago
Created attachment 660605 [details] [diff] [review]
Add easy way to disable typed array move() method

Waldo would be the natural one for r?, but he's partially out right now.

This patch leaves move() enabled, but adds a way to disable in one line.
Attachment #660605 - Flags: review?(dmandelin)
(Assignee)

Comment 4

5 years ago
Created attachment 660606 [details] [diff] [review]
Disable typed array move() command

And this one does the actual disable.
Attachment #660606 - Flags: review?(dmandelin)
(Assignee)

Comment 5

5 years ago
Created attachment 660614 [details] [diff] [review]
Add easy way to disable typed array move() method
Attachment #660614 - Flags: review?(dmandelin)
(Assignee)

Updated

5 years ago
Attachment #660605 - Attachment is obsolete: true
Attachment #660605 - Flags: review?(dmandelin)
Attachment #660606 - Flags: review?(dmandelin) → review+
Attachment #660614 - Flags: review?(dmandelin) → review+
(Assignee)

Comment 6

5 years ago
http://hg.mozilla.org/integration/mozilla-inbound/rev/e4ae0aa3d663
(Assignee)

Comment 7

5 years ago
Comment on attachment 660614 [details] [diff] [review]
Add easy way to disable typed array move() method

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 730873

User impact if declined: a move() method that is not part of the any spec will be exposed to web content, allowing web developers to start creating potential backwards-compatibility problems.

Testing completed (on m-c, etc.): local testing, very recently landed on m-i.
 
Risk to taking this patch (and alternatives if risky): extremely low. Applying this patch does not change the preprocessed code at all. The followup patch is needed to actually change something.

String or UUID changes made by this patch: none
Attachment #660614 - Flags: approval-mozilla-beta?
Attachment #660614 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 8

5 years ago
Comment on attachment 660606 [details] [diff] [review]
Disable typed array move() command

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 730873

User impact if declined: new method move() on typed arrays exposed to web content. move() is not yet part of any spec, so exposing it introduces backwards compatibility risk.

Testing completed (on m-c, etc.): local only (for now, this should only land on beta since we want to leave the new method enabled on aurora)

Risk to taking this patch (and alternatives if risky): Minimal
 
String or UUID changes made by this patch: none

This patch requires the other patch in this bug, which added the ENABLE_TYPEDARRAY_MOVE preprocessor macro.
Attachment #660606 - Flags: approval-mozilla-beta?
(Assignee)

Comment 9

5 years ago
Requesting tracking flags for 17 and 18 as well, since this will still be an issue until move() is added to the spec or people agree that we can add it in.
tracking-firefox17: --- → ?
tracking-firefox18: --- → ?
https://hg.mozilla.org/mozilla-central/rev/e4ae0aa3d663
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla18
tracking-firefox17: ? → +
tracking-firefox18: ? → +
Attachment #660606 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #660614 - Flags: approval-mozilla-beta?
Attachment #660614 - Flags: approval-mozilla-beta+
Attachment #660614 - Flags: approval-mozilla-aurora?
Attachment #660614 - Flags: approval-mozilla-aurora+
(Assignee)

Comment 11

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/e237933d2b08 (only the addition of the #define; still enabled on aurora)
(Assignee)

Comment 12

5 years ago
https://hg.mozilla.org/releases/mozilla-beta/rev/9faa4ad41e23
https://hg.mozilla.org/releases/mozilla-beta/rev/b5c1c48202a7
(Assignee)

Updated

5 years ago
status-firefox16: --- → fixed
status-firefox17: --- → affected
status-firefox18: --- → affected
Target Milestone: mozilla18 → mozilla16
(Assignee)

Comment 13

5 years ago
Messed up the rebase for beta.

https://hg.mozilla.org/releases/mozilla-beta/rev/2f8a5f915a15

Updated

5 years ago
status-firefox17: affected → fixed
status-firefox18: affected → fixed
Target Milestone: mozilla16 → mozilla18
(Assignee)

Comment 14

5 years ago
Scoobidiver: are those status markings accurate? This feature is *not* yet disabled for either 17 or 18, and we don't know yet know whether we want it to be enabled or disabled. To the naive observer (namely, me), tracking-firefox17+ and status-firefox17=fixed implies that nothing else needs to be done. Should I open a separate bug?

Comment 15

5 years ago
(In reply to Steve Fink [:sfink] from comment #14)
> Scoobidiver: are those status markings accurate?  This feature is *not* yet
> disabled for either 17 or 18, and we don't know yet know whether we want it
> to be enabled or disabled.
In Aurora, the changeset is http://hg.mozilla.org/releases/mozilla-aurora/rev/e237933d2b08 that matches the second patch.
In Beta, they are http://hg.mozilla.org/releases/mozilla-beta/rev/9faa4ad41e23 (second patch), http://hg.mozilla.org/releases/mozilla-beta/rev/b5c1c48202a7 (first patch), and http://hg.mozilla.org/releases/mozilla-beta/rev/2f8a5f915a15 (second patch partially backed out).

> tracking-firefox17+ and status-firefox17=fixed implies that nothing else
> needs to be done. Should I open a separate bug?
Yes because these patches are such a mess it's hard to follow.
Whiteboard: [js:t] → [js:t][qa-]
(Assignee)

Updated

5 years ago
Blocks: 803288
You need to log in before you can comment on or make changes to this bug.