Last Comment Bug 803288 - Disable typed array move() operator for beta
: Disable typed array move() operator for beta
Status: RESOLVED FIXED
[js:t]
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Steve Fink [:sfink] [:s:]
:
Mentors:
Depends on: 786386
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-18 14:45 PDT by Steve Fink [:sfink] [:s:]
Modified: 2013-01-23 16:04 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed
-
-


Attachments
Disable typed array move() operator for beta (1.05 KB, patch)
2012-10-18 14:45 PDT, Steve Fink [:sfink] [:s:]
dmandelin: review+
lukasblakk+bugs: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description Steve Fink [:sfink] [:s:] 2012-10-18 14:45:37 PDT
ArrayBufferView.move is not (yet?) spec'ed, so we don't want it to slip into a release.
Comment 1 Steve Fink [:sfink] [:s:] 2012-10-18 14:45:55 PDT
Created attachment 672968 [details] [diff] [review]
Disable typed array move() operator for beta

This is pretty much the same as https://bugzilla.mozilla.org/attachment.cgi?id=660606 but given that this is going to be landed on beta, I'd rather not just inherit the r+.
Comment 2 Steve Fink [:sfink] [:s:] 2012-10-18 14:51:43 PDT
Requesting tracking for all releases beta and on because this needs to be re-done for every beta. See also bug 803276.
Comment 3 Steve Fink [:sfink] [:s:] 2012-10-19 12:49:17 PDT
Comment on attachment 672968 [details] [diff] [review]
Disable typed array move() operator for beta

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 730873

User impact if declined: new method move() on typed arrays exposed to web content. move() is not yet part of any spec, so exposing it introduces backwards compatibility risk.

Testing completed (on m-c, etc.): this patch is more or less present on current release, and has been since it was beta

Risk to taking this patch (and alternatives if risky): Minimal
 
String or UUID changes made by this patch: none

This same change was previously approved for the last beta in bug 786386.
Comment 4 Alex Keybl [:akeybl] 2012-10-19 15:25:51 PDT
(In reply to Steve Fink [:sfink] from comment #2)
> Requesting tracking for all releases beta and on because this needs to be
> re-done for every beta. See also bug 803276.

We'll approve the current patch for beta, but please make a follow up for Aurora 18 and Nightly 19 such that this pref is automatically disabled on the Beta/Release channels. We shouldn't need to perform the same back out every release.
Comment 5 Steve Fink [:sfink] [:s:] 2012-10-19 15:39:54 PDT
(In reply to Alex Keybl [:akeybl] from comment #4)
> (In reply to Steve Fink [:sfink] from comment #2)
> > Requesting tracking for all releases beta and on because this needs to be
> > re-done for every beta. See also bug 803276.
> 
> We'll approve the current patch for beta, but please make a follow up for
> Aurora 18 and Nightly 19 such that this pref is automatically disabled on
> the Beta/Release channels. We shouldn't need to perform the same back out
> every release.

I don't think we have a proper mechanism for that, which is why I filed bug 803276. Please weigh in on that bug, since I like the status quo even less than you do.
Comment 6 Lukas Blakk [:lsblakk] use ?needinfo 2012-10-21 09:41:13 PDT
Comment on attachment 672968 [details] [diff] [review]
Disable typed array move() operator for beta

Thanks for filing bug 803276, go ahead and do the disabling on beta branch.
Comment 7 Lukas Blakk [:lsblakk] use ?needinfo 2012-10-25 09:41:29 PDT
Please get this landed to beta asap so it's in our next Beta release.
Comment 8 Steve Fink [:sfink] [:s:] 2012-10-25 15:12:21 PDT
http://hg.mozilla.org/releases/mozilla-beta/rev/8c6312b2da71
Comment 9 Alex Keybl [:akeybl] 2012-11-07 17:26:22 PST
We'll start tracking this for 18/19 if bug 803276 doesn't end up being the final solution.
Comment 10 Alex Keybl [:akeybl] 2012-11-09 15:40:38 PST
Bug 803276 means we no longer need to track this for release.

Note You need to log in before you can comment on or make changes to this bug.