Last Comment Bug 786420 - new Volume Control Scrubber seems displaced horizontally
: new Volume Control Scrubber seems displaced horizontally
Status: RESOLVED FIXED
: regression
Product: Toolkit
Classification: Components
Component: Themes (show other bugs)
: 17 Branch
: All All
: -- normal (vote)
: mozilla18
Assigned To: Jared Wein [:jaws] (please needinfo? me)
:
Mentors:
http://videos-cdn.mozilla.net/serv/qa...
Depends on:
Blocks: 780433
  Show dependency treegraph
 
Reported: 2012-08-28 12:51 PDT by (mostly gone) XtC4UaLL [:xtc4uall]
Modified: 2012-10-01 15:41 PDT (History)
5 users (show)
jaws: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed


Attachments
Screenshot showing the Issue (322.06 KB, image/png)
2012-08-28 12:53 PDT, (mostly gone) XtC4UaLL [:xtc4uall]
no flags Details
Patch (1.07 KB, patch)
2012-09-20 18:09 PDT, Jared Wein [:jaws] (please needinfo? me)
no flags Details | Diff | Splinter Review
Patch v2 (2.69 KB, patch)
2012-09-21 11:07 PDT, Jared Wein [:jaws] (please needinfo? me)
dolske: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description (mostly gone) XtC4UaLL [:xtc4uall] 2012-08-28 12:51:20 PDT
See Attachment.
Comment 1 (mostly gone) XtC4UaLL [:xtc4uall] 2012-08-28 12:53:13 PDT
Created attachment 656167 [details]
Screenshot showing the Issue

Arrg, hit Enter Key by Accident too early.

Reg Range: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=8af6a22827ec&tochange=8af2ff9c6018

likely by Bug 780433
Comment 2 Jared Wein [:jaws] (please needinfo? me) 2012-09-20 18:09:24 PDT
Created attachment 663233 [details] [diff] [review]
Patch

Silly image, off-by-one pixels are for kids!

I also used optimized the png size.
Comment 3 Matthew N. [:MattN] 2012-09-20 21:42:55 PDT
Comment on attachment 663233 [details] [diff] [review]
Patch

Is there reason the subject (16x8px) of the image isn't centered in the canvas (21x10px)? i.e. why not 20x10px?  Is the point of all the transparent pixels (alpha=0) in the image to provide a bigger clip target?
Comment 4 Jared Wein [:jaws] (please needinfo? me) 2012-09-21 11:07:19 PDT
Created attachment 663471 [details] [diff] [review]
Patch v2

No reason, I removed the extra column of pixels in this version of the patch and updated the CSS to reflect the change.

Asking dolske for review since he's a toolkit peer.
Comment 5 Justin Dolske [:Dolske] 2012-09-21 14:50:20 PDT
Comment on attachment 663471 [details] [diff] [review]
Patch v2

rs=me
Comment 6 Jared Wein [:jaws] (please needinfo? me) 2012-09-21 14:54:36 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/d1e20611089c
Comment 7 Alex Keybl [:akeybl] 2012-09-21 17:01:19 PDT
Agreed that we should take the visual fix on FF17, as it's affected. Tracking.
Comment 8 Ryan VanderMeulen [:RyanVM] 2012-09-21 19:52:39 PDT
https://hg.mozilla.org/mozilla-central/rev/d1e20611089c
Comment 9 Alex Keybl [:akeybl] 2012-09-28 16:01:38 PDT
(In reply to Ryan VanderMeulen from comment #8)
> https://hg.mozilla.org/mozilla-central/rev/d1e20611089c

Are we comfortable with an uplift at this point?
Comment 10 Jared Wein [:jaws] (please needinfo? me) 2012-09-28 16:06:15 PDT
Comment on attachment 663471 [details] [diff] [review]
Patch v2

Yeah, thanks for the reminder.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 780433
User impact if declined: awkward looking volume slider
Testing completed (on m-c, etc.): m-c for a week
Risk to taking this patch (and alternatives if risky): none expected
String or UUID changes made by this patch: none
Comment 11 Lukas Blakk [:lsblakk] use ?needinfo 2012-10-01 15:23:28 PDT
Been on m-c for a week, low risk, approving for Aurora.
Comment 12 Jared Wein [:jaws] (please needinfo? me) 2012-10-01 15:41:05 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/e2dd0df7f9cf

Note You need to log in before you can comment on or make changes to this bug.