The default bug view has changed. See this FAQ.

Moving a tab to a different window leaves other tabs shifted in the source window

RESOLVED FIXED in Firefox 17

Status

()

Firefox
Tabbed Browser
--
major
RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: emorley, Assigned: dao)

Tracking

({regression})

Trunk
Firefox 18
regression
Points:
---

Firefox Tracking Flags

(firefox17 verified)

Details

Attachments

(1 attachment)

http://hg.mozilla.org/mozilla-central/rev/8af2ff9c6018
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0

1) Start Nightly
2) Ctrl+N for a new window
3) Open several (3+) new tabs in each window
4) Drag the rightmost (though this probably happens for any of them) tab from one window to the other

Expected:
* Tab detaches & is dropped in the new window at the location of the cursor.
* Gap in tab bar on old window is filled by the other tabs moving into the space
* Tabs can be opened/closed/dragged/switched between on both windows without the wrong tab being operated on

Actual:
* Tab doesn't always drop at the correct location on the new window's tab bar
* The old window's tab bar is left with a gap
* Subsequent tab operations (switching, closing etc) occur on the wrong tab
(In reply to Ed Morley [:edmorley] from comment #0)
> * Subsequent tab operations (switching, closing etc) occur on the wrong tab

Also: middle mouse click (to close) some of the tabs on either window - you instead sometimes get a new tab opened (as though you had middle clicked on an empty space on the tab bar).
(Assignee)

Comment 2

5 years ago
(In reply to Ed Morley [:edmorley] from comment #0)
> * Tab doesn't always drop at the correct location on the new window's tab bar

I can't reproduce this. Please file a separate bug if you have STR.
OS: Windows 7 → All
Hardware: x86 → All
Summary: Tab dragging between Windows broken → Moving a tab to a different window leaves tabs shifted on the source window
(Assignee)

Updated

5 years ago
Summary: Moving a tab to a different window leaves tabs shifted on the source window → Moving a tab to a different window leaves other tabs shifted in the source window
(Assignee)

Comment 3

5 years ago
Created attachment 656390 [details] [diff] [review]
patch
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #656390 - Flags: review?(jaws)
(Assignee)

Updated

5 years ago
Duplicate of this bug: 786340
Attachment #656390 - Flags: review?(jaws) → review+
(Assignee)

Comment 5

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/b132293a4701
https://hg.mozilla.org/mozilla-central/rev/b132293a4701
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 18
(Assignee)

Comment 7

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/be605a6e4ade
status-firefox17: --- → fixed
Keywords: verifyme

Comment 8

5 years ago
Verified as fixed on Firefox 17 beta 1 - when moving a tab to a different window, there are no gaps left in the other window, the tab can be dropped in the wanted location and the tab operations can be properly done.

Verified on Windows 7, Ubuntu 12.04 and Mac OS X 10.7:
Mozilla/5.0 (Windows NT 6.1; rv:17.0) Gecko/17.0 Firefox/17.0
Mozilla/5.0 (X11; Linux i686; rv:17.0) Gecko/17.0 Firefox/17.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:17.0) Gecko/17.0 Firefox/17.0
status-firefox17: fixed → verified
mass remove verifyme requests greater than 4 months old
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.