Deleted template displays incorrect message body once deleted

RESOLVED FIXED in Thunderbird 18.0

Status

MailNews Core
Networking: IMAP
--
major
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Ian Neal, Assigned: Ian Neal)

Tracking

(Blocks: 1 bug, {regression})

Trunk
Thunderbird 18.0
x86_64
Linux
regression

Thunderbird Tracking Flags

(thunderbird15 unaffected, thunderbird16+ fixed, thunderbird17 fixed, thunderbird18 fixed, seamonkey2.12 unaffected, seamonkey2.13 fixed, seamonkey2.14 fixed, seamonkey2.15 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
STR using Daily 18.0a1 (2012-08-29) Build ID 20120829000550
1/ Using an IMAP account go to Trash folder, select properties from context menu and Repair Folder
2/ Go to Templates folder and create a Test Template.
3/ Go to Inbox, select a message
4/ From File menu, select Save As Template
5/ Go to Templates folder, select template created from message and make sure message body displays correctly
6/ Delete that template
7/ Go to Trash folder and select template you have just deleted.

Expected Result
1/ Message body is the correct one

Actual Result
1/ Message body is that of the test template

Notes
1/ View message source displays the correct message source
2/ Doing a "Repair Folder" on the trash folder corrects the issue
3/ Happens if you add multiple templates from inbox and then delete them
4/ Tested on Earlybird 16.0a2 (2012-08-27) also happens there
5/ Tested on TB 14.0 (Build ID 20120717093534) and works fine there
(Assignee)

Updated

5 years ago
Keywords: regressionwindow-wanted
(Assignee)

Comment 1

5 years ago
EB 15.0a2 Build ID 20120716042001 OK
EB 16.0a2 Build ID 20120717042008 Bad
(Assignee)

Comment 2

5 years ago
Daily 16.0a1 Build ID 20120619030501 OK
Daily 16.0a1 Build ID 20120620030501 Bad
(Assignee)

Comment 3

5 years ago
http://hg.mozilla.org/comm-central/pushloghtml?startdate=2012-06-19+03%3A05%3A01&enddate=2012-06-20+03%3A05%3A01 appears to be the list of pushes cc'ing likely people. Probably an IMAP issue -> MailNews Core: Network IMAP
Component: Message Reader UI → Networking: IMAP
Product: Thunderbird → MailNews Core
(Assignee)

Updated

5 years ago
status-seamonkey2.12: --- → unaffected
status-seamonkey2.13: --- → affected
status-seamonkey2.14: --- → affected
status-seamonkey2.15: --- → affected
status-thunderbird15: --- → unaffected
status-thunderbird16: --- → affected
status-thunderbird17: --- → affected
status-thunderbird18: --- → affected
Keywords: regressionwindow-wanted
tracking-thunderbird16: --- → +
(Assignee)

Comment 4

5 years ago
http://hg.mozilla.org/comm-central/rev/13c4be7e7d31 works
http://hg.mozilla.org/comm-central/rev/8c820d9d2612 fails
Looks like Bug 765926
Depends on: 765926
(Assignee)

Comment 5

5 years ago
Confirmed, backing out the fix from bug 765926 locally fixes the issue for me.
(Assignee)

Comment 6

5 years ago
Created attachment 658279 [details] [diff] [review]
Partial backout of patch from bug 765926 [Checked in: Comment 8]

This backs out the parts of the patch from bug 765926 that is not removal of redundant code. This fixes the issue locally.
Assignee: nobody → iann_bugzilla
Status: NEW → ASSIGNED
Attachment #658279 - Flags: review?(neil)

Comment 7

5 years ago
Comment on attachment 658279 [details] [diff] [review]
Partial backout of patch from bug 765926 [Checked in: Comment 8]

I assume you'll reopen bug 765926...
Attachment #658279 - Flags: review?(neil) → review+
(Assignee)

Comment 8

5 years ago
Comment on attachment 658279 [details] [diff] [review]
Partial backout of patch from bug 765926 [Checked in: Comment 8]

http://hg.mozilla.org/comm-central/rev/9fcf8235df70
Attachment #658279 - Attachment description: Partial backout of patch from bug 765926 → Partial backout of patch from bug 765926 [Checked in: Comment 8]
(Assignee)

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 18.0
(Assignee)

Updated

5 years ago
status-seamonkey2.15: affected → fixed
status-thunderbird18: affected → fixed
(Assignee)

Comment 9

5 years ago
Comment on attachment 658279 [details] [diff] [review]
Partial backout of patch from bug 765926 [Checked in: Comment 8]

[Approval Request Comment]
Regression caused by (bug #): 765926
User impact if declined: Issues with incorrect message body being displayed on deleted templates once they are in Trash folder on IMAP servers. Potentially causes issues moving messages from "Sent" to "Inbox" too on IMAP servers.
Testing completed (on c-c, etc.): tested locally, patch has been checked into c-c
Risk to taking this patch (and alternatives if risky): None known
Attachment #658279 - Flags: approval-comm-beta?
Attachment #658279 - Flags: approval-comm-aurora?
might this/765926 have caused corruption for moved messages?  I've been seeing bad message bodies for a couple weeks now, for some messages that I moved from Inbox to other folders.

such such issues are listed in https://bugzilla.mozilla.org/buglist.cgi?type1-0-0=substring;list_id=4364955;short_desc=message%20body%20header%20thread;field0-0-0=short_desc;bug_severity=blocker;bug_severity=critical;bug_severity=major;bug_severity=normal;type0-0-1=substring;field0-0-1=keywords;type1-0-1=allwordssubstr;resolution=---;classification=Client%20Software;classification=Components;chfieldto=Now;query_format=advanced;chfield=[Bug%20creation];chfieldfrom=2012-06-01;short_desc_type=anywordssubstr;type0-0-0=nowordssubstr;value0-0-0=news%20html%20smtp%20instant%20search%20chat%20mapi%20crash%20tool%20dialog%20sent%20sort%20date%20notif%20auth%20icon%20print%20alert%20send%20get%20count;field1-0-0=short_desc;product=MailNews%20Core;product=Thunderbird;field1-0-1=short_desc
Attachment #658279 - Flags: approval-comm-beta?
Attachment #658279 - Flags: approval-comm-beta+
Attachment #658279 - Flags: approval-comm-aurora?
Attachment #658279 - Flags: approval-comm-aurora+
Checked in:

https://hg.mozilla.org/releases/comm-aurora/rev/677e495fe144
https://hg.mozilla.org/releases/comm-beta/rev/eee7d015fba5
status-seamonkey2.13: affected → fixed
status-seamonkey2.14: affected → fixed
status-thunderbird16: affected → fixed
status-thunderbird17: affected → fixed
Blocks: 765926
No longer depends on: 765926
You need to log in before you can comment on or make changes to this bug.