Remove ellipsis from "Site Settings..." menu item string

RESOLVED FIXED in Firefox 23

Status

()

--
minor
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: ioana.chiorean, Assigned: Margaret)

Tracking

({uiwanted})

17 Branch
Firefox 23
ARM
Android
uiwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: ui-hackathon)

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
Created attachment 656809 [details]
Screenshot

Build ID: 17.0a2 (2012-08-29) Aurora Channel
Device: Galaxy Nexus 
OS: Android 4.0.4

Steps to reproduce:
1. Open Fennec 
2. Press long the URL bar

Expected result:
- Urlbar context menu should be consistent, following same rules for display

Actual result:
- The new added option Site settings presents 3 dots after it: Site Settings....

Note: 
- bug 781900 tracks the decision to move site preferences menu item to the urlbar context menu
The intention is to use "..." for any action the requires more user attention. In this case a dialog appears for the user to manage the site settings.

Adding Ian so UX can provide thoughts
(Reporter)

Comment 2

6 years ago
If this is the intention to have ".." (2 not 3 dots)  we should take into account also share option for consistency. Share also implies an action the requires more user attention.
We're using the unicode ellipsis character, so it is probably dependent on your system font? On all my devices it is three dots.

http://mxr.mozilla.org/mozilla-central/source/mobile/android/base/locales/en-US/android_strings.dtd#154
(Reporter)

Comment 4

6 years ago
There are 3 dots, yes. I made a mistake in comment 2.
(Assignee)

Comment 5

6 years ago
I agree that this ellipsis is inconsistent. Even if it does follow the interaction pattern of "the user needs to do more", it's the only ellipsis we use in a menu item in the product. Also, there are actually other items that end up requiring more action, such as "Share", that don't have an ellipsis.

Are there any Android UX guidelines on this? I'd really like to get rid of it.
Flags: needinfo?(ibarlow)
Keywords: uiwanted
Summary: Inconsistency in urlbar context menu : site settings.. → Remove ellipsis from "Site Settings..." menu item string
Created attachment 721165 [details]
menu example

I don't know of any Android guideline that frowns on ellipses, but we actually started using a little carat in our overflow menu to indicate there is another level to the interaction. 

For consistency's sake, it would make sense to use that here instead of the ellipsis.
Flags: needinfo?(ibarlow)
(Assignee)

Updated

6 years ago
Whiteboard: ui-hackathon
(Assignee)

Comment 7

6 years ago
(In reply to Ian Barlow (:ibarlow) from comment #6)

> I don't know of any Android guideline that frowns on ellipses, but we
> actually started using a little carat in our overflow menu to indicate there
> is another level to the interaction. 

How important is this carat? I ask mainly because I'm lazy, but partially because I think that the user will understand that "Site Settings" is going to take them somewhere else. I think the ellipsis was initially introduced (and much more important) when this string used to be "Clear Site Settings...".
(Assignee)

Updated

6 years ago
Assignee: nobody → margaret.leibovic
Another non-caraty approach might be to use a verb to make the "Site settings" item read the same way as everything else in the list. So something like

'Show site settings'
or
'Edit site settings'
(Assignee)

Comment 9

6 years ago
Created attachment 741967 [details] [diff] [review]
patch

I think no caret is nice for staying consistent with all our other context menu items. I decided to go with "Edit Site Settings", since this item brings up a dialog that asks 

While I was messing around with these strings, I decided to update the dialog title to simply be "Site Settings". Right now we're reusing the same string for this dialog title and for the context menu item, and that doesn't really make sense.

Eventually it would be nice to replace this dialog with better UI, but I think these are some good improvements in the meantime.
Attachment #741967 - Flags: review?(wjohnston)
(In reply to :Margaret Leibovic from comment #9)

> Eventually it would be nice to replace this dialog with better UI, but I
> think these are some good improvements in the meantime.

Agreed.
Attachment #741967 - Flags: review?(wjohnston) → review+
https://hg.mozilla.org/mozilla-central/rev/b9064e2ab1e2
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 23
You need to log in before you can comment on or make changes to this bug.