Closed Bug 781900 Opened 7 years ago Closed 7 years ago

Move site preferences menu item to the urlbar context menu

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 17

People

(Reporter: wesj, Assigned: wesj)

References

Details

Attachments

(2 files)

We can remove this item from our default menu and add it to the urlbar context menu (Later we could add it to the awesomescreen too? but don't want to distract from the easier fix here...).
Adding Ian. This would be an easy win to remove a rarely used menuitem from the main menu.
Awesome idea. It might make sense to change the menu title to simply read "Site Settings", instead of "Clear Site Settings" as well -- you don't always open this item to clear everything out, sometimes you might just turn one thing on or off.
tracking-fennec: --- → ?
OS: Linux → Android
Hardware: x86 → ARM
Attached patch Patch 1/2Splinter Review
This moves the menu item. Doing the strings in a separate patch so that we can uplift this easier.
Attachment #652873 - Flags: review?(mark.finkle)
This changes this string to "Site Settings…".
Attachment #652875 - Flags: review?(mark.finkle)
Comment on attachment 652873 [details] [diff] [review]
Patch 1/2

You added to GeckoApp.java because that's where the context menu handler is now. Should that be moved to BrowserApp in a new bug?
Attachment #652873 - Flags: review?(mark.finkle) → review+
Comment on attachment 652875 [details] [diff] [review]
Strings Patch 2/2

I like how we didn't need to change any other files because the entity in strings.xml.in did not need to change.
Attachment #652875 - Flags: review?(mark.finkle) → review+
Duplicate of this bug: 757389
Assignee: nobody → wjohnston
https://hg.mozilla.org/mozilla-central/rev/31f1b05f1bd5
https://hg.mozilla.org/mozilla-central/rev/04472ce8d6cd
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 17
Adrian, please update any test-cases.
Flags: in-moztrap?(adrian.tamas)
Clear Site Preferences is now moved to URL bar as Site Settings... 
For clearing the inconsistencies in URL bar context menu is filled Bug 786999. 

Adrian will follow up when TC is updated.
Status: RESOLVED → VERIFIED
^^ 
Build ID: 17.0a2 (2012-08-29) Aurora Channel
Device: Galaxy Nexus 
OS: Android 4.0.4
Changed the test cases for Firefox 17 and up for both phones and tablets.

Changed tests:
https://moztrap.mozilla.org/manage/cases/_detail/5308/
https://moztrap.mozilla.org/manage/cases/_detail/5298/
https://moztrap.mozilla.org/manage/cases/_detail/5436/  - also updated the Custom Menu content with Apps and Reading list items
Flags: in-moztrap?(adrian.tamas) → in-moztrap+
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.