bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Add `module.metadata` with `stability` flags to SDK modules' code

RESOLVED FIXED

Status

Add-on SDK
General
P1
normal
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: zer0, Assigned: zer0)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
Every modules in SDK should have the metadata with stability flag set.

Modules' metadata proposal:

https://github.com/mozilla/addon-sdk/wiki/JEP-Metadata

Modules' stability status list:

https://docs.google.com/spreadsheet/ccc?key=0ArhtdvniRVpcdEl1SDdpQmJ1XzFuOHluaUt4YXhGQkE#gid=0
(Assignee)

Updated

6 years ago
Assignee: nobody → zer0
(Assignee)

Comment 1

6 years ago
Created attachment 656909 [details]
Pointer to Github pull request: https://github.com/mozilla/addon-sdk/pull/544

Pointer to Github pull-request
(Assignee)

Updated

6 years ago
Attachment #656909 - Flags: review?(wbamberg)

Updated

6 years ago
Priority: -- → P1
Attachment #656909 - Flags: review?(wbamberg) → review+

Comment 2

6 years ago
Commits pushed to master at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/cdfb1612bab0ee71051f9175ffb6a360c1b1f85f
Bug 787072 - Add `module.metadata` with `stability` flags to SDK modules

https://github.com/mozilla/addon-sdk/commit/1d2f4c2b56a3577062f7e00d8075c52dc77625b4
Merge pull request #544 from ZER0/stability/Bug787072

Fix Bug 787072 - Add `module.metadata` with `stability` flags to SDK modules r=@wbamberg
(Assignee)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
Duplicate of this bug: 725769
You need to log in before you can comment on or make changes to this bug.