Closed Bug 787188 Opened 7 years ago Closed 7 years ago

Hold off on about:home marketplace promo for now

Categories

(Firefox for Android :: Web Apps, defect, P1)

ARM
Android
defect

Tracking

()

RESOLVED FIXED
Firefox 18
Tracking Status
firefox16 --- unaffected
firefox17 --- verified
firefox18 --- verified

People

(Reporter: andy+bugzilla, Assigned: mfinkle)

References

Details

(Whiteboard: [blocking-webrtandroid1+])

Attachments

(2 files)

Awesome to see this that in bug 766389 we added a snippet to the marketplace.

But at the moment the marketplace is open to Mozillians only and about 1 hour after filing this bug, it will have no UI that works on anything but B2G. I don't think this should be live yet.

Can we turn this off for the moment, ready to turn on when the marketplace is accessible to all?
Wes - Can you put the marketplace advertisements behind an about:config pref?
Blocks: 766389
OS: Mac OS X → Android
Hardware: x86 → ARM
Version: unspecified → Trunk
Currently this is only available in Fx17 and Fx18. I'd rather not mess with the code unless it really becomes a problem.

If we can't use the Marketplace for test purposes, we can change the URL to something else as well.
I don't know the number of nightly users, but I can bet there is a large intersection of Mozillians (who can use the marketplace) and nightly users.

This is more of a concern if this goes into a beta or final release without the marketplace being widely available.
danhorner	in my email on aug 24th:
	danhorner	5. Go-to-Market Strategy (Dan)
	danhorner	Mid October launch will be confirmed on October 7th content meeting, based on Rick's app catalogue requirements
	danhorner	Mid-October is purposefully vague - this will only be confirmed once product and app catalogue requirements are met.
	danhorner	If launch date is confirmed on October 7th:
	danhorner	Developer preparation comms will go out one week prior to mid October Beta launch.
	danhorner	Inbound PR / Messaging will need to be in place for Developer preparation comms
	danhorner	For launch
	danhorner	Password will be removed on Marketplace - anyone accessing the Marketplace with Fennec Beta, Aurora or Nightly will be able to use and download apps
	danhorner	Marketplace promo on Fennec start page will begin/appear across Beta, Aurora and Nightly
	danhorner	Hacks blog post will go live, and inbound PR will be primed
	danhorner	Marketing will monitor usage numbers, and no further comms will be pushed unless usage figures are lower than 2-3,000 targets.
See comment 4 above - This is from Dan (Product Marketing Manager for Apps). Basically what this means is that the marketplace promo should not be advertised until the marketplace is officially launched. Sounds like we're going to have to put this behind a preference and pref this on when launch is declared.
Keywords: productwanted
To clarify; we plan to make a go-no go decision on whether Marketplace will launch as a public Beta on October 7th.

If it does - the request will *likely* be that a Marketplace snippet will appear in Fennec Beta, Aurora and Nightly from mid-October.

This snippet will *not* appear in GA until early 2013.

There will be an updated decision on this approach on Monday; I will update this bug accordingly then.
The technical issues will be a bit harder than we might be thinking here. We are calling this a "snippet" but it is really a hard code piece of the UI. Turning it off and on is not something we can do without making a new build.

The "snippet" is currently visible in Nightly and Aurora. We removed it from Beta before it shipped. We will need to evaluate removing it from Aurora (Fx17) before it moves to Beta on Oct 8th.

Wes or someone can look into a way to easily stop showing the snippet so it's not an obtrusive change.
Summary: Hold off on the marketplace snippet for now → Hold off on about:home marketplace promo for now
Fyi - I had specified these requirements in the following bug:

https://bugzilla.mozilla.org/show_bug.cgi?id=785559

In reply to Mark's comments re: easily stopping showing the snippet- I'd envisaged implementing dynamic HTML (hence me calling this a 'snippet' even though it currently isn't really a snippet in the desktop sense). 

This would have another major advantage, of allowing the user engagement team to update this placement to support product marketing promotions of other features in the future.
Its not HTML. Its native Java UI so that it can show quickly. Right now it executes some "chrome"/Java code. We could modify it to just launch "http://marketplace.mozilla.org" (or any other link) which would prompt to install the marketplace. In that case it could be a really simple set of image, text, link. Sync would have to be a special case. We've abstracted enough to make that fairly easy.

Homescreen space is super valuable though, and pushes the users personalized content below the fold. We have to be pretty careful about what we show.
Hey Guys,

Let's hold the discussion on this bug for now and get into a short discussion in a meeting to resolve this. I took a look at the proposal in bug 785559 and have realized the our implementation plan does not align with the GTM plan Dan has proposed. I'll put out an email shortly about this.
Would be good if we could hold off at least until Monday; there's a Android meeting to decide milestone dates and next steps, so we'll have a much more concrete idea by then.
(In reply to Old_bug_account_DanH from comment #11)
> Would be good if we could hold off at least until Monday; there's a Android
> meeting to decide milestone dates and next steps, so we'll have a much more
> concrete idea by then.

Sounds good. I blocked off a short discussion on next Tuesday to talk about this at 10am between you, Mark, myself, and Erin.
Duplicate of this bug: 785559
What is the resolution of this bug here?
This patch simply changes the code to allow for the possibility that no promo could be shown.
Assignee: nobody → mark.finkle
Attachment #663267 - Flags: review?(wjohnston)
This patch adds some preprocessor logic to hide the "Apps" menu and the Apps promo box on Beta and Release builds. Yes, I duplicated the code in AboutHomeContent because the preprocessor is lame and this code is destined to die.

Note that, if we randomly pick the Apps promo, we fallback to the Sync promo if we have not already set up Sync. If we have set it up, we show no promo.
Attachment #663269 - Flags: review?(wjohnston)
(In reply to Aaron Train [:aaronmt] from comment #14)
> What is the resolution of this bug here?

We are disabling the Apps promo and the "Apps" menu on Beta and Release. Around the time we go to build for Fx17 beta 1, we'll decide if the Marketplace is ready to enter "beta phase" and if it is, we'll remove the checks that hide the promo and menu for Beta, but leave them in for Release. This means, if things go well, we'll have the promo and menu turned on by Fx17 beta 2.
Comment on attachment 663267 [details] [diff] [review]
patch 1/2: refactor to allow no promo to be shown

Review of attachment 663267 [details] [diff] [review]:
-----------------------------------------------------------------

::: mobile/android/base/AboutHomeContent.java
@@ +220,5 @@
>  
> +        AboutHomePromoBox.Type type = mPrelimPromoBoxType;
> +        if (syncIsSetup && type == AboutHomePromoBox.Type.SYNC)
> +            type = AboutHomePromoBox.Type.APPS;
> +        mPromoBox.show(type);

Not your bug, but we could query the WebAppsAllocator to see if the marketplace app is installed and in that case show nothing.
Attachment #663267 - Flags: review?(wjohnston) → review+
Comment on attachment 663269 [details] [diff] [review]
patch 2/2: skip app promo on beta and release

Review of attachment 663269 [details] [diff] [review]:
-----------------------------------------------------------------

::: mobile/android/base/AboutHomeContent.java
@@ +221,5 @@
>          AboutHomePromoBox.Type type = mPrelimPromoBoxType;
>          if (syncIsSetup && type == AboutHomePromoBox.Type.SYNC)
>              type = AboutHomePromoBox.Type.APPS;
> +
> +#if MOZ_UPDATE_CHANNEL == beta

This logic is... confusing. Add a comment explaining what we're doing?
Attachment #663269 - Flags: review?(wjohnston) → review+
Priority: -- → P1
Whiteboard: [blocking-webrtandroid1+]
https://hg.mozilla.org/mozilla-central/rev/bb07e91c012d
https://hg.mozilla.org/mozilla-central/rev/c6dab1c5387c
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
I can verify that on mozilla-central (Nightly), we get both promo's still.
So this never made it to the Beta channel and ended in 17.0 Beta 1 after-all.
(In reply to Aaron Train [:aaronmt] from comment #23)
> So this never made it to the Beta channel and ended in 17.0 Beta 1 after-all.

Okay, so that confirms that I wasn't the only one who saw this. Reopening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to Jason Smith [:jsmith] from comment #24)
> (In reply to Aaron Train [:aaronmt] from comment #23)
> > So this never made it to the Beta channel and ended in 17.0 Beta 1 after-all.
> 
> Okay, so that confirms that I wasn't the only one who saw this. Reopening.

Wait a second. I know what happened here. It never got uplifted. Crap.
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
Whiteboard: [blocking-webrtandroid1+] → [blocking-webrtandroid1+] [needs-beta-uplift]
Jason / Aaron - the promo an 'Apps' menu item should not go live in Beta - we are only using Aurora for the Firefox Marketplace release on the 18th.
(In reply to Dan Horner from comment #26)
> Jason / Aaron - the promo an 'Apps' menu item should not go live in Beta -
> we are only using Aurora for the Firefox Marketplace release on the 18th.

See comment #23; this is currently not the case with mozilla-beta (17.0 beta 1)
Comment on attachment 663267 [details] [diff] [review]
patch 1/2: refactor to allow no promo to be shown

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: showing a promo for marketplace that we don't want to advertise to the aurora audience.
Testing completed (on m-c, etc.): it's been on m-c for a while and is on aurora now.
Risk to taking this patch (and alternatives if risky): 
String or UUID changes made by this patch: none
Attachment #663267 - Flags: approval-mozilla-beta?
Comment on attachment 663269 [details] [diff] [review]
patch 2/2: skip app promo on beta and release

see above
Attachment #663269 - Flags: approval-mozilla-aurora?
Attachment #663267 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #663269 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Comment on attachment 663269 [details] [diff] [review]
patch 2/2: skip app promo on beta and release

Whoops. This was for beta too.
Attachment #663269 - Flags: approval-mozilla-aurora+ → approval-mozilla-beta+
Whiteboard: [blocking-webrtandroid1+] [needs-beta-uplift] → [blocking-webrtandroid1+]
Verified on:
Firefox Mobile 17.0b2 build 2 (2012-10-18)
Device: Samsung Galaxy R
OS: Android 2.3.4
Status: RESOLVED → VERIFIED
Comment on attachment 663269 [details] [diff] [review]
patch 2/2: skip app promo on beta and release

Review of attachment 663269 [details] [diff] [review]:
-----------------------------------------------------------------

::: mobile/android/base/AboutHomeContent.java
@@ +228,5 @@
> +#endif
> +#if MOZ_UPDATE_CHANNEL == release
> +        if (type == AboutHomePromoBox.Type.APPS)
> +            type = (syncIsSetup ? AboutHomePromoBox.Type.NONE : AboutHomePromoBox.Type.SYNC);
> +#endif

I don't like making this file preprocessed simply for this. Instead please add an abstract function to GeckoApp and implement it in App.java.in
Status: VERIFIED → RESOLVED
Closed: 7 years ago7 years ago
You need to log in before you can comment on or make changes to this bug.