Add snippet on home screen to advertise the Marketplace

VERIFIED FIXED in Firefox 17

Status

()

enhancement
P1
normal
VERIFIED FIXED
7 years ago
3 years ago

People

(Reporter: jsmith, Assigned: mcomella)

Tracking

({late-l10n})

unspecified
Firefox 17
ARM
Android
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -
in-moztrap +

Firefox Tracking Flags

(firefox17 verified)

Details

(Whiteboard: [blocking-webrtandroid1+])

Attachments

(7 attachments, 8 obsolete attachments)

281.85 KB, image/png
Details
285.53 KB, image/png
Details
482.36 KB, image/png
Details
49.94 KB, patch
sriram
: review+
Details | Diff | Splinter Review
316.96 KB, image/png
Details
7.53 KB, patch
sriram
: review+
Details | Diff | Splinter Review
4.85 KB, patch
mcomella
: review+
Pike
: feedback+
Details | Diff | Splinter Review
Reporter

Description

7 years ago
Discoverability idea for allowing a user to discover the about:apps page containing what apps they have installed to their Android device through Firefox for Android. We would need to add a clickable item to the about:home page that stands out enough (i.e. attractive to click it) such that a user would be curious to click it to see what apps they have installed (i.e. user is taken to about:apps). UX feedback is welcome here (this was a random idea to help solve the problem with providing context to about:apps as an extension to bug 741472).
Reporter

Updated

7 years ago
Severity: normal → enhancement
Reporter

Updated

7 years ago
Component: General → Web Apps
QA Contact: general → web-apps
Reporter

Updated

7 years ago
QA Contact: aaron.train
Reporter

Updated

7 years ago
Priority: -- → P2
We want to make apps more discoverable. The idea here (for now) is to replace the about:sync promotion with this one... sometimes. To start with, I'm fine with replacing it randomly. If the user has clicked on it once, we should hide it and not show it again. Since the ratings promotion is also vying for this place, an interface and method of registering snippets would be useful.

There's no design for this right now, beyond something similar to the Sync one. I told mcomella to forge ahead as best he can. I'd be fine with no image as a starting point as well. Just some text. Something like "Install the Firefox Marketplace to use native webapps on your device!"?

Sound good? Ask questions as you run into them.
Assignee: nobody → michael.l.comella
Status: NEW → ASSIGNED
Adjusted the summary to what I think this item should do? i.e. I think we want to install the marketplace app, and then automagically launch it as well. Perhaps even avoiding all prompts along the way?
Summary: Add a My Apps clickable item on the about:home page to take a user to about:apps → Add a My Apps clickable item on the about:home page to install and launch the marketplace app
Duplicate of this bug: 778914
Separated the marketplace-specific implementation from the act of replacing the sync box with a promo box abstraction. Filed bug 781262 for that.
Depends on: 781262
I think it's important to make a link to "My Apps" that is always shown and easier to find than the current location in the options overflow menu. The promo box is will work well but it seems the desire is to make that not show when the Marketplace has already been visited once. I think it's very important we have a consistent visible link. As such, I came up with some ideas that we may want to implement in addition to the promo box:

1) A "Top Apps" section, similar to the "Add-ons", "Synced Tabs" and "Top Sites" sections.
2) Replace Firefox logo on about:home with a link to "My Apps" (see "about:home My Apps link (top right)")
3) Using the idea from https://bugzilla.mozilla.org/show_bug.cgi?id=759011#c12 add a link in the tab bar (see "Tab Bar My Apps link").

Additionally, to help users revisit "My Apps" at a later point, we may want to use the promo box to display "featured" apps.
(In reply to Michael Comella (:mcomella) from comment #7)
> I think it's important to make a link to "My Apps" that is always shown and
> easier to find than the current location in the options overflow menu.

Why? I don't think Apps are important enough to _always_ have a link on the home page. Remember, any installed app has an icon on your Android homescreen too. I don't want to go overboard on "Apps, Apps, Apps!"

> promo box is will work well but it seems the desire is to make that not show
> when the Marketplace has already been visited once.

Correct. We want to just get the user's attention to explore the Apps stuff.

> I think it's very important we have a consistent visible link. As such, I came up with some
> ideas that we may want to implement in addition to the promo box:
> 
> 1) A "Top Apps" section, similar to the "Add-ons", "Synced Tabs" and "Top
> Sites" sections.

I don't think we want a dedicated section for this on the homescreen. I could be pursuaded otherwise, but we are getting too many sections and none of them will be useful.

Maybe we need to rotate Apps and Add-ons

> 2) Replace Firefox logo on about:home with a link to "My Apps" (see
> "about:home My Apps link (top right)")

Overkill IMO

> 3) Using the idea from
> https://bugzilla.mozilla.org/show_bug.cgi?id=759011#c12 add a link in the
> tab bar (see "Tab Bar My Apps link").

I would consider this idea, in a separate bug, as long as Addons and Downloads are present too. Apps might be new and shiny, but it's the samemetaphor as the other builtin content UIs.

> Additionally, to help users revisit "My Apps" at a later point, we may want
> to use the promo box to display "featured" apps.

Honestly, I feel bug 781262 is the base from which we should start and should take the place of this bug. Your #3 idea is something I'd like to see in a bug so we can debate it separately.
(In reply to Mark Finkle (:mfinkle) from comment #8)
> Why? I don't think Apps are important enough to _always_ have a link on the
> home page. Remember, any installed app has an icon on your Android
> homescreen too. I don't want to go overboard on "Apps, Apps, Apps!"

Sorry, I realized I wasn't being very clear. I think it's important to remind users of apps, specifically the marketplace, more than once. I wonder that even if a user has a good experience the first time around (entering the marketplace through the promo box, downloading a useful app, etc.), what would remind them to come back to explore further? What drives the second exploration? Will the experience be so memorable as to stick out over the standard Google Play Store experience that the next time they want an app, they'll look in the apps marketplace first? I feel getting users to explore a second time around is especially difficult considering the branding – Firefox will still likely be just a web browser to them, even if apps left a good impression.

By putting a consistent reference back to apps, users will notice it even if they aren't really looking for it. It should be noticeable, but not intrusive. It could make them at least a little curious to explore apps again.

And even then, if a user does want to come back, will they know how? The current location (opening overflow options and having to scroll down, at least on the Galaxy Nexus) is not very user friendly.

> > 3) Using the idea from
> > https://bugzilla.mozilla.org/show_bug.cgi?id=759011#c12 add a link in the
> > tab bar (see "Tab Bar My Apps link").
> 
> I would consider this idea, in a separate bug, as long as Addons and
> Downloads are present too. Apps might be new and shiny, but it's the
> samemetaphor as the other builtin content UIs.

Thinking through this again, I like this version the most – in my opinion, it's the least intrusive and yet the most noticeable. Additionally, I really like the idea of adding Addons and Downloads – these options are not very visible in their current locations.
(In reply to Mark Finkle (:mfinkle) from comment #8)
> should take the place of this bug. Your #3 idea is something I'd like to see
> in a bug so we can debate it separately.

Bug 781595.
Desktop at one point had some homescreen mockups that had "Top Sites" and "Apps" on it. I wonder if we can do something similar as well. i.e. swiping about:home left and right could switch between a top sites and an Apps section (and others?).

Maybe thats too Inception. Tabs inside tabs inside tabs.....
Whiteboard: [blocking-webrtandroid1+]
Summary: Add a My Apps clickable item on the about:home page to install and launch the marketplace app → Add snippet on home screen to advertise the Marketplace
Reporter

Updated

7 years ago
Priority: P2 → P1
Posted image Ian's Mockup
Here is Ian's mockup, moved from bug 778914
Posted patch Strings patch (obsolete) — Splinter Review
I think we need to get these strings in now for l10n. I'm going to nom for Aurora at the same time and push to get these moved forward now.
Attachment #650988 - Flags: review?(mbrubeck)
Comment on attachment 650988 [details] [diff] [review]
Strings patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): New feature/ad
User impact if declined: Non localized ad
Testing completed (on m-c, etc.): Hasn't landed yet. Just strings though
Risk to taking this patch (and alternatives if risky): Very low risk. Worst case we have some unused strings lying aruond
String or UUID changes made by this patch: That's all it is.
Attachment #650988 - Flags: approval-mozilla-aurora?
Posted patch Strings patch (obsolete) — Splinter Review
Sorry. First patch was qrefed wrong. See above comments.
Attachment #650988 - Attachment is obsolete: true
Attachment #650988 - Flags: review?(mbrubeck)
Attachment #650988 - Flags: approval-mozilla-aurora?
Attachment #650990 - Flags: review?(mbrubeck)
Attachment #650990 - Flags: approval-mozilla-aurora?
Attachment #650990 - Flags: review?(mbrubeck) → review+
Comment on attachment 650990 [details] [diff] [review]
Strings patch

I spoke to Pike about this briefly. It sounds like the l10N folks would

1.) Like comments about what the strings are for. Especially given the strangeness of this bold bit.
2.) Would rather the feature was there first, to avoid churn that might occur if we land the strings without the feature.

With that in mind, I'll hold off on the string bits until we have a patch here.
Attachment #650990 - Flags: approval-mozilla-aurora?
Posted patch App Box Patch (obsolete) — Splinter Review
Patch builds upon the patch in bug 781262. Currently the apps promo box will appear only when sync is setup (thus, there is always a promo box visible). This should change to the desired display behavior before this patch is pushed. This patch also needs the real image resources.

When clicking the promo box, this patch will open the Marketplace in a new tab (leaving about:home in a background background).
Attachment #651090 - Flags: feedback?(sriram)
The image is too small but you get the idea. :)
Reporter

Updated

7 years ago
Comment on attachment 651090 [details] [diff] [review]
App Box Patch

Review of attachment 651090 [details] [diff] [review]:
-----------------------------------------------------------------

Please update this patch with your latest changes.
This might not have onClickListener and more text/image resources I guess.
Attachment #651090 - Flags: feedback?(sriram) → feedback-
Posted patch 01: Strings (obsolete) — Splinter Review
Updated the strings patch. The unicode character ("»") in the apps box string was removed from the patch as it will be added in code (for internationalization purposes).
Attachment #650990 - Attachment is obsolete: true
Attachment #653576 - Flags: review?(mbrubeck)
Posted patch 02: App box patch (obsolete) — Splinter Review
As specified in the code as comments with "TODO", two things still need to be done:

1) Determine when we will show the apps promo box (currently when sync is setup).

2) Get image resources for the apps marketplace and include them in the promo box.
Attachment #651090 - Attachment is obsolete: true
Attachment #653606 - Flags: feedback?(sriram)
Comment on attachment 653576 [details] [diff] [review]
01: Strings

Adding "»" in code still seems slightly problematic for RTL languages, and also for languages that use « and » for quotation.  Do we really need the chevrons?
Attachment #653576 - Flags: review?(mbrubeck) → review+
If it's a real problem we can take out the "»"
Posted patch 02: ResourcesSplinter Review
Added addition of resources as a separate patch. "02: App box patch" will be moved to 03.
Attachment #654007 - Flags: review?(sriram)
Posted patch 03a: App box patch (obsolete) — Splinter Review
Moved from "02: Resources".

As discussed on IRC, waiting for comment from mfinkle for inclusion of the chevron in the string file rather than adding them in code.
Attachment #653606 - Attachment is obsolete: true
Attachment #653606 - Flags: feedback?(sriram)
Attachment #654009 - Flags: review?(sriram)
Actual resources in place.
Attachment #651091 - Attachment is obsolete: true
Some feedback:
* the chevron should be part of the string. That will allow translators to change or drop the chevron from their locale.
* instead of waiting for the Sync promo to go away, can we randomize the display? Sometimes Sync, sometimes Apps? (I'd be willing to see this in a new bug if it slows down landing these patches)
Posted patch 01a: Strings (obsolete) — Splinter Review
As per mfinkle's comment, added the chevrons to the strings.
Attachment #653576 - Attachment is obsolete: true
Attachment #654037 - Flags: review?(mbrubeck)
As per mfinkle's comment, made the Apps promo box show up randomly (1/2 chance for each) when sync is not enabled. The promo box will only show the apps box if sync is enabled.
Attachment #654009 - Attachment is obsolete: true
Attachment #654009 - Flags: review?(sriram)
Attachment #654060 - Flags: review?(sriram)
Comment on attachment 654007 [details] [diff] [review]
02: Resources

Looks good to me.
Attachment #654007 - Flags: review?(sriram) → review+
Comment on attachment 654060 [details] [diff] [review]
03b: App box patch

Review of attachment 654060 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me.
Attachment #654060 - Flags: review?(sriram) → review+
Attachment #654037 - Flags: review?(mbrubeck) → review+
Comment on attachment 654037 [details] [diff] [review]
01a: Strings

Review of attachment 654037 [details] [diff] [review]:
-----------------------------------------------------------------

The about_sync string changed, localizers won't pick that up without a key change.

::: mobile/android/base/locales/en-US/android_strings.dtd
@@ +180,5 @@
> +<!-- Localization note (abouthome_about_sync, abouthome_about_apps): The chevron (ex: "»"; unicode=
> +     U+00BB) is used as an arrow to show that clicking this text in the promotions box will perform
> +     some action. Note that a non-breaking space (unicode= U+00A0) should be used between this
> +     character and the remainder of the string to prevent word wrap. -->
> +<!ENTITY abouthome_about_sync "Set up Firefox Sync to access bookmarks, history and tabs from your other devices »">

This string got changed without updating the key that's referencing it, so localizations won't pick this change up.
Attachment #654037 - Flags: feedback-
Posted patch 01b: StringsSplinter Review
Updated the key mentioned in Pike's comment and changed localization notes to 80 character line lengths so that they are (hopefully) more readable.
Attachment #654037 - Attachment is obsolete: true
Attachment #654316 - Flags: review+
Attachment #654316 - Flags: feedback?(l10n)
Forgot to mention, moved r+.
Keywords: checkin-needed
Comment on attachment 654316 [details] [diff] [review]
01b: Strings

Review of attachment 654316 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for the update.
Attachment #654316 - Flags: feedback?(l10n) → feedback+
Looks good on latest-MI/MC:

Tested via Galaxy Nexus (4.1.1):

* No Sync Account → Preliminary Sync Promo → Sync Account Added → Market Promo
* Sync Account Removed → Preliminary Sync Promo → Sync Account Added → Market Promo 
* Randomized preliminary promo on Fennec launch (got both Sync and Market promo)
Status: RESOLVED → VERIFIED
Flags: in-moztrap?(aaron.train)
Depends on: 787188

Comment 39

7 years ago
added https://moztrap.mozilla.org/manage/case/6202/ starting Fx 20 .
Flags: in-moztrap?(aaron.train) → in-moztrap+
You need to log in before you can comment on or make changes to this bug.