Last Comment Bug 787563 - Pymake causes builds to fail on Elm project repo
: Pymake causes builds to fail on Elm project repo
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: x86_64 Windows 7
: P2 normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Gregory Szorc [:gps]
Mentors:
Depends on: 787600
Blocks: 593585 779902 806799
  Show dependency treegraph
 
Reported: 2012-08-31 14:23 PDT by Jim Mathies [:jimm]
Modified: 2012-12-30 06:55 PST (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Disable pymake on elm (1.04 KB, patch)
2012-08-31 15:55 PDT, Chris Cooper [:coop]
aki: review+
Details | Diff | Splinter Review

Description Jim Mathies [:jimm] 2012-08-31 14:23:50 PDT
We have two sets of builders on Elm, regular win32 builders and experimental vs 2012 builders. With the latest merge of mc and the changes in bug 593585 and follow ups, every build on Elm broke.

Notes:

- In the repo the mozconfig.vs2011-win64 config scripts have been updated to match cset 3cc378b302c9 changes. Two patches landed - 

https://hg.mozilla.org/projects/elm/rev/be1e0e1e3bf1
https://hg.mozilla.org/projects/elm/rev/d846bcea5974

The problem in these machines seems to have something to do with a variable 'CRTDLL_FULLPATH' - 

LINK : fatal error LNK1146: no argument specified with option '/EXTRACT:'

For the regular win32 builders, we have a cryptic build failure:

<widget_windows.lib.desc>: Found error
<libs>: Found error

I can't reproduce this locally so I'm not sure what to do. I think somebody is going to have to get onto these machines and poke around.
Comment 1 Chris Cooper [:coop] 2012-08-31 14:36:04 PDT
Let me know if a clobber doesn't fix it and I'll disable pymake on elm until we can figure it out.
Comment 2 Jim Mathies [:jimm] 2012-08-31 15:09:50 PDT
(In reply to Chris Cooper [:coop] from comment #1)
> Let me know if a clobber doesn't fix it and I'll disable pymake on elm until
> we can figure it out.

Unfortunately it didn't. :/

AFAIK, the normal win32 builders come out of the same pool and use the same config mc/mi use. So while I can understand issues with the experimental win8 builders, I don't understand why the normal builds broke.
Comment 3 Chris Cooper [:coop] 2012-08-31 15:55:35 PDT
Created attachment 657473 [details] [diff] [review]
Disable pymake on elm

This unblocks metro work until they have a chance to address pymake-specific issues.
Comment 4 Chris Cooper [:coop] 2012-08-31 18:55:02 PDT
Comment on attachment 657473 [details] [diff] [review]
Disable pymake on elm

https://hg.mozilla.org/build/buildbot-configs/rev/70fd785f5bfc

This is in production now. I will schedule clobbers for elm Windows builds.
Comment 5 Jim Mathies [:jimm] 2012-09-01 09:12:14 PDT
Things are back to normal. Morphing this bug into the pymake issue.
Comment 6 Mike Hommey [:glandium] 2012-10-30 05:21:29 PDT
There have been several pymake changes since the beginning of september, and that issue may actually be fixed. Can you give pymake a spin?
Comment 7 Brian R. Bondy [:bbondy] 2012-10-30 05:23:04 PDT
I'll try with pymake today
Comment 8 Jim Mathies [:jimm] 2012-10-30 05:28:15 PDT
pymake works fine locally but Elm had some weird problems with it when we changed over. Sid felt that these issues were addressed. We can experiment with turning it back on in bug 806799.
Comment 9 Jim Mathies [:jimm] 2012-11-07 11:23:50 PST
working now.
Comment 10 thomas.harfmann 2012-12-27 08:27:34 PST
Hi, I tried to build Firefox today using VS2011. I still get this error.

12:09.51 Warning: C4244 in c:\mozilla-central\widget\windows\nsImageClipboard.cpp: 'Initialisierung': Konvertierung von 'WORD' in 'uint8_t', möglicher Datenverlust
12:09.51 c:/mozilla-central/widget/windows/nsImageClipboard.cpp(270) : warning C4244: 'Initialisierung': Konvertierung von 'WORD' in 'uint8_t', möglicher Datenverlust
12:09.51
12:09.51 <widget_windows.lib.desc>: Found error
12:09.56 nsBidiKeyboard.cpp
12:09.56
12:09.62 nsNativeDragTarget.cpp
12:09.62
12:09.76 nsDragService.cpp
12:09.76
12:09.82 nsClipboard.cpp
12:09.82
12:09.82 Warning: C4018 in c:\mozilla-central\widget\windows\nsClipboard.cpp: '>': Konflikt zwischen 'signed' und 'unsigned'
12:09.82 c:/mozilla-central/widget/windows/nsClipboard.cpp(710) : warning C4018: '>': Konflikt zwischen 'signed' und 'unsigned'
12:09.82
12:10.26 nsTextStore.cpp
12:10.28
12:10.28 <libs>: Found error
12:10.28 <../../staticlib/components/widget_windows.lib.desc>: Found error
12:10.28 <libs>: Found error
12:10.28 c:\mozilla-central\config\makefiles\target_libs.mk:60:0: command 'c:/mozilla-build/python/python.exe c:/mozilla-central/build/pymake/pymake/../make.py -C windows libs' failed, return code 2
12:10.28 c:\mozilla-central\config\makefiles\target_libs.mk:18:0: command 'c:/mozilla-build/python/python.exe c:/mozilla-central/build/pymake/pymake/../make.py -C widget libs' failed, return code 2
12:10.28 c:\mozilla-central\config\rules.mk:596:0: command 'c:/mozilla-build/python/python.exe c:/mozilla-central/build/pymake/pymake/../make.py libs_tier_platform' failed, return code 2
12:10.28 c:\mozilla-central\config\rules.mk:561:0: command 'c:/mozilla-build/python/python.exe c:/mozilla-central/build/pymake/pymake/../make.py  tier_platform' failed, return code 2
12:10.28 c:\mozilla-central\client.mk:360:0: command 'c:/mozilla-build/python/python.exe c:/mozilla-central/build/pymake/pymake/../make.py -j6 -C c:/mozilla-central/../firefox-build' failed, return code 2
12:10.28 c:\mozilla-central\client.mk:160:0: command 'c:/mozilla-build/python/python.exe c:/mozilla-central/build/pymake/pymake/../make.py -f c:/mozilla-central/client.mk realbuild' failed, return code 2
Comment 11 Mike Hommey [:glandium] 2012-12-27 09:11:14 PST
(In reply to Thomas Harfmann from comment #10)
> Hi, I tried to build Firefox today using VS2011. I still get this error.

You're not giving enough backlog, the error is somewhere before that.
Comment 12 thomas.harfmann 2012-12-27 09:44:19 PST
> You're not giving enough backlog, the error is somewhere before that.

No it isn't.

-> 12:09.51 <widget_windows.lib.desc>: Found error
Comment 13 Mike Hommey [:glandium] 2012-12-27 09:52:48 PST
(In reply to Thomas Harfmann from comment #12)
> > You're not giving enough backlog, the error is somewhere before that.
> 
> No it isn't.
> 
> -> 12:09.51 <widget_windows.lib.desc>: Found error

That's not the relevant error. The relevant error is not in what you pasted.
Comment 14 Jim Mathies [:jimm] 2012-12-30 06:55:12 PST
(In reply to Thomas Harfmann from comment #10)
> Hi, I tried to build Firefox today using VS2011. I still get this error.

This isn't the right place to discuss this. Could you please file a fresh bug?

Note You need to log in before you can comment on or make changes to this bug.