Image error is unreadable against dark background

VERIFIED FIXED in Firefox 16

Status

()

Toolkit
Themes
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Minh Nguyễn, Assigned: dao)

Tracking

({regression})

Trunk
mozilla18
regression
Points:
---

Firefox Tracking Flags

(firefox15 wontfix, firefox16 verified, firefox17 verified)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 658395 [details]
unreadable-error.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20120903042010

Steps to reproduce:

Opened a broken image, such as:

data:image/png,


Actual results:

The “cannot be displayed” error message is black against the dark gray background.


Expected results:

The error message should have been white or near white for better readability.

This is a regression caused by the following changesets:

https://hg.mozilla.org/mozilla-central/rev/836e451c8b77
https://hg.mozilla.org/mozilla-central/rev/35ac9dfcef9b
(Reporter)

Updated

5 years ago

Updated

5 years ago
Blocks: 754539
Status: UNCONFIRMED → NEW
Component: Untriaged → Layout
Depends on: 376997
Ever confirmed: true
OS: Mac OS X → All
Product: Firefox → Core
Hardware: x86 → All
(Assignee)

Updated

5 years ago
Assignee: nobody → jaws
Blocks: 756419
No longer blocks: 754539
Component: Layout → Themes
No longer depends on: 376997
Keywords: regression
Product: Core → Toolkit
(Assignee)

Updated

5 years ago
status-firefox15: --- → affected
status-firefox16: --- → affected
status-firefox17: --- → affected
Version: 17 Branch → Trunk
(Assignee)

Comment 1

5 years ago
Created attachment 659219 [details] [diff] [review]
patch
Assignee: jaws → dao
Status: NEW → ASSIGNED
Attachment #659219 - Flags: review?(dolske)
(Assignee)

Updated

5 years ago
Comment on attachment 659219 [details] [diff] [review]
patch

Review of attachment 659219 [details] [diff] [review]:
-----------------------------------------------------------------

::: toolkit/themes/winstripe/global/TopLevelImageDocument.css
@@ +12,2 @@
>      background-color: #fff;
>      color: #222;

Why does the tag name need to be specified here?
Attachment #659219 - Flags: review?(dolske) → review+
(Assignee)

Comment 3

5 years ago
(In reply to Jared Wein [:jaws] from comment #2)
> ::: toolkit/themes/winstripe/global/TopLevelImageDocument.css
> @@ +12,2 @@
> >      background-color: #fff;
> >      color: #222;
> 
> Why does the tag name need to be specified here?

It makes the code more readable. The class by itself isn't as descriptive.
(Assignee)

Comment 4

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/0b6afc4c7b06
https://hg.mozilla.org/mozilla-central/rev/0b6afc4c7b06
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla18
(Assignee)

Comment 6

5 years ago
Comment on attachment 659219 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 756419
User impact if declined: unreadable errors for some invalid images
Testing completed (on m-c, etc.): manual on m-c
Risk to taking this patch (and alternatives if risky): low risk
String or UUID changes made by this patch: none
Attachment #659219 - Flags: approval-mozilla-aurora?
(Assignee)

Updated

5 years ago
Attachment #659219 - Flags: approval-mozilla-beta?
Attachment #659219 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 7

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/4dcae7cb7390
status-firefox15: affected → wontfix
status-firefox17: affected → fixed

Comment 8

5 years ago
Comment on attachment 659219 [details] [diff] [review]
patch

Sounds like regressions (if any) could be wontfix'd. Approving for Beta.
Attachment #659219 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
(Assignee)

Comment 9

5 years ago
https://hg.mozilla.org/releases/mozilla-beta/rev/a6a85d5f4732
status-firefox16: affected → fixed
Keywords: verifyme
Reproduced the issue on FF 16b3.
Verified fixed on FF 16b4 on Win 7 x64, Ubuntu 12.04 and Mac OS X 10.7.4.
status-firefox16: fixed → verified
Verified fixed on FF 17b1 on Win 7 x64, Ubuntu 12.04 and Mac OS X 10.6.8.
Status: RESOLVED → VERIFIED
status-firefox17: fixed → verified
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.