Closed Bug 788423 Opened 7 years ago Closed 3 years ago

[adbe 3612667] Flash hang in F_1152915508 on dropbox.com

Categories

(External Software Affecting Firefox :: Flash (Adobe), defect, critical)

x86
Windows 7
defect
Not set
critical

Tracking

(firefox16-, firefox17-, firefox18-)

RESOLVED INCOMPLETE
Tracking Status
firefox16 - ---
firefox17 - ---
firefox18 - ---

People

(Reporter: scoobidiver, Unassigned)

References

(Blocks 1 open bug, )

Details

(Keywords: hang, reproducible, Whiteboard: [flash-11.4][flash-11.5])

Crash Data

blinky wrote in bug 763896 comment 58:
> Steps to reproduce:
> 1. Open the page https://dl.dropbox.com/u/95157096/85f61cf7/f3d6ffe9.html
> 2. Wait for 3 minutes.
thanks for breaking this out Scoobidiver.  we are tracking the issue internally as #3325067
Status: NEW → ASSIGNED
Summary: Flash hang in F_1152915508 on dropbox.com → [adbe 3325067] Flash hang in F_1152915508 on dropbox.com
Keywords: crashhang
going to track this for Beta since it's reproducible.
I believe this is fixed in our daily builds.  I can provide a build to any Mozilla employees that want to confirm.
(In reply to Jeromie Clark from comment #4)
> I believe this is fixed in our daily builds.  I can provide a build to any
> Mozilla employees that want to confirm.

Please send this build to Marcia for testing. Thanks!
Keywords: topcrash
Ended up here reviewing a user's crashes on 15.0.1 in SUMO[1].
Linking in case you need to gather more data from the system with the crash.

bp-6cd208e6-f538-457e-b1c6-fa3cc2120928

1| https://support.mozilla.org/en-US/questions/938146
Thanks for the head's up.  We're investigating.
Mozilla/5.0 (Windows NT 6.0; rv:17.0) Gecko/17.0 Firefox/17.0

I got this crash while playing 13 YouTube videos on Firefox 17 beta 1 (on Windows Vista).  
https://crash-stats.mozilla.com/report/index/bp-d0a7bd2c-fecc-4b7a-9800-53cd02121010
https://crash-stats.mozilla.com/report/index/bp-e213439b-4799-4c8e-a531-5a64d2121010
This bug tracks hangs with the STR in comment 0.
If you have reliable STR, please file a bug.
Blocks: 789379
Let's only mark the tracking bug as a topcrasher.
Keywords: topcrash
our bug has been marked fixed verified in an internal dev build.  the change will roll out in the next 11.5 Flash Player release, Ellis.

also, you can verify using the current 11.5 beta...
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Keywords: verifyme
Resolution: --- → FIXED
Whiteboard: [flash-11.4] → [flash-11.4][fixed in Flash 11.5]
Ioana, can you please verify this is fixed with Flash 11.5 in Firefox 17.0b5?
QA Contact: ioana.budnar
On Firefox 17 beta 5, I get the following behavior with Flash 11.5.502.110:

https://dl.dropbox.com/u/95157096/85f61cf7/f3d6ffe9.html - about 1 minute after opening this link, I get a warning about a script causing Flash to run slowly and the options to stop or continue running this script. If I stop the script, everything works fine. If I choose to continue running the script, I get a crash: 
Plugin Report: https://crash-stats.mozilla.com/report/index/bp-37a18f8d-128b-4dd2-b6cc-2ce3e2121107
Browser Report: https://crash-stats.mozilla.com/report/index/bp-9adf31e2-a274-4575-948b-9d9cc2121107

https://dl.dropbox.com/u/95157096/85f61cf7/fe80383b.swf - when opening this link, the warning from above is opened in at most 2-3 seconds. Firefox freezes on that warning, followed by a crash.

Unfortunately, although I got 16 crashes in half an hour, only the two above were submitted right. The links for all the others lead to https://crash-stats.mozilla.com/about/throttling.
(In reply to Ioana Budnar [QA] from comment #13)
> On Firefox 17 beta 5, I get the following behavior with Flash 11.5.502.110:
> 
> https://dl.dropbox.com/u/95157096/85f61cf7/f3d6ffe9.html - about 1 minute
> after opening this link, I get a warning about a script causing Flash to run
> slowly and the options to stop or continue running this script. If I stop
> the script, everything works fine. If I choose to continue running the
> script, I get a crash: 
> Plugin Report:
> https://crash-stats.mozilla.com/report/index/bp-37a18f8d-128b-4dd2-b6cc-
> 2ce3e2121107
> Browser Report:
> https://crash-stats.mozilla.com/report/index/bp-9adf31e2-a274-4575-948b-
> 9d9cc2121107
> 
> https://dl.dropbox.com/u/95157096/85f61cf7/fe80383b.swf - when opening this
> link, the warning from above is opened in at most 2-3 seconds. Firefox
> freezes on that warning, followed by a crash.
> 
> Unfortunately, although I got 16 crashes in half an hour, only the two above
> were submitted right. The links for all the others lead to
> https://crash-stats.mozilla.com/about/throttling.

Confirming, I see the same in the latest hourly m-c win32 running on win7 x64 
and the latest Flash player - 11.5.502.110  This is NOT fixed it appears or has manifested itself in a new form.
In Nightly: https://crash-analysis.mozilla.com/hang-reports/2012/11-07/hr-20121107-d9e479dc-7073-4cf2-b6fc-7b89a02b431b.html
Status: RESOLVED → REOPENED
Keywords: verifyme
Resolution: FIXED → ---
Whiteboard: [flash-11.4][fixed in Flash 11.5] → [flash-11.4][flash-11.5]
Did we want to track this for Firefox 17 or later?
We're investigating now.  Our bug notes show that we confirmed this as fixed again in 11.5.500.99.  It appears to have been re-injected during the end-game.  

I'm able to reproduce in FF 15,16 and 17 with the same stacks, so I don't think this is a Firefox injection.

I'll update you guys as we know more.  Thanks for the head's up.
We're too close to shipping 17 to take speculative fixes, so I'll track for 18 and we can keep investigating.
(In reply to Lukas Blakk [:lsblakk] from comment #18)
> We're too close to shipping 17 to take speculative fixes, so I'll track for
> 18 and we can keep investigating.
It's a Flash bug, not a Firefox one.
New Beta out:  11.5.502.113 - Still getting 'Slow Script Warning' with this build.

No crash however....
We believe the issue with the modal dialog hang cited in the original bug report is resolved in the current betas.  Today's build is 11.5.502.118, and can be downloaded from http://www.adobe.com/go/flashplayerbeta/
(In reply to Jeromie Clark from comment #21)
> We believe the issue with the modal dialog hang cited in the original bug
> report is resolved in the current betas.  Today's build is 11.5.502.118, and
> can be downloaded from http://www.adobe.com/go/flashplayerbeta/

Just tested the URL in comment #3, plugin crashed following  Slow Script Warning
The URL for the Dropbox also still throws Slow Script warnings 

I tested using Win7 x64 running the latest hourly m-c win32 build based on cset:
https://hg.mozilla.org/mozilla-central/rev/df3421b24be8

Same in latest Chrome release version:  23.0.1271.64
Disabled their 'pepper' and enabled the beta to test.

URL in Comment #3 also throws Slow Script Warning in IE 10 preview for Win7 x64
and I'm using the release version of Flash on IE 10 Preview 11.5.502.110 
the 11.5.502.113beta was causing IE 10 Preview to crash.
Thanks for the feedback.  I've sent this back to the developer to take another look.
Are we sure this is not a problem with the test-link coding ?

I've tried now the latest two beta's and I'm still seeing 'slow script warning' as noted above in commnet #22

11.5.502.124 and 11.5.502.131
The Slow Script dialog is expected.  This SWF is doing something CPU-intensive to the point that it's impacting system performance.

If you do not respond to the Slow Script dialog within 30-seconds, Firefox is killing the player instance.  This shouldn't happen, but probably needs to be addressed on the Firefox side.

Any hangs or crashes you encounter after choosing "Yes" to the "Do you want to abort the script?" dialog are *not* expected, and are things we want to fix.
(In reply to Jeromie Clark from comment #25)
> The Slow Script dialog is expected.  This SWF is doing something
> CPU-intensive to the point that it's impacting system performance.
> 
> If you do not respond to the Slow Script dialog within 30-seconds, Firefox
> is killing the player instance.  This shouldn't happen, but probably needs
> to be addressed on the Firefox side.
> 
> Any hangs or crashes you encounter after choosing "Yes" to the "Do you want
> to abort the script?" dialog are *not* expected, and are things we want to
> fix.

Thanks for the reply.  I myself have not experienced any crash of the plugin, even ignoring the 'slow-script' dialog for up to two mins.  CPU use is indeed high, Flash is consuming 25% CPU on a Quad-core Athlon Phenom II.  

The OP that was seeing the crashes need to weigh in I think, as even from the start I never crashed or hung, just saw the 'slow-script' warnings.

Sorry, if I'd led folks astray.
CpuUsageFlashProcess2 	50.01

This appears to be Flash in some sort of long loop.
(In reply to blinky from comment #27)
> This crash is happening in
> http://dl.dropbox.com/u/95157096/85f61cf7/PICB241.html
I get the Firefox unresponsive plugin prompt twice.

> blinky wrote in bug 763896 comment 58:
> > Steps to reproduce:
> > 1. Open the page https://dl.dropbox.com/u/95157096/85f61cf7/f3d6ffe9.html
> > 2. Wait for 3 minutes.
I get a Flash script.
Rather than reopening this, can we please treat it as a new issue?  I realize the signature is the same, but it's fairly generic.  Dragging all the baggage along just makes things convoluted.
I'm tracking this as ADBE 3612667
Summary: [adbe 3325067] Flash hang in F_1152915508 on dropbox.com → [adbe 3612667] Flash hang in F_1152915508 on dropbox.com
In Firefox 23 and 24 with Flash Player 11.9.900.85 (and in the 11.8.xxx.xxx versions I looked at) on Windows, I'm getting the slow script dialog, which is expected.  Only after stopping the plug-in through the Firefox dialog do I get a crashed plug-in notification, but this is expected as Firefox has forcefully killed the running Flash instance.

On Mac, I get a beach ball, and eventually a slow script dialog which also works as expected.

I'm also not seeing anything logged in about:crashes when I work through this scenario.  Am I missing something?
Jeromie, what you are seeing is probably not the slow script dialog, but the plugin hang dialog that we introduced a few releases ago.

Benjamin, can you help with Jeromie's question in comment #33?
After 2 months with a perfect behaviour (zero hangs with a lot of flash videos for 18 hours),
since a few day the hang re-happens as in the past
https://www.facebook.com/arenaverona?fref=ts
https://crash-stats.mozilla.com/report/index/ea722316-1354-472a-8a44-3b0d92150805
reasons? a misterious.
the hang happened when I scrolled the link above,
but flash was activated by this other page:
https://www.facebook.com/BandaDeMusicaBriocense
reproduced successfully today
https://crash-stats.mozilla.com/report/index/c87643b5-d619-46bc-89c0-b9ffa2150806
always here
https://www.facebook.com/BandaDeMusicaBriocense

only embedded vidoes. zero issues on youtube.
Crash Signature: RealMsgWaitForMultipleObjectsEx | MsgWaitForMultipleObjects | F_1152915508___________________________________ ] [@ hang | GetLogicalDriveStringsA] [@ hang | LocalReAlloc] [@ hang | memcpy | RealMsgWaitForMultipleObjectsEx] [@ hang | memcpy | → RealMsgWaitForMultipleObjectsEx | MsgWaitForMultipleObjects | F_1152915508___________________________________ ] [@ hang | GetLogicalDriveStringsA] [@ hang | LocalReAlloc] [@ hang | memcpy | RealMsgWaitForMultipleObjectsEx] [@ hang | memcpy |
I'm closing a lot of bugs which are filed as Adobe Flash bugs which are either irrelevant, not actionable, or not serious enough to track in the Mozilla bug tracker. For the most part, Flash bugs should be filed in Adobe bugbase, and we'll only track a few highly-critical issues in the Mozilla tracker.
Status: REOPENED → RESOLVED
Closed: 7 years ago3 years ago
Resolution: --- → INCOMPLETE
Version and milestone values are being reset to defaults as part of product refactoring.
Version: 11.x → unspecified
You need to log in before you can comment on or make changes to this bug.