Last Comment Bug 788489 - nightly mozconfigs in mozilla-aurora/beta should not have --disable-profiling
: nightly mozconfigs in mozilla-aurora/beta should not have --disable-profiling
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Build Config (show other bugs)
: 16 Branch
: All All
: -- normal (vote)
: ---
Assigned To: :Ehsan Akhgari
:
: Gregory Szorc [:gps]
Mentors:
Depends on:
Blocks: 786278
  Show dependency treegraph
 
Reported: 2012-09-05 06:16 PDT by Chris AtLee [:catlee]
Modified: 2012-09-07 16:56 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed


Attachments
Aurora patch (3.72 KB, patch)
2012-09-06 11:16 PDT, :Ehsan Akhgari
catlee: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
Details | Diff | Splinter Review
Beta patch (3.72 KB, patch)
2012-09-06 11:17 PDT, :Ehsan Akhgari
catlee: review+
lukasblakk+bugs: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description Chris AtLee [:catlee] 2012-09-05 06:16:51 PDT
As part of our pre-release tests, we compare the nightly and release mozconfigs for each platform under $product/config/mozconfigs. The check has been failing for beta builds because the nightly mozconfigs have --disable-profiling, and the release mozconfig doesn't have it. The check doesn't know which is the default, so it's safer to have both mozconfigs contain the same flag.

This probably affects aurora and central as well.
Comment 1 Chris AtLee [:catlee] 2012-09-05 06:26:09 PDT
You can use `sed /enable-profiling/d` to delete lines, e.g.:

sed -i /enable-profiling/d browser/config/mozconfigs/linux32/nightly
Comment 2 :Ehsan Akhgari 2012-09-06 11:16:37 PDT
Created attachment 658934 [details] [diff] [review]
Aurora patch

Not sure if this requires approval, but here it goes.
Comment 3 :Ehsan Akhgari 2012-09-06 11:17:33 PDT
Created attachment 658935 [details] [diff] [review]
Beta patch
Comment 4 :Ehsan Akhgari 2012-09-06 11:20:39 PDT
Also updated the docs.

https://wiki.mozilla.org/Release_Management/Merge_Documentation#Disable_profiling
Comment 5 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-09-06 20:44:16 PDT
Comment 0 mentions this affects central as well. Is that just not a problem because "release" mozconfigs aren't used there?
Comment 6 :Ehsan Akhgari 2012-09-07 14:31:02 PDT
(In reply to comment #5)
> Comment 0 mentions this affects central as well. Is that just not a problem
> because "release" mozconfigs aren't used there?

release mozconfigs don't have --enable-profiling in them.

Note You need to log in before you can comment on or make changes to this bug.