Last Comment Bug 788598 - logged out state has no login
: logged out state has no login
Status: RESOLVED FIXED
[Fx17]
:
Product: Firefox
Classification: Client Software
Component: SocialAPI (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 18
Assigned To: Shane Caraveo (:mixedpuppy) [on leave 5/16-7/16]
:
Mentors:
: 791054 (view as bug list)
Depends on: 790112
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-05 10:54 PDT by Shane Caraveo (:mixedpuppy) [on leave 5/16-7/16]
Modified: 2013-12-27 14:19 PST (History)
6 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed


Attachments
v1 (6.15 KB, patch)
2012-09-27 11:17 PDT, Shane Caraveo (:mixedpuppy) [on leave 5/16-7/16]
jaws: review+
Details | Diff | Review
V2 (5.99 KB, patch)
2012-09-28 16:42 PDT, Shane Caraveo (:mixedpuppy) [on leave 5/16-7/16]
akeybl: approval‑mozilla‑aurora+
Details | Diff | Review

Description Shane Caraveo (:mixedpuppy) [on leave 5/16-7/16] 2012-09-05 10:54:38 PDT
if logged out of the provider, the profile section of the provider menu has a generic face and says "not logged in".  This should be clickable and take the user to the top level of the provider website.
Comment 1 Mark Hammond [:markh] 2012-09-05 23:04:17 PDT
As going to the top-level origin may not always be the most appropriate place to land, this implies some API might be necessary to indicate where that click should go.
Comment 2 Asa Dotzler [:asa] 2012-09-07 13:27:55 PDT
This is an extremely confusing state and I think we need to do something about it for 17. Changing the text from "not logged in" to a link that says "log in" and takes you to the social providers front page would probably be sufficient.

I think we're OK going to the top level origin for now though we may want a better solution in the future.
Comment 3 Shane Caraveo (:mixedpuppy) [on leave 5/16-7/16] 2012-09-07 14:00:06 PDT
I created bug 789585 for future enhancement, and for now we'll just do the top-level origin for the "login" link.
Comment 4 Mark Hammond [:markh] 2012-09-13 17:12:54 PDT
*** Bug 791054 has been marked as a duplicate of this bug. ***
Comment 5 Shane Caraveo (:mixedpuppy) [on leave 5/16-7/16] 2012-09-27 11:17:53 PDT
Created attachment 665553 [details] [diff] [review]
v1

This patch also makes the entire profile area in the menu clickable
Comment 6 Jared Wein [:jaws] (please needinfo? me) 2012-09-27 14:23:43 PDT
Comment on attachment 665553 [details] [diff] [review]
v1

Review of attachment 665553 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/base/content/browser-social.js
@@ +32,4 @@
>        openUILinkIn(Social.provider.profile.profileURL, "tab");
> +    else {
> +      // bug 789585 open the top level of the provider domain, in the future
> +      // we will modify the api to allow a provider to define a login url

This comment is a little confusing. Please replace it with,
// XXX Bug 789585 will implement an API for provider-specified login pages.

::: browser/base/content/browser.xul
@@ +668,5 @@
>                     hidden="true">
>          <hbox id="social-toolbar-button-box" class="social-statusarea-container">
>            <button id="social-provider-image" type="menu">
>              <menupopup id="social-statusarea-popup">
> +              <hbox id="social-statusarea-user" pack="left" align="center"

pack="start"

@@ +674,4 @@
>                  <image id="social-statusarea-user-portrait"/>
>                  <vbox>
> +                  <button id="social-statusarea-notloggedin"
> +                          class="link">&social.notLoggedIn.label;</button>

label="&social.notLoggedIn.label;"
Comment 7 Shane Caraveo (:mixedpuppy) [on leave 5/16-7/16] 2012-09-28 16:38:24 PDT
rebasing to land on top of bug 790112
Comment 8 Shane Caraveo (:mixedpuppy) [on leave 5/16-7/16] 2012-09-28 16:42:30 PDT
Created attachment 666115 [details] [diff] [review]
V2

feedback implemented, rebased on top of another bug modifying the same area of xul, carrying forward r+
Comment 9 Shane Caraveo (:mixedpuppy) [on leave 5/16-7/16] 2012-10-02 13:14:36 PDT
Comment on attachment 666115 [details] [diff] [review]
V2

[Approval Request Comment]
User impact if declined: poor ux in social provider menu
String or UUID changes made by this patch: none
Comment 10 Ryan VanderMeulen [:RyanVM] 2012-10-02 17:22:34 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/09a1c6254392
Comment 11 Ed Morley [:emorley] 2012-10-03 06:05:25 PDT
https://hg.mozilla.org/mozilla-central/rev/09a1c6254392
Comment 12 Alex Keybl [:akeybl] 2012-10-03 15:13:29 PDT
Comment on attachment 666115 [details] [diff] [review]
V2

Isolated changes to Social API without l10n impact, approving for Aurora 17.
Comment 13 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-10-05 07:39:32 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/53a6cfba7382

Note You need to log in before you can comment on or make changes to this bug.