Charset Override mechanism needed for browser

VERIFIED FIXED in M16

Status

()

Core
Internationalization
P3
major
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: Katsuhiko Momoi, Assigned: cata)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+])

(Reporter)

Description

18 years ago
I'm filing this bug to make a formal request that we put in a
charset override mechanism for the Browser. We have had an internal
document for the earlier 5.0 specification:

http://warp/GApps/intl/gromit/gromitencode.html#feedback

which could be useful in looking at issues raised earlier.
It is not necessary that we follow the recommendations there
but we should at least be able to address the issues there
with our new spec. If enough people are interested in
reading the override pasrt of this document, I'll be happy
to externalize that part as a separate file.

There is also a somewhat related issue for Editor, which needs
to address some Editor-sepcific issues.The Editor specs for
the old 5.0 project is here:

http://warp/GApps/intl/gromit/gromitcomposer.html

The Mail pasr of the request was filed as; Bug 5938.

Our hope is that we should come up with a consistent
UI for the override taking into account various needs
involved.

I'll add more comments later.
(Reporter)

Updated

18 years ago
Blocks: 5938

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M10

Comment 1

18 years ago
Mark this as a M10 feature.

Updated

18 years ago
Target Milestone: M10 → M11

Comment 2

18 years ago
Move to M11

Updated

18 years ago
Target Milestone: M11 → M12

Comment 3

18 years ago
this have dependency on cata's encoding menu work. Since he won't make it untill
next Monday, I don't think I can work on this in M11. Move to M12

Updated

18 years ago
Assignee: ftang → cata
Status: ASSIGNED → NEW

Comment 4

18 years ago
reassign to cata.
Should considering use "Shift-" menu select for "Charset Override" ? Momoi- what
is the currenty ui spec say?

Comment 5

18 years ago
Cata, please put a pointer to the spec in this bug report.

Frank, I think the Shift menu selection is too obscure. Users want the menu to
have an effect when they select something, even without the Shift key.
(Reporter)

Comment 6

18 years ago
My current proposal is that:

"Changing a Character encoding menu on a page with a meta tag which
has been loaded already triggers Charset override. The override
is one time only and will not persist. This way it will not
require any additional UI."

This proposal is contained in this document (See the section on
Charset override.)

http://rocknroll/users/momoi/publish/seamonkey/50intlui.html

I'll be updating this document as it relates to Charset menu UI
according to the more recent UI proposal in the Editor UI document
and also other-lang related preferences.

I've looked at IE5 for charset override behavior and it simply
override any meta tag if you choose a menu item other than the
one that is the current document charset. This does not persist
and you can override it any number of times with different
selections.
(Reporter)

Comment 7

18 years ago
I also agree with Erik that using special key is not needed.
I think we want this to be a easily discoverable process and
changing a menu is what the users are used to already.
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

18 years ago
Target Milestone: M12 → M13
(Assignee)

Updated

18 years ago
Blocks: 20761

Updated

18 years ago
Target Milestone: M13 → M14

Comment 8

18 years ago
Out of time for M13, moving to M14.

Comment 9

18 years ago
change platform to ALL
Hardware: PC → All

Comment 10

18 years ago
change OS to ALL
OS: Windows NT → All

Comment 11

18 years ago
Added beta1 for Encoding menu functional.
Keywords: beta1

Updated

18 years ago
Whiteboard: [pdt+]

Comment 12

18 years ago
Changed QA contact to amasri@netscape.com.
QA Contact: teruko → amasri
(Assignee)

Updated

18 years ago
Whiteboard: [pdt+] → [pdt+] ETA: 11/Feb
(Assignee)

Comment 13

18 years ago
ETA moved to 15.
Whiteboard: [pdt+] ETA: 11/Feb → [pdt+] ETA: 15/Feb

Comment 14

18 years ago
Cata, I cleared the ETA.  Please update with new ETA.
Whiteboard: [pdt+] ETA: 15/Feb → [pdt+]
(Assignee)

Updated

18 years ago
Whiteboard: [pdt+] → [pdt+] ETA: 23/Feb
(Assignee)

Comment 15

18 years ago
I'm not done yet. I think tomorrow it'll be ready.
Whiteboard: [pdt+] ETA: 23/Feb → [pdt+] ETA: 24/Feb

Comment 16

18 years ago
This will become a pdt- on friday if you don't make tomorrow.  Good luck! ;-)
(Assignee)

Updated

18 years ago
Whiteboard: [pdt+] ETA: 24/Feb → [pdt+] ETA: 24/Feb I have a fix, but I am not very confident about possible side effects.

Comment 17

18 years ago
cata has a fix that seems to be working in his local tree.  But he needs
to review his code and discuss with ftang and do some thorough testing
before checking in.  It won't be checked in today.  We probably will check
in early next week or post-Beta1 depending upon the review and testing.
Whiteboard: [pdt+] ETA: 24/Feb I have a fix, but I am not very confident about possible side effects. → [pdt+] ETA: 24/Feb I have a fix, but need to review potential side effects

Comment 18

18 years ago
Either get this reviewed an in RSN, or get it off the radar.  Your last comment 
suggests that you are willing to later it (post beta).  One way or the other, 
lets move this one along.
Please update the status whiteboard with a landing date if it is going in now.
Thanks,
Jim
(Assignee)

Comment 19

18 years ago
No, we still want this for beta. I am almost done with the latest revision of my 
patch, we have a set of tests, and QA is ready to hammer on it. Check-in date 
is tomorrow or Friday the latest.
Whiteboard: [pdt+] ETA: 24/Feb I have a fix, but need to review potential side effects → [pdt+] ETA: 2/Mar I have a fix, but need to review potential side effects
(Assignee)

Comment 20

18 years ago
Ok. the charset override has been activated. Remaining work is post-beta, bug 
#30169
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
Whiteboard: [pdt+] ETA: 2/Mar I have a fix, but need to review potential side effects → [pdt+] done.

Comment 21

18 years ago
If the fix was backed out, shouldn't this bug be reopened?
(Assignee)

Comment 22

18 years ago
Fix was backed out. It caused regression #30299
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

18 years ago
No longer blocks: 5938

Comment 23

18 years ago
Removed this from beta1 candidacy.
Keywords: beta1
Whiteboard: [pdt+] done.

Updated

18 years ago
Target Milestone: M14 → M16

Comment 24

17 years ago
cata- please clean up the REOPEN state and mark it ASSIGN. And please state 
clearly what kind of regression you introduce last time so QA can verify when 
you fix this later. 
(Assignee)

Comment 25

17 years ago
*** Bug 30169 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

17 years ago
Status: REOPENED → ASSIGNED

Updated

17 years ago
Keywords: beta2

Updated

17 years ago
Blocks: 28284

Updated

17 years ago
Blocks: 28740

Updated

17 years ago
Keywords: nsbeta2

Comment 26

17 years ago
Putting on [nsbeta2+] radar.  
Keywords: beta2
Whiteboard: [nsbeta2+]
(Assignee)

Comment 27

17 years ago
Implemented. For now, it is activated only when you add the following line in 
your prefs file: pref("intl.charset.override", "yes");

QA, please activate and test it. Fill the eventual bugs against me...
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → FIXED

Comment 28

17 years ago
Changed QA contact to teruko@netscape.com.
QA Contact: amasri → teruko

Comment 29

17 years ago
I tested this in 2000-05-30 Win32 build, the override in the following specs does not work.
http://rocknroll/users/momoi/publish/seamonkey/5_0intlbrowsermenudft2.html

Charset Override: 
An override will not persist if a new document is loaded or Super-reload of the same document is chosen(?) -- see below for Issues. 

Steps of reproduce
1. Put user_pref("intl.charset.override", "yes"); in prefs.js file
2. Start Netscape 
3. Go to http://home.netscape.com/ja/
4. Select Character coding ->Multibyte->Japanese(EUC-JP)
   The page is tried to loaded as EUC-JP.  The Japanese characters are displayed 
   garbage. (This is correct.)
5. Go to http://home.netecape.com/ko/
   The page is displayed the different Kanji characters.  This page is not in
   Korean characters.
 
   If new document is loaded, the override is not persist. So, this page is loaded as Korean (EUC-KR) since this page has meta charset info.


   
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 30

17 years ago
M16 has been out for a while now, these bugs target milestones need to be 
updated.
(Assignee)

Comment 31

17 years ago
I'm marking this bug fixed againb, as the override is not supposed to be 
persistent. It is only supposed to survive a simple "reload". But that is marked 
in different bugs: 43530 and 43529.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 32

17 years ago
I verified this in 2000-06-30-08 Win32, Mac, and Linux build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.