AutoComplete causing multiple entries of the same word

VERIFIED FIXED in Firefox 15

Status

()

Firefox for Android
Keyboards and IME
P1
normal
VERIFIED FIXED
5 years ago
9 months ago

People

(Reporter: Tyler, Assigned: cpeterson)

Tracking

(Blocks: 1 bug)

16 Branch
Firefox 18
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox15+ verified, firefox16+ verified, firefox17 verified, firefox18 verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Related to Bug #780543 Comment 15

This same issue is reflected in google Play Reviews
"When I type a message, the words are repeated! It'll so if I type hello, it'll say helhellhello. Real aggravating!"

This is just one specific review, there are many more that are "can't type in google, fb, etc" "can't type on websites" etc. That are possibly the same thing.
Coalescing the Google Play reviews; have we seen a pattern of device model/brand?
Posted a test-case in 780543 as I can reproduce. Not sure how this bug differs; they all sound the same.

Comment 3

5 years ago
Chris believes this may be bug 769520.
tracking-firefox15: ? → +
tracking-firefox16: --- → +

Comment 4

5 years ago
Has anyone contacted Swiftkey for an insight into this? They have the same issue being reported with multiple browsers on their site. While I don't think the issue is exclusive to Swiftkey, it could shed some light.
(Assignee)

Comment 5

5 years ago
I backed out bug 769520 from m-c, so this bug should (with luck) be fixed in tomorrow's Nightly:
https://hg.mozilla.org/mozilla-central/rev/3974efe8d584
https://hg.mozilla.org/mozilla-central/rev/1f1e5cdae68d
Assignee: nobody → cpeterson
Status: NEW → ASSIGNED

Comment 6

5 years ago
I can reproduce this issue using Swiftkey 3 Trial on Nightly 18.0a1 (2012-09-05) following the STR and the test-case from Bug 780543 using:
- Samsung Galaxy Tab 2 7.09 (Android 4.0.4)
- Samsung Galaxy Nexus (Android 4.1.1)
- ASUS EEE Transformer (Android 4.0.3)

Using the same device,STR and test-case the issue is not reproducible on latest Nightly 18.0a1 (2012-09-06).

Updated

5 years ago
Keywords: qawanted, steps-wanted
(Assignee)

Comment 7

5 years ago
Created attachment 658959 [details] [diff] [review]
Backout ad4fd5dcc088 (Bug 769520 Part 2)

[Approval Request Comment]
Regression caused by (bug #): bug 769520
User impact if declined: Keyboard input can repeat itself in some large text fields, making typing impossible.
Testing completed (on m-c, etc.): QA tested Nightly 18.0a1 2012-09-06
Risk to taking this patch (and alternatives if risky): bug 759857 regression for some phones with small screens in landscape orientation
Attachment #658959 - Flags: approval-mozilla-release?
Attachment #658959 - Flags: approval-mozilla-beta?
Attachment #658959 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 8

5 years ago
Created attachment 658960 [details] [diff] [review]
Backout b9ad5793fbba (Bug 769520 Part 1)

[Approval Request Comment]
Regression caused by (bug #): bug 769520
User impact if declined: Keyboard input can repeat itself in some large text fields, making typing impossible.
Testing completed (on m-c, etc.): QA tested Nightly 18.0a1 2012-09-06
Risk to taking this patch (and alternatives if risky): bug 759857 regression for some phones with small screens in landscape orientation
Attachment #658960 - Flags: approval-mozilla-release?
Attachment #658960 - Flags: approval-mozilla-beta?
Attachment #658960 - Flags: approval-mozilla-aurora?
Attachment #658959 - Flags: approval-mozilla-release?
Attachment #658959 - Flags: approval-mozilla-release+
Attachment #658959 - Flags: approval-mozilla-beta?
Attachment #658959 - Flags: approval-mozilla-beta+
Attachment #658959 - Flags: approval-mozilla-aurora?
Attachment #658959 - Flags: approval-mozilla-aurora+
Comment on attachment 658960 [details] [diff] [review]
Backout b9ad5793fbba (Bug 769520 Part 1)

Taking this for the 15.0.1 respin for Mobile, we'll have to take the hit of the single-device glitch in bug 759857 in order to see this larger issue fixed for more users. I know Chris is going to see what he can do today for a testable fix for the Samsung bug but either way we'll take this on branches, please update the status flags in bug 769520 once this is backed out.
Attachment #658960 - Flags: approval-mozilla-release?
Attachment #658960 - Flags: approval-mozilla-release+
Attachment #658960 - Flags: approval-mozilla-beta?
Attachment #658960 - Flags: approval-mozilla-beta+
Attachment #658960 - Flags: approval-mozilla-aurora?
Attachment #658960 - Flags: approval-mozilla-aurora+
(Assignee)

Comment 10

5 years ago
Fixed by bug 780543 comment 22:
https://hg.mozilla.org/mozilla-central/rev/3974efe8d584
https://hg.mozilla.org/mozilla-central/rev/1f1e5cdae68d
Blocks: 759857
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
status-firefox15: --- → affected
status-firefox16: --- → affected
status-firefox17: --- → affected
status-firefox18: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 18
(Assignee)

Comment 11

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/53bcbf4def76
https://hg.mozilla.org/releases/mozilla-aurora/rev/6210771c474b
status-firefox17: affected → fixed
(Assignee)

Comment 12

5 years ago
https://hg.mozilla.org/releases/mozilla-beta/rev/c43988d1b0b7
https://hg.mozilla.org/releases/mozilla-beta/rev/dd8f72317c3f
status-firefox16: affected → fixed
(Assignee)

Comment 13

5 years ago
https://hg.mozilla.org/releases/mozilla-release/rev/d90936ea0e2e
https://hg.mozilla.org/releases/mozilla-release/rev/5b80d834dff7
status-firefox15: affected → fixed

Updated

5 years ago
Blocks: 769520

Updated

5 years ago
Status: RESOLVED → VERIFIED
status-firefox15: fixed → verified
status-firefox16: fixed → verified
status-firefox17: fixed → verified
status-firefox18: fixed → verified
You need to log in before you can comment on or make changes to this bug.