Holding backspace causes enormous repeats of content

VERIFIED FIXED in Firefox 15

Status

()

Firefox for Android
Keyboards and IME
P1
normal
VERIFIED FIXED
5 years ago
10 months ago

People

(Reporter: Joe Drew (not getting mail), Assigned: cpeterson)

Tracking

(Blocks: 1 bug, {regression})

16 Branch
Firefox 18
ARM
Android
regression
Points:
---

Firefox Tracking Flags

(firefox14 unaffected, firefox15+ verified, firefox16+ verified, firefox17+ verified, firefox18 verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
When I'm looking to delete a bunch of text with SwiftKeyX, I hold down the backspace key to engage key repeat. Unfortunately, while in web text fields (at least), when I hold backspace, the content in question gets repeated and repeated, and then eventually gets deleted.

I can create a screencast of this later if necessary.
(Assignee)

Comment 1

5 years ago
Joe, which version of Firefox are you using?
Assignee: nobody → cpeterson
OS: Mac OS X → Android
Priority: -- → P1
Hardware: x86 → ARM
(Assignee)

Comment 2

5 years ago
I can repro with Nightly 17 and Aurora 16, but not Beta 15 or Firefox 14.
Status: NEW → ASSIGNED
status-firefox14: --- → unaffected
status-firefox15: --- → unaffected
status-firefox16: --- → affected
status-firefox17: --- → affected
(Reporter)

Comment 3

5 years ago
Nightly 17 for sure, though I've seen this over the past several weeks (as long as I've been using Swiftkey).
(Assignee)

Comment 4

5 years ago
Joe, are you using Firefox's form autocomplete popup? I can repro this bug if I use the form autocomplete popup to insert some text and then try to delete the autocompleted text. But I can't repro this bug by just typing then deleting.

I believe this a SwiftKey bug because their users have reported similar problems with Google Chrome and other apps:

http://support.swiftkey.net/forums/116693-2-swiftkey-bugs-/suggestions/2975688-google-chrome-backspace-inserts-and-repeats-lett

However, if Firefox's form autocomplete triggers this SwiftKey bug, I can disable autocomplete for SwiftKey (until they fix their bug).
(Reporter)

Comment 5

5 years ago
Not intentionally, but it could be that it works out that way.

STR:
1. Open Fennec.
2. Type "penny arcade" in awesomebar. Tap on the Google entry saying "Penny Arcade".
3. Tap on the space in the middle of the string, as if you wanted to delete "Penny" but leave "arcade".
4. Hold backspace. Enormous repetition of the word "Penny".
(Assignee)

Comment 6

5 years ago
I can repro the "Penny Arcade" bug on Nightly 17, but I can also repro the bug on Chrome and the JB Stock browser (if I try to delete "Arcade" instead of "Penny"). I am testing SwiftKey 3 Trial version 3.0.0.302 on JB 4.1.1.

As the SwiftKey forum link in comment 4 describes, this is a SwiftKey bug. I can only repro the bug with Nightly 17 and Aurora 16, but SwiftKey users report problems with "latest Firefox" and "Firefox beta". I assume they are referring to Firefox 14 and Beta 15.

I will keep this bug open for now so we can track when/whether SwiftKey fixes the problem. If they don't fix it in a timely manner, we may need to add a workaround. :\
tracking-firefox16: --- → ?
Target Milestone: --- → Future
tracking-firefox16: ? → +
tracking-firefox17: --- → +

Comment 7

5 years ago
Swiftkey appear to be aware of the problem: http://support.swiftkey.net/forums/116693-2-swiftkey-bugs-/suggestions/2975688-google-chrome-backspace-inserts-and-repeats-lett

Comment 8

5 years ago
Yes i have the same.  Mostly with SwiftKey. But also with built in keyboard.  Always in Firefox beta.  Other aplications works well. Using backspace its a nightmare
I have seen this with SwiftKey, but also with the Samsung keyboard on the Galaxy S3. Having all of my keyboards break makes me sad! 
I can also get similar behavior ( whole word repeats) when doing other things - e. g. I typing after a punctuation mark like that paren. 

occasional workaround is to back-sssssswipe on the keyboard, which deletes the whole word and allows re-tttttttyping.
(Assignee)

Comment 10

5 years ago
I saw this bug with Swype yesterday.
Summary: Holding backspace with SwiftKey causes enormous repeats of content → Holding backspace causes enormous repeats of content
Version: unspecified → Firefox 16
(Assignee)

Updated

5 years ago
Duplicate of this bug: 781471
This appears to be happening in FF15 according to comments on the Play Store, and even with the stock browser according to comments here. Can we investigate for inclusion in a possible 15.0.1?
status-firefox15: unaffected → affected
tracking-firefox15: --- → ?
so is this a regression in firefox? comment 2 says it regressed between Fx15 and Fx16, but comment 12 says that it is happening in Fx15.
(Assignee)

Comment 14

5 years ago
I am investigating whether this is a new bug beyond just SwiftKey's known bug.

I don't have an ETA for a fix or backout ready for 15.0.1.
STR (for what I'm seeing and what google play reviews are mentioning):
Reply to an Email in Zimbra (stock Keyboard, Droid X).
Enter one Letter
press any other key. Autocomplete picks the first word and puts that in (example, if I tried to type and, it would be aand and all I hit were "a" and "n")
Autocomplete will continue this for each key you press (aandandand after pressing "a" "n" "d" and space).
Hitting backspace will do one more autocomplete, but then you can back up and type the word normally. Hitting the space key begins the cycle over.

Same bug?
(In reply to Tyler Downer [:Tyler] from comment #15)
> STR (for what I'm seeing and what google play reviews are mentioning):
> Reply to an Email in Zimbra (stock Keyboard, Droid X).
...
> Same bug?

(In reply to Brad Lassey [:blassey] from comment #13)
> so is this a regression in firefox? comment 2 says it regressed between Fx15
> and Fx16, but comment 12 says that it is happening in Fx15.

My hunch is that very recent Android keyboards do similar autocomplete tricks to SwiftKey -- I have seen this bug with the stock keyboard on my Galaxy S3 (and posted as such in one of the bugs hanging around). SwiftKey still demonstrates it more visibly, of course.

So this isn't so much a regression as the ground shifting under us. On my Android 2.3 device, the stock keyboard was pretty 'dumb', and I guess that saved us. Now that option has drifted away...
I'll echo comment 10: I've seen this with Swype on a Samsung Charge and Samsung 10.1 tablet using Aurora (16 I think, definitely 17). I was blaming Swype but after seeing this bug I realized I've only seen it in Firefox and not other apps.
Re: Zimbra test-case 

I am able to reproduce this on mozilla-central (09/05), mozilla-aurora (09/05), mozilla-beta (16/b2), and mozilla-release (15) using my Galaxy Nexus (Android 4.1.1), stock Android Keyboard quite easily. A repeat of characters are input both while typing and while backspacing in a simple reply email.
status-firefox18: --- → affected
Created attachment 658566 [details]
testcase
(Assignee)

Comment 20

5 years ago
I have determined this was an Aurora 15 regression from bug 769520:
https://hg.mozilla.org/mozilla-central/rev/b9ad5793fbba

The change is easy to backout, BUT it was a speculative fix for a bunch of random IME crashes. I can backout the change and investigate a different fix for the random IME crashes.
Keywords: regression
We're taking the backout on m-c today, and will land it to m-r tomorrow if builds pan out for our 15.0.1 mobile respin.
tracking-firefox15: ? → +
(Assignee)

Comment 22

5 years ago
I backed out the regression changes from m-c, so this bug _should_ be fixed in tomorrow's Nightly:
https://hg.mozilla.org/mozilla-central/rev/3974efe8d584
https://hg.mozilla.org/mozilla-central/rev/1f1e5cdae68d

Comment 23

5 years ago
We were not able to reproduce this on today's Nightly build (2012-09-06) using the attached testcase. 

We tried on:
- Samsung Galaxy Nexus (Android 4.1.1) using stock Android Keyboard and SwiftKey 3 Trial
- Samsung Galaxy Tab 2 7.0 (Android 4.0.4) using SwiftKey 3 Trial
- ASUS EEE Transformer (Android 4.0.3) using SwiftKey 3 Trial
Confirming too (Galaxy SII, 4.0.4), back-out fixed this on mozilla-central.
(Assignee)

Comment 25

5 years ago
Fix landed in comment 22
Blocks: 759857
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
status-firefox18: affected → fixed
Resolution: --- → FIXED
Target Milestone: Future → Firefox 18
(Assignee)

Comment 26

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/53bcbf4def76
https://hg.mozilla.org/releases/mozilla-aurora/rev/6210771c474b
status-firefox17: affected → fixed
(Assignee)

Comment 27

5 years ago
https://hg.mozilla.org/releases/mozilla-beta/rev/c43988d1b0b7
https://hg.mozilla.org/releases/mozilla-beta/rev/dd8f72317c3f
status-firefox16: affected → fixed
(Assignee)

Comment 28

5 years ago
https://hg.mozilla.org/releases/mozilla-release/rev/d90936ea0e2e
https://hg.mozilla.org/releases/mozilla-release/rev/5b80d834dff7
status-firefox15: affected → fixed

Comment 29

5 years ago
Created attachment 659267 [details]
screenshot

I was still able to reproduce this bug on Asus EEE Transformer TF101 (Android 4.0.3) using ASUS Keyboard as you can see in the screenshot on Firefox 16.0 Beta 2 build 2. Using SwiftKey or Android keyboard all works as expected.
(In reply to Andreea Pod from comment #29)
> Created attachment 659267 [details]
> screenshot
> 
> I was still able to reproduce this bug on Asus EEE Transformer TF101
> (Android 4.0.3) using ASUS Keyboard as you can see in the screenshot on
> Firefox 16.0 Beta 2 build 2. Using SwiftKey or Android keyboard all works as
> expected.

The fix will be in the next available beta candidate; beta 2 build 2 did not take this change.

Updated

5 years ago
Status: RESOLVED → VERIFIED
status-firefox15: fixed → verified
status-firefox16: fixed → verified
status-firefox17: fixed → verified
status-firefox18: fixed → verified
Duplicate of this bug: 782595
You need to log in before you can comment on or make changes to this bug.