Closed Bug 789093 Opened 9 years ago Closed 9 years ago

Slideshow is broken on cnet.com

Categories

(Firefox :: General, defect)

17 Branch
x86
Windows 7
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Tracking Status
firefox17 --- unaffected
firefox18 --- verified
firefox19 --- verified

People

(Reporter: alice0775, Unassigned)

References

()

Details

(Keywords: regression)

Steps to reproduce:
1. Open http://www.cnet.com/
2. Observe text and back ground color in the slide show
3. Click small yellow dots or Click "<" ">" mark at the bottom of the slide show

Actual results:
  Background color is transparent.
  Slide show does not work properly.
  And the following error in the error console:
Error: TypeError: this.indicators[C] is undefined
Source file: http://asset1.cbsistatic.com/cnwk.1d/html/rb/js/tron/doors/doors.tron.r2d2.compressed.js
Line: 4

Expected results:
  Background color should be whitish.
  Slide show should work properly.


Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/20fc34efd733
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120804004627
Bad:
http://hg.mozilla.org/mozilla-central/rev/0a17cde2a4b6
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120804111326
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=20fc34efd733&tochange=0a17cde2a4b6


Regression window(m-c)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/aa100b9efcca
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120803104127
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/87e7abe891a9
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120803113827
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=aa100b9efcca&tochange=87e7abe891a9
Keywords: regression
Duplicate of this bug: 789316
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 781796
Blocks: 789036
No longer blocks: harmony:stringextras
Blocks: 793781
No longer blocks: 793781
This bug needs to be reopened. The slideshow issue is not related.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Status: REOPENED → NEW
Here are the errors on OS X.

[09:13:44.135] Unknown property '-moz-box-shadow'.  Declaration dropped. @ http://asset2.cbsistatic.com/cnwk.1d/css/rb/Build/global/base.css?v=2:1
[09:13:44.141] Expected declaration but found '*'.  Skipped to next declaration. @ http://asset3.cbsistatic.com/cnwk.1d/css/rb/Build/global/site1.css:1
[09:13:44.144] Unknown property '-moz-box-shadow'.  Declaration dropped. @ http://asset3.cbsistatic.com/cnwk.1d/css/rb/Build/2000/2000.1.0.css?v=4:1
[09:13:44.144] Unknown property '-moz-border-radius'.  Declaration dropped. @ http://asset3.cbsistatic.com/cnwk.1d/css/rb/Build/2000/2000.1.0.css?v=4:1
[09:13:44.144] Unknown property '-moz-text-shadow'.  Declaration dropped. @ http://asset3.cbsistatic.com/cnwk.1d/css/rb/Build/2000/2000.1.0.css?v=4:1
[09:13:44.144] Error in parsing value for 'filter'.  Declaration dropped. @ http://asset3.cbsistatic.com/cnwk.1d/css/rb/Build/2000/2000.1.0.css?v=4:1
[09:13:44.144] Unknown property '-moz-opacity'.  Declaration dropped. @ http://asset3.cbsistatic.com/cnwk.1d/css/rb/Build/2000/2000.1.0.css?v=4:1
[09:13:44.144] Error in parsing value for 'background'.  Declaration dropped. @ http://asset3.cbsistatic.com/cnwk.1d/css/rb/Build/2000/2000.1.0.css?v=4:1
[09:13:44.144] Expected color but found 'top'.  Error in parsing value for 'background'.  Declaration dropped. @ http://asset3.cbsistatic.com/cnwk.1d/css/rb/Build/2000/2000.1.0.css?v=4:1
[09:13:44.145] Expected declaration but found '*'.  Skipped to next declaration. @ http://asset3.cbsistatic.com/cnwk.1d/css/rb/Build/2000/2000.1.0.css?v=4:1
[09:13:44.145] Unknown property 'zoom'.  Declaration dropped. @ http://asset3.cbsistatic.com/cnwk.1d/css/rb/Build/2000/2000.1.0.css?v=4:1
[09:13:44.147] Error in parsing value for 'border-image'.  Declaration dropped. @ http://asset3.cbsistatic.com/cnwk.1d/css/rb/Build/2000/2000.1.0.css?v=4:1
[09:13:44.586] Selector expected.  Ruleset ignored due to bad selector. @ http://www.cnet.com/:144
[09:13:45.026] Unknown property 'textAlign'.  Declaration dropped. @ http://www.cnet.com/
[09:13:45.656] TypeError: this.indicators[C] is undefined @ http://asset1.cbsistatic.com/cnwk.1d/html/rb/js/tron/doors/doors.tron.r2d2.compressed.js:4
[09:13:46.062] Error in parsing value for 'filter'.  Declaration dropped. @ http://www.cnet.com/
[09:13:46.551] Unknown property '-moz-border-radius'.  Declaration dropped. @ http://www.cnet.com/:6
[09:13:46.551] Error in parsing value for 'top'.  Declaration dropped. @ http://www.cnet.com/:8
[09:13:46.551] Error in parsing value for 'right'.  Declaration dropped. @ http://www.cnet.com/:8
[09:13:46.552] Error in parsing value for 'background'.  Declaration dropped. @ http://www.cnet.com/:50
[09:13:46.552] Error in parsing value for 'display'.  Declaration dropped. @ http://www.cnet.com/:67
[09:13:46.552] Unknown property 'zoom'.  Declaration dropped. @ http://www.cnet.com/:74
[09:13:46.552] Expected declaration but found '*'.  Skipped to next declaration. @ http://www.cnet.com/:156




So, is this a site problem? Or is it on our end?
I'm sure it's still the MooTools 1.2.x issue.
Who's working on this bug? This has been an ongoing bug for a while now. I would think it would be fixed by now.
Nobody is working on the "fix" because ultimately, the correct fix is for CNet to update their copy of MooTools. Until this happens, though, we will be "fixing" it on our side by removing String.prototype.contains. See bug 793781.
Alright. Is Cnet aware of this?
I emailed them about the video issue but never heard back; maybe that caused them to fix it some other way. https://cbsi.secure.force.com/CBSi/sitefeedback?template=template_cnet&referer=cnet.com&cfs=SFS_1&data= is a contact link.
That's true. I guess I'll try emailing them.
Thanks!
Alright. I sent an email through customer support, although that is not really what I want. I believe it should help. It might be a while before they get back to it though. Here's part of the email they sent.

////////
This e-mail is to acknowledge receipt of your message. We make every effort to respond to all inquiries.  Your inquiry has been assigned a case number 00020485.
////////

We will see if they ever respond.
Oh, also this bug needs to be updated. Only Firefox 18 and 19 are affected.
Alright, Cnet responded. Here is what they said:

//////////////////////////////
Dear Josiah,

Thank you for taking the time to write us about MooTools.

We value your comments and have forwarded them on to our manager. Our goal is to make CNET an easy to use, friendly and safe site that helps people find and learn about the latest tech and consumer electronics.

Please let us know if we may be of further assistance.

Sincerely,
Arturo
CNET Support
////////////////////////////////

They are now aware of the situation. Hopefully it will be fixed relatively soon.
Cnet has once again modified their website. It does resolve the issue we have had, but I am not sure if they will keep it this way. If it has not changed in a week we can mark this as resolved.
It looks like they've updated their MooTools version to 1.4.0, which should resolve the problems. Thanks for your help, Josiah!
Status: NEW → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
Verified fixed in the Firefox 18 beta 4 build.

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20121212073002
QA Contact: manuela.muntean
Verified fixed in the Firefox 19 beta 2 build.

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130116072953
Status: RESOLVED → VERIFIED
Also checked on Windows 7 32-bit, 19 beta 2.

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:19.0) Gecko/20100101 Firefox/19.0
You need to log in before you can comment on or make changes to this bug.