Last Comment Bug 789102 - Split browser_586068-cascaded_restore.js into multiple tests
: Split browser_586068-cascaded_restore.js into multiple tests
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Session Restore (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 18
Assigned To: Tim Taubert [:ttaubert] (on PTO, back Aug 29th)
:
Mentors:
Depends on: 794436 797263 802953
Blocks: 617062 775955 782995 789003 789709 809123
  Show dependency treegraph
 
Reported: 2012-09-06 10:00 PDT by Tim Taubert [:ttaubert] (on PTO, back Aug 29th)
Modified: 2012-11-06 10:44 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
patch v1 (71.00 KB, patch)
2012-09-06 10:00 PDT, Tim Taubert [:ttaubert] (on PTO, back Aug 29th)
no flags Details | Diff | Splinter Review
patch v2 (71.08 KB, patch)
2012-09-26 05:51 PDT, Tim Taubert [:ttaubert] (on PTO, back Aug 29th)
felipc: review+
Details | Diff | Splinter Review

Description Tim Taubert [:ttaubert] (on PTO, back Aug 29th) 2012-09-06 10:00:22 PDT
Created attachment 658912 [details] [diff] [review]
patch v1

browser_586068-cascaded_restore.js is quite a big file consisting of multiple tests. We have a couple of intermittent failures with this and it would certainly help to split this into multiple test files to ease debugging a little.

This should also reduce the possibility of cascading failures because at the moment it doesn't seem like the test state is cleanly restored before moving on to the next sub-test.
Comment 1 Tim Taubert [:ttaubert] (on PTO, back Aug 29th) 2012-09-07 04:57:07 PDT
There are some strange style editor crashes on try. Not sure why they should be related...

https://tbpl.mozilla.org/?tree=Try&rev=5805ebce61e4
Comment 2 Tim Taubert [:ttaubert] (on PTO, back Aug 29th) 2012-09-10 04:01:00 PDT
Comment on attachment 658912 [details] [diff] [review]
patch v1

Style editor crashes are fixed. Need to figure out some intermittent timeout in the new tests:

https://tbpl.mozilla.org/?tree=Try&rev=3b6ef2cf072b
Comment 3 Tim Taubert [:ttaubert] (on PTO, back Aug 29th) 2012-09-26 05:51:45 PDT
Created attachment 664915 [details] [diff] [review]
patch v2

Ok, my patch wasn't the culprit. Will be fixed by bug 794436.
Comment 4 Tim Taubert [:ttaubert] (on PTO, back Aug 29th) 2012-09-27 04:25:41 PDT
Looks good on try:

https://tbpl.mozilla.org/?tree=Try&rev=fd3bc18288fc
Comment 5 Tim Taubert [:ttaubert] (on PTO, back Aug 29th) 2012-09-28 01:48:38 PDT
https://hg.mozilla.org/integration/fx-team/rev/f6a071d71458
Comment 6 Tim Taubert [:ttaubert] (on PTO, back Aug 29th) 2012-09-28 10:01:10 PDT
https://hg.mozilla.org/mozilla-central/rev/f6a071d71458

Note You need to log in before you can comment on or make changes to this bug.