Some versions don't have Crashes per ADU entries in the table, but are graphed in Crashes per 100 ADUs

VERIFIED FIXED in 18

Status

Socorro
Webapp
--
blocker
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: stephend, Assigned: espressive)

Tracking

unspecified

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 659152 [details]
Screenshot

STR:

1. Load https://crash-stats.allizom.org/daily?form_selection=by_version&p=Firefox&v[]=14.0.1&v[]=18.0a1&v[]=15.0&v[]=13.0&hang_type=any&os[]=Windows&os[]=Mac&os[]=Linux&date_range_type=report&date_start=2012-08-23&date_end=2012-09-06&submit=Generate#
2. Look at Crashes per 100 ADUs (graph) vs. Crashes per ADU (table, below)

Expected Results:

Data for 15.0, 14.0.1, and 13.0 is displayed, alongside 18.0a1

Actual Results:

Only data for 18.0a1 shows up in the Crashes per ADU table
(Assignee)

Updated

6 years ago
Assignee: nobody → sneethling
(Assignee)

Comment 1

6 years ago
This and bug 789410 seems related to me and must be due to the key used to extract the data for the table from the object. Currently still waiting to get complete access to stage db so I can point my local environment and test against the same data.

Will however try and reproduce using data from dev.db in the mean time.
(Assignee)

Comment 2

6 years ago
[:stephend] - Sent pull request https://github.com/mozilla/socorro/pull/815 - I believe this fixes this bug as well as bug 789408
(Assignee)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

6 years ago
Still seeing this; reopening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

6 years ago
Depends on: 790646

Comment 6

6 years ago
Commits pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/8c4f4c968286d6e6ed582ecdb28cc95a87cf5e32
removed if statement from view fixes bug 789408

https://github.com/mozilla/socorro/commit/52c2ccdb7a2071dbf916f61739185bf9538a89aa
Merge pull request #821 from ossreleasefeed/mobeta-fixes-to-cadu-by-version-789408

removed if statement from view fixes bug 789408

Updated

6 years ago
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
Created attachment 660478 [details]
qa - verified

QA verified on stage -- the Crashes per ADU table is populated with data for 18.0a1, 15.0, 14.0.1, and 13.0.
You need to log in before you can comment on or make changes to this bug.