Last Comment Bug 789791 - Firefox for Android Nightly 20120905 fails to update ("No updates found") if system language is not en-US
: Firefox for Android Nightly 20120905 fails to update ("No updates found") if ...
Status: VERIFIED FIXED
: regression
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: 18 Branch
: ARM Android
: -- major (vote)
: Firefox 18
Assigned To: James Willcox (:snorp) (jwillcox@mozilla.com)
:
: Sebastian Kaspari (:sebastian)
Mentors:
: 789926 (view as bug list)
Depends on: 790702
Blocks: 786380 791387
  Show dependency treegraph
 
Reported: 2012-09-09 07:45 PDT by Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout)
Modified: 2016-07-29 14:29 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
verified


Attachments
logcat for "no update" (22.87 KB, text/plain)
2012-09-09 07:45 PDT, Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout)
no flags Details
use MOZ_UI_LOCALE in update URL instead of system locale on Android (4.28 KB, patch)
2012-09-10 07:01 PDT, James Willcox (:snorp) (jwillcox@mozilla.com)
no flags Details | Diff | Splinter Review
always use en-US for update URL on Android (3.42 KB, patch)
2012-09-10 07:37 PDT, James Willcox (:snorp) (jwillcox@mozilla.com)
mark.finkle: review-
Details | Diff | Splinter Review
Use contents of update.locale file in update URL on Android (8.48 KB, patch)
2012-09-10 09:14 PDT, James Willcox (:snorp) (jwillcox@mozilla.com)
mark.finkle: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout) 2012-09-09 07:45:01 PDT
Created attachment 659571 [details]
logcat for "no update"

Firefox for Android Nightly 20120905 fails to update ("No updates found").

Steps to reproduce:
1. Open about:firefox.
2. Tap the "Check for updates" button.

Actual result:
No update found.

Expected result:
Update found

ftp://ftp.mozilla.org/pub/mobile/nightly/latest-mozilla-central-android/ looks fine.

Logcat reads:
I/GeckoApp( 2118): Got message: Update:Check
I/GeckoApp( 2118): Return 
I/GeckoScreenshot( 2118): rect: 150.000000, 71.800003, 385.200012, 197.000000
I/UpdateService( 1762): next update will be at: Sun Sep 09 20:31:24 MESZ 2012
D/dalvikvm( 1762): GC_CONCURRENT freed 333K, 6% free 8324K/8775K, paused 14ms+5ms, total 39ms
I/UpdateService( 1762): no update available
Comment 1 Aaron Train [:aaronmt] 2012-09-09 09:51:13 PDT
Curious, are you running Android in a language other than English? Do you get an update if you switch your system language to English?
Comment 2 Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout) 2012-09-09 10:14:57 PDT
Indeed, switching from German (de) to en-US in the Android system settings fixed this, so likely regression from bug 786380.
Comment 3 Chris AtLee [:catlee] 2012-09-10 04:45:49 PDT
I'm getting this as well. My nightly is also stuck on 2012-09-05. I believe I have Android set to en-US....but it might be en-CA. Where do I check this setting?
Comment 4 Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout) 2012-09-10 06:54:22 PDT
Android home screen > menu button > system settings > Category 'Personal' > Language & input > Language (first item).

But there are only en-US and en-UK available (at least for the Nexus S with Jelly Bean/4.1.1, don't know if this device dependent).
Comment 5 Chris AtLee [:catlee] 2012-09-10 07:00:28 PDT
Ok, then I'm "English (Canada)"
Comment 6 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-09-10 07:01:31 PDT
Created attachment 659699 [details] [diff] [review]
use MOZ_UI_LOCALE in update URL instead of system locale on Android
Comment 7 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-09-10 07:37:34 PDT
Created attachment 659711 [details] [diff] [review]
always use en-US for update URL on Android
Comment 8 Mark Finkle (:mfinkle) (use needinfo?) 2012-09-10 07:53:35 PDT
Comment on attachment 659711 [details] [diff] [review]
always use en-US for update URL on Android

James found that the Gecko updater uses the locale stored in the update.locale file:
http://mxr.mozilla.org/mozilla-central/source/toolkit/mozapps/update/nsUpdateService.js#852

We plan on trying to read that file too, from this JAR URL:
jar:jar:file:///data/app/org.mozilla.XXX.apk!/omni.ja!/update.locale
where XXX is the right fennec APK name.

We'll try using GeckoJarReader to load the text from the file
Comment 9 Aaron Train [:aaronmt] 2012-09-10 08:14:25 PDT
*** Bug 789926 has been marked as a duplicate of this bug. ***
Comment 10 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-09-10 09:14:13 PDT
Created attachment 659738 [details] [diff] [review]
Use contents of update.locale file in update URL on Android
Comment 11 Mark Finkle (:mfinkle) (use needinfo?) 2012-09-10 10:08:54 PDT
Comment on attachment 659738 [details] [diff] [review]
Use contents of update.locale file in update URL on Android

Looks good
Comment 12 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-09-10 10:55:23 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/bc546b6fe5b5
Comment 13 Thomas Stache 2012-09-10 12:44:08 PDT
The old updater made it impossible to stay on the en-US build, when Android is on another language. What does this "update.locale" file contain?
In the end Fennec should stay on the original locale, no matter what, like desktop Firefox.
Comment 14 Ryan VanderMeulen [:RyanVM] 2012-09-10 18:45:27 PDT
https://hg.mozilla.org/mozilla-central/rev/bc546b6fe5b5
Comment 15 Axel Hecht [:Pike] 2012-09-11 01:34:07 PDT
This is not going to fix existing users on nightly, right? We'll need to do some outreach to have folks re-install? Or should we try to get some update snippets that at least get folks on the multi build. Which may be better than having them stuck.
Comment 16 Paul Feher 2012-09-12 02:15:20 PDT
As I said in Bug 789926 the issue was reproducible on Nightly 18.0a1 2012-09-09
HTC Desire Z (Android 2.3.3).

I can't reproduce it anymore on:
Nightly 18.0a1 (2012-09-11)
Device: HTC Desire Z
OS: Android 2.3.3
Comment 17 Chris AtLee [:catlee] 2012-09-12 05:15:37 PDT
How are we going to get users back on the nightly train?
Comment 18 Mark Finkle (:mfinkle) (use needinfo?) 2012-09-12 05:20:37 PDT
(In reply to Chris AtLee [:catlee] from comment #17)
> How are we going to get users back on the nightly train?

IMO, the easiest way might be to use some redirection rules on the server to point all incoming requests to "en-US".

Thoughts?
Comment 19 Scoobidiver (away) 2012-09-12 05:30:25 PDT
(In reply to Chris AtLee [:catlee] from comment #17)
> How are we going to get users back on the nightly train?
An add-on hotfix?
Comment 20 Thomas Stache 2012-09-14 14:05:23 PDT
(In reply to Thomas Stache from comment #13)
> The old updater made it impossible to stay on the en-US build, when Android
> is on another language. What does this "update.locale" file contain?
> In the end Fennec should stay on the original locale, no matter what, like
> desktop Firefox.

After a automatic update the locale still changes from English to the system locale. Someone mentioned "multi builds". Can Fennec be configured via prefs to be English?
Comment 21 Axel Hecht [:Pike] 2012-09-14 14:42:33 PDT
Setting the locale explicitly is bad for startup, so that's not available no more. There are single-locale builds for nightly and aurora, if you're keen to use fx in a specific language.
Comment 22 Thomas Stache 2012-09-14 14:46:44 PDT
But is it okay for the updater to use the system locale code for the update check URL, or should it use the binary's locale (which is what I want)? Why does an automatic update *change* my locale?
Comment 23 Alexander L. Slovesnik 2012-09-14 15:03:21 PDT
(In reply to Axel Hecht [:Pike] from comment #21)
> There are single-locale builds for nightly and aurora, if you're keen
> to use fx in a specific language.
Do we really have single-locale builds for nightly and aurora? I can not find them.
http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/latest-mozilla-central-android-l10n/ and http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/latest-mozilla-central-android-l10n/ are empty and http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/latest-mozilla-central-android/ and http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/latest-mozilla-aurora-android/ contain only multi-locale builds.
Comment 24 Thomas Stache 2012-09-14 15:07:11 PDT
What I download from nightly.mozilla.org runs in English, after one update the result runs in German. What's changing?
Comment 25 Axel Hecht [:Pike] 2012-09-14 15:08:45 PDT
Grmpf, I can't find l10n nightlies and auroras, too, file a bug, please?
Comment 26 Chris AtLee [:catlee] 2012-09-15 08:49:14 PDT
Here are the locales with more than 100 hits since sept 5th:

da-DK 100
es-MX 101
fi-FI 103
pt-PT 106
sk 109
de-CH 125
de-AT 169
ja 182
fr 192
es-US 213
ko-KR 264
pl-PL 280
en-AU 296
sv-SE 307
nl-NL 308
pt-BR 364
it-IT 488
en-CA 582
de 656
ru-RU 700
fr-FR 991
es-ES 1009
ru 1691
ja-JP 1782
en-GB 2824
de-DE 2953
zh-TW 4196
zh-CN 23951
en-US 9391999

I've added symlinks for en-CA, en-GB and en-AU to en-US (which is the multilocale build). Which other locales should be updated to the latest en-US (multilocale) build?
Comment 27 Aki Sasaki [:aki] 2012-09-15 12:26:44 PDT
(In reply to Thomas Stache from comment #24)
> What I download from nightly.mozilla.org runs in English, after one update
> the result runs in German. What's changing?

I think nightly.mozilla.org is pointing to en-US.
http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/latest-mozilla-central-android/en-US/fennec-18.0a1.en-US.android-arm.apk

The link should point to the multi:
http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/latest-mozilla-central-android/fennec-18.0a1.multi.android-arm.apk

That means you're installing en-US, which is getting updated to the multilocale.  We should start off pointing at multi.
Comment 28 Aki Sasaki [:aki] 2012-09-15 12:43:08 PDT
https://bugzilla.mozilla.org/show_bug.cgi?id=791482
Comment 29 Axel Hecht [:Pike] 2012-09-17 08:02:19 PDT
I guess we can put stranded folks on the multi by default. Also +1 to make that the default offering on nightly.m.o.

Is there a bug about the en-US becoming multi on update?
Comment 30 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-09-17 08:33:04 PDT
Comment on attachment 659738 [details] [diff] [review]
Use contents of update.locale file in update URL on Android

[Approval Request Comment]
Necessary dependency for bug 786380
Comment 31 Aki Sasaki [:aki] 2012-09-17 10:29:44 PDT
(In reply to Axel Hecht [:Pike] from comment #29)
> I guess we can put stranded folks on the multi by default. Also +1 to make
> that the default offering on nightly.m.o.
> 
> Is there a bug about the en-US becoming multi on update?

Currently we're using the en-US update channel as the multilocale channel for any products/branches that have multilocale builds; if we want to separate the two, we'd have to support a separate multilocale channel.
Comment 32 Chris AtLee [:catlee] 2012-09-17 14:05:45 PDT
I'm going to symlink the following locales to en-US as well:

it-IT -> en-US 488
pl-PL -> en-US 280
ja-JP -> en-US 1782
de-CH -> en-US 125
nl-NL -> en-US 308
de-AT -> en-US 169
da-DK -> en-US 100
ru-RU -> en-US 700
fi-FI -> en-US 103
ko-KR -> en-US 264
de-DE -> en-US 2953
fr-FR -> en-US 991

These users currently aren't getting updates, and we have no way of knowing if they were on a single locale build or the multilocale build before. The counts are the # of hits to AUS for that locale from sept 5-12.
Comment 33 Alex Keybl [:akeybl] 2012-09-17 14:54:25 PDT
(In reply to James Willcox (:snorp) (jwillcox@mozilla.com) from comment #30)
> Comment on attachment 659738 [details] [diff] [review]
> Use contents of update.locale file in update URL on Android
> 
> [Approval Request Comment]
> Necessary dependency for bug 786380

We'll discuss bug 786380 tomorrow, and a decision about uplift of this bug will happen at the same time.
Comment 34 Scoobidiver (away) 2012-09-20 14:29:52 PDT
Pushed to Aurora: http://hg.mozilla.org/releases/mozilla-aurora/rev/a62178800150

Note You need to log in before you can comment on or make changes to this bug.