Closed Bug 789846 Opened 12 years ago Closed 12 years ago

Loading forever on http://www.lemonde.fr/ since Firefox 17

Categories

(Core :: Graphics: ImageLib, defect)

17 Branch
x86
Windows 7
defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla19
Tracking Status
firefox17 + verified
firefox18 + verified

People

(Reporter: alice0775, Assigned: khuey)

References

Details

(Keywords: regression)

Attachments

(1 file)

Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/f31d1aa89848
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120909030609

This is spun off from Bug 789800.

Steps to reproduce:
1. Start a fresh profile.
2. Open http://www.lemonde.fr/proche-orient/portfolio/2012/09/08/a-alep-un-nouveau-bombardement-meurtrier-de-l-aviation-gouvernementale_1757609_3218.html


Actual result:
 Notice the website is loading in loop "live.lmde.fr"

Expected result:
 The loading should be completed normally.

Regression window(m-c)
good=2012-08-15
bad=2012-08-16
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=86ee4deea55b&tochange=50e4ff05741e

In local build:
Last Good: 55b5cab554b5 (incl. d5e42dcb36fd+d67c02074ced)
First Bad: 54f586a529ae (incl. d5e42dcb36fd+d67c02074ced)

Triggered by:
54f586a529ae	Kyle Huey — Bug 697230: Part 3 - Make style images block onload. r=bz
I can't reproduce this.
Keywords: testcase-wanted
Oh, ok.  I didn't see that there was a more specific link than the front page.
Keywords: testcase-wanted
"Transferring data from live.lemde.fr..." tooltip is looping.
Kyle - we're less than a week from putting 17 on Beta channel, where's this falling in your priorities over the coming weeks?
Yes, in addition LeMonde.fr is the 1st online newspaper in France. :D
(In reply to Lukas Blakk [:lsblakk] from comment #4)
> Kyle - we're less than a week from putting 17 on Beta channel, where's this
> falling in your priorities over the coming weeks?

I'm digging in here.  I originally thought it was a site issue, but now I'm pretty sure it's our bug.
This is an imagelib bug.  Patch shortly.
Component: Style System (CSS) → ImageLib
Attached patch PatchSplinter Review
Attachment #669301 - Flags: review?(justin.lebar+bug)
Comment on attachment 669301 [details] [diff] [review]
Patch

jdm is going to haaaaate you
Attachment #669301 - Flags: review?(justin.lebar+bug) → review+
Comment on attachment 669301 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 697230
User impact if declined: Some pages will fail to load properly (because the onload event will never fire)
Testing completed (on m-c, etc.): Manual testing on the regressed site, will be on m-c by the time this approval request is considered
Risk to taking this patch (and alternatives if risky): Low risk.  The patch is pretty straightforward.
String or UUID changes made by this patch: none
Attachment #669301 - Flags: approval-mozilla-beta?
Attachment #669301 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/1f0548aecd6d
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
Thanks, it's fixed for me on lemonde.fr with the latest nightly.
Attachment #669301 - Flags: approval-mozilla-beta?
Attachment #669301 - Flags: approval-mozilla-beta+
Attachment #669301 - Flags: approval-mozilla-aurora?
Attachment #669301 - Flags: approval-mozilla-aurora+
Reproduced the issue on Nightly 2012-10-01.
Verified fixed on Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0b6
(In reply to Paul Silaghi [QA] from comment #16)
> Reproduced the issue on Nightly 2012-10-01.
> Verified fixed on Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0
> Firefox/17.0b6

I verified for FF 18b2 builds:

Windows 7 x64:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0 (20121128060531)

Ubuntu x32
Mozilla/5.0 (X11; Linux i686; rv:18.0) Gecko/20100101 Firefox/18.0 (20121128060531)

Mac OS 10.8
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:18.0) Gecko/20100101 Firefox/18.0 (20121128060531)

I couldn't reproduce this issue useing new profile, so Paul please set flag as Verified for FF18.
(In reply to Paul Silaghi [QA] from comment #16)
> Reproduced the issue on Nightly 2012-10-01.
> Verified fixed on Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0
> Firefox/17.0b6

I verified for FF 18b2 builds:

Windows 7 x64:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0 (20121128060531)

I couldn't reproduce this issue useing new profile, so Paul please set flag as Verified for FF18.
Verified fixed based on comment 18. Thanks MarioMi !
Status: RESOLVED → VERIFIED
this problem occurs again.

go to https://www.lemonde.fr/smart-cities/portfolio/2018/09/09/la-defense-1958-2018-soixante-ans-de-transformations-en-images_5352380_4811534.html

then

FF loads without an end the slideshow.

no problem with chrome
i forgot : FF 62.0 with opensuse leap 15.0
> this problem occurs again.

Please file a new bug with details, since chances are it's a different underlying issue?

Please do include various pertinent details (e.g. whether this can be reproduced with a clean profile, whether there are any extensions installed, etc) , because I just tried to reproduce in Firefox 62 with a clean profile and I can't: the page loads and then stops loading; the slideshow works fine.
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: