Last Comment Bug 789859 - Toolbar notification icons don't close on second click.
: Toolbar notification icons don't close on second click.
Status: RESOLVED FIXED
[Fx17]
:
Product: Firefox
Classification: Client Software
Component: SocialAPI (show other bugs)
: unspecified
: x86_64 Windows 7
: P1 normal (vote)
: Firefox 18
Assigned To: Mark Hammond [:markh]
:
Mentors:
: 790104 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-09 22:08 PDT by Mark Hammond [:markh]
Modified: 2012-09-25 11:41 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Add consumeoutsideclicks attribute (807 bytes, patch)
2012-09-11 23:49 PDT, Mark Hammond [:markh]
jaws: review+
gavin.sharp: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Mark Hammond [:markh] 2012-09-09 22:08:50 PDT
* Click once in the toolbar notification area - notification opens
* Click again in the same area:

** Expected: The notification area closes and stays closed.
** Actual: The notification area closes, then immediately re-opens.

This is possibly Windows only.
Comment 1 Jared Wein [:jaws] (please needinfo? me) 2012-09-10 05:26:51 PDT
I'm pretty sure (untested), that |consumeoutsideclicks="true"| needs to be set on the panel to fix this.

See http://mxr.mozilla.org/mozilla-central/source/browser/base/content/browser.xul#359 and http://mxr.mozilla.org/mozilla-central/source/browser/base/content/browser.xul#271 for comparison.

Mark, can you test this out?
Comment 2 Shane Caraveo (:mixedpuppy) 2012-09-10 16:28:42 PDT
*** Bug 790104 has been marked as a duplicate of this bug. ***
Comment 3 Mark Hammond [:markh] 2012-09-11 23:49:46 PDT
Created attachment 660332 [details] [diff] [review]
Add consumeoutsideclicks attribute

As usual, Jaws is right on the money!
Comment 5 Ed Morley [:emorley] 2012-09-13 13:08:25 PDT
https://hg.mozilla.org/mozilla-central/rev/db504651197a
Comment 6 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-09-25 11:41:38 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/0527322af7a6

Note You need to log in before you can comment on or make changes to this bug.