android.view.ViewRootImpl$CalledFromWrongThreadException: Only the original thread that created a view hierarchy can touch its views. at android.view.ViewRootImpl.checkThread(ViewRootImpl.java) at android.widget.ListView.setSelectionFromTop(ListView.java)

VERIFIED FIXED in Firefox 16

Status

()

Firefox for Android
Theme and Visual Design
P1
critical
VERIFIED FIXED
5 years ago
10 months ago

People

(Reporter: Scoobidiver (away), Assigned: cpeterson)

Tracking

(4 keywords)

15 Branch
Firefox 18
ARM
Android
crash, regression, reproducible, topcrash
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox15+ affected, firefox16+ fixed, firefox17+ verified, firefox18+ verified)

Details

(Whiteboard: [native-crash][STR in comment 4], crash signature)

(Reporter)

Description

5 years ago
It's #2 top crasher in 15.0.1, #9 in 17.0a2 and #20 in 18.0a1.
The stack trace is different from bug 771544 and bug 786312.

It first appeared in 18.0a1/20120906, 17.0a2/20120606 and 15.0.1.
The regression windows are:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=6705e131aeaa&tochange=0c4fa25f637b
http://hg.mozilla.org/releases/mozilla-aurora/pushloghtml?fromchange=31341ab65f0c&tochange=c2cc63c864e4
http://hg.mozilla.org/releases/mozilla-release/pushloghtml?fromchange=d470654392d9&tochange=3011a47b3812
It's a regression from bug 769894.

Here is a crash report: bp-c79418ad-e776-4894-bf4b-04eb52120911.

android.view.ViewRootImpl$CalledFromWrongThreadException: Only the original thread that created a view hierarchy can touch its views.
	at android.view.ViewRootImpl.checkThread(ViewRootImpl.java:4267)
	at android.view.ViewRootImpl.requestLayout(ViewRootImpl.java:842)
	at android.view.View.requestLayout(View.java:12815)
	at android.view.View.requestLayout(View.java:12815)
	at android.widget.AbsListView.requestLayout(AbsListView.java:1809)
	at android.widget.ListView.setSelectionFromTop(ListView.java:1930)
	at android.widget.ListView.setSelection(ListView.java:1895)
	at android.widget.ListPopupWindow.setSelection(ListPopupWindow.java:673)
	at android.widget.Spinner$DropdownPopup.show(Spinner.java:778)
	at android.widget.ListPopupWindow$ResizePopupRunnable.run(ListPopupWindow.java:1240)
	at android.os.Handler.handleCallback(Handler.java:605)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:137)
	at org.mozilla.gecko.GeckoBackgroundThread.run(GeckoBackgroundThread.java:31)

More reports at:
https://crash-stats.mozilla.com/report/list?signature=android.view.ViewRootImpl%24CalledFromWrongThreadException%3A+Only+the+original+thread+that+created+a+view+hierarchy+can+touch+its+views.+at+android.view.ViewRootImpl.checkThread%28ViewRootImpl.java%29

Comment 1

5 years ago
Assigning to Chris. Are we sure this is caused by bug 769894 as opposed to bug 788600?

We'll keep an eye on the volume to make sure this isn't a significant new top crasher.
Assignee: nobody → cpeterson
tracking-firefox15: ? → +
tracking-firefox16: ? → +
tracking-firefox17: ? → +
tracking-firefox18: ? → +
(Reporter)

Comment 2

5 years ago
(In reply to Alex Keybl [:akeybl] from comment #1)
> Assigning to Chris. Are we sure this is caused by bug 769894 as opposed to
> bug 788600?
By fixing bug 788600, this bug and all dependencies of bug 769520 including crashes have been (re-)introduced.
(Assignee)

Comment 3

5 years ago
(In reply to Alex Keybl [:akeybl] from comment #1)
> Assigning to Chris. Are we sure this is caused by bug 769894 as opposed to
> bug 788600?
> 
> We'll keep an eye on the volume to make sure this isn't a significant new
> top crasher.

This bug is likely related to, not a regression, of bug 769894. The patch for bug 769894 was fixed *a* bug, but it was mostly speculation by Sriram and me that it was the exact stack trace in bug 769894.

I don't think IME bug 788600 is related.
STR on Nightly (09/13)

Install Phony, pull up the Phony menu and scroll through it. I hit this crash each and every single.
(Reporter)

Updated

5 years ago
Keywords: reproducible
Whiteboard: [native-crash] → [native-crash][STR in comment 4]
(Assignee)

Updated

5 years ago
Priority: -- → P1
(Assignee)

Comment 5

5 years ago
Thanks, Aaron!

With your STR, I can repro with Nightly 09-13.
(Assignee)

Comment 6

5 years ago
I posted a patch on bug 786312 that should fix this bug.
Depends on: 786312
(Assignee)

Comment 7

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/9980650215af
Assignee: cpeterson → nobody
Status: NEW → ASSIGNED
status-firefox15: --- → affected
status-firefox16: --- → affected
status-firefox17: --- → affected
status-firefox18: --- → fixed
Component: General → Theme and Visual Design
Target Milestone: --- → Firefox 18
https://hg.mozilla.org/mozilla-central/rev/9980650215af
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 9

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/541adb1639bb
https://hg.mozilla.org/releases/mozilla-beta/rev/4442bb93e91a
Assignee: nobody → cpeterson
status-firefox16: affected → fixed
status-firefox17: affected → fixed
(Reporter)

Comment 10

5 years ago
There are no crashes after 18.0a1/20120918 and 17.0a2/20120918.
Status: RESOLVED → VERIFIED
status-firefox17: fixed → verified
status-firefox18: fixed → verified
You need to log in before you can comment on or make changes to this bug.